[PATCH 0/3] gnu: cl-trivia: Update to 0.1-0.8b406c3.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
P
P
Paul A. Patience wrote on 21 Apr 2022 05:06
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220421030625.271224-1-paul@apatience.com
One thing I'm not sure about in the definition of sbcl-trivia is:
should "trivia.balland2006" be part of #:asd-systems?

Also, there are various other *.test.asd files in the repository
that are not mentioned in the Guix packages.

Paul A. Patience (3):
gnu: cl-trivia: Remove input labels.
gnu: cl-trivia: Remove trailing booleans.
gnu: cl-trivia: Update to 0.1-0.8b406c3.

gnu/packages/lisp-xyz.scm | 47 ++++++++++++++++++++-------------------
1 file changed, 24 insertions(+), 23 deletions(-)

--
2.35.1
P
P
Paul A. Patience wrote on 21 Apr 2022 05:07
[PATCH 1/3] gnu: cl-trivia: Remove input labels.
(address . 55051@debbugs.gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220421030745.271304-1-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-trivia.trivial)[inputs]: Remove
labels.
(sbcl-trivia)[native-inputs, inputs]: Remove labels.
---
gnu/packages/lisp-xyz.scm | 26 +++++++++++++-------------
1 file changed, 13 insertions(+), 13 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 2e8b957c53..69382e4d4f 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6235,10 +6235,10 @@ (define-public sbcl-trivia.trivial
"0ln0sj3jry7kzbmxhnin66kpbqan1wp8wwgdbw4k29afbdblkcca"))))
(build-system asdf-build-system/sbcl)
(inputs
- `(("alexandria" ,sbcl-alexandria)
- ("closer-mop" ,sbcl-closer-mop)
- ("lisp-namespace" ,sbcl-lisp-namespace)
- ("trivial-cltl2" ,sbcl-trivial-cltl2)))
+ (list sbcl-alexandria
+ sbcl-closer-mop
+ sbcl-lisp-namespace
+ sbcl-trivial-cltl2))
(arguments
'(#:phases
(modify-phases %standard-phases
@@ -6270,16 +6270,16 @@ (define-public sbcl-trivia
(inherit sbcl-trivia.trivial)
(name "sbcl-trivia")
(native-inputs
- `(("fiveam" ,sbcl-fiveam)
- ("optima" ,sbcl-optima)))
+ (list sbcl-fiveam
+ sbcl-optima))
(inputs
- `(("alexandria" ,sbcl-alexandria)
- ("cffi" ,sbcl-cffi)
- ("cl-ppcre" ,sbcl-cl-ppcre)
- ("fare-quasiquote" ,sbcl-fare-quasiquote)
- ("iterate" ,sbcl-iterate)
- ("trivia.trivial" ,sbcl-trivia.trivial)
- ("type-i" ,sbcl-type-i)))
+ (list sbcl-alexandria
+ sbcl-cffi
+ sbcl-cl-ppcre
+ sbcl-fare-quasiquote
+ sbcl-iterate
+ sbcl-trivia.trivial
+ sbcl-type-i))
(arguments
'(#:asd-systems '("trivia"
"trivia.ppcre"
--
2.35.1
P
P
Paul A. Patience wrote on 21 Apr 2022 05:08
[PATCH 2/3] gnu: cl-trivia: Remove trailing booleans.
(address . 55051@debbugs.gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220421030745.271304-2-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-trivia.trivial,
sbcl-trivia)[arguments]: Remove trailing booleans.
---
gnu/packages/lisp-xyz.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 69382e4d4f..abb608702d 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6250,8 +6250,7 @@ (define-public sbcl-trivia.trivial
"trivia.quasiquote.asd"
"trivia.cffi.asd"
"trivia.asd"
- "trivia.test.asd"))
- #t)))))
+ "trivia.test.asd")))))))
(synopsis "Pattern matching in Common Lisp")
(description "Trivia is a pattern matching compiler that is compatible
with Optima, another pattern matching library for Common Lisp. It is meant to
@@ -6294,8 +6293,7 @@ (define-public sbcl-trivia
'("trivia.level0.asd"
"trivia.level1.asd"
"trivia.level2.asd"
- "trivia.trivial.asd"))
- #t)))))))
+ "trivia.trivial.asd")))))))))

(define-public cl-trivia
(sbcl-package->cl-source-package sbcl-trivia))
--
2.35.1
P
P
Paul A. Patience wrote on 21 Apr 2022 05:08
[PATCH 3/3] gnu: cl-trivia: Update to 0.1-0.8b406c3.
(address . 55051@debbugs.gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220421030745.271304-3-paul@apatience.com
* gnu/packages/lisp-xyz.scm (sbcl-trivia.trivial): Update to
0.1-0.8b406c3. (The version listed in the .asd files was always 0.1,
not 0.0.0.)
[arguments]: Delete trivia.fset.asd file in 'fix-build' phase.
(sbcl-trivia)[inputs]: Add sbcl-fset.
[arguments]<#:asd-systems>: Add trivia.fset.
---
gnu/packages/lisp-xyz.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index abb608702d..121c2de58b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6218,21 +6218,21 @@ (define-public ecl-fare-quasiquote
;;; Split the trivia package in two to work around the circular dependency
;;; between guicho271828/trivia and guicho271828/type-i.
(define-public sbcl-trivia.trivial
- (let ((commit "7286d5d2a4f685f1cac8370816f95276c0851111")
- (revision "3"))
+ (let ((commit "8b406c3f83521d290e97bb787d3f6c1eb3b716af")
+ (revision "0"))
(package
(name "sbcl-trivia.trivial")
- (version (git-version "0.0.0" revision commit))
+ (version (git-version "0.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/guicho271828/trivia")
(commit commit)))
- (file-name (git-file-name "trivia" version))
+ (file-name (git-file-name "cl-trivia" version))
(sha256
(base32
- "0ln0sj3jry7kzbmxhnin66kpbqan1wp8wwgdbw4k29afbdblkcca"))))
+ "0fnnjnba07qrsf82jm4q6dini7z72xabcssy5y2bqy082r07l8l7"))))
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-alexandria
@@ -6249,6 +6249,7 @@ (define-public sbcl-trivia.trivial
"trivia.ppcre.asd"
"trivia.quasiquote.asd"
"trivia.cffi.asd"
+ "trivia.fset.asd"
"trivia.asd"
"trivia.test.asd")))))))
(synopsis "Pattern matching in Common Lisp")
@@ -6276,6 +6277,7 @@ (define-public sbcl-trivia
sbcl-cffi
sbcl-cl-ppcre
sbcl-fare-quasiquote
+ sbcl-fset
sbcl-iterate
sbcl-trivia.trivial
sbcl-type-i))
@@ -6283,7 +6285,8 @@ (define-public sbcl-trivia
'(#:asd-systems '("trivia"
"trivia.ppcre"
"trivia.quasiquote"
- "trivia.cffi")
+ "trivia.cffi"
+ "trivia.fset")
#:test-asd-file "trivia.test.asd"
#:phases
(modify-phases %standard-phases
--
2.35.1
G
G
Guillaume Le Vaillant wrote on 23 Apr 2022 10:58
Re: [bug#55051] [PATCH 0/3] gnu: cl-trivia: Update to 0.1-0.8b406c3.
(name . Paul A. Patience)(address . paul@apatience.com)(address . 55051-done@debbugs.gnu.org)
87sfq4f9xu.fsf@kitej
The "trivia.balland2006" system is a dependency of the "trivia" system,
so it doesn't need to be added to 'asd-systems' as it will be compiled
automatically when compiling "trivia".

Patches pushed as 56353b72df6b987aea75a142edebd7a110e5d374 and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYmPA7Q8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+lKAD+IKnoJtN17gtpVFehu72Q6Vk6SDwqWJbSgcGj
q63NlJEA/RJxaCUaLz2mXw8zxr4OpDi39qjT7NLloA5mJV9r5zMj
=/TpV
-----END PGP SIGNATURE-----

Closed
?