[PATCH 1/2] gnu: avizo: Add 1.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Pier-Hugues Pellerin
Owner
unassigned
Submitted by
Pier-Hugues Pellerin
Severity
normal
P
P
Pier-Hugues Pellerin wrote on 20 Apr 2022 23:57
(address . guix-patches@gnu.org)(name . Pier-Hugues Pellerin)(address . ph@heykimo.com)
20220420215745.32012-1-ph@heykimo.com
Avizo is a simple notification daemon, mainly intended to be used for
multimedia keys.
---
gnu/packages/xdisorg.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index d2caee85ec..08f6f3ad69 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -3050,3 +3050,32 @@ (define-public wlsunset
that support @samp{wlr-gamma-control-unstable-v1}. It is also known as a blue
light filter or night light.")
(license license:expat)))
+
+(define-public avizo
+ (package
+ (name "avizo")
+ (version "1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/misterdanb/avizo")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02h2jbgrbl2hyq6bzwryc1r47mipgdqrdh7zi44skc25w045s6q5"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:build-type "release"))
+ (inputs
+ `(("gtk+", gtk+)))
+ (native-inputs
+ `(("vala", vala)
+ ("glib:bin", glib "bin")
+ ("gobject-introspection", gobject-introspection)
+ ("gtk-layer-shell", gtk-layer-shell)
+ ("pkg-config", pkg-config)))
+ (home-page "https://github.com/misterdanb/avizo")
+ (synopsis "Avizo notification daemon")
+ (description "Avizo is a simple notification daemon for sway, mainly intended to be used for multimedia keys.")
+ (license license:gpl3+)))

base-commit: 6db5787120d5b571836a46ab8e1abc92d1b0ef8d
--
2.35.1
P
P
Pier-Hugues Pellerin wrote on 20 Apr 2022 23:59
[PATCH 2/2] Add Pier-Hugues Pellerin to header
(address . 55046@debbugs.gnu.org)(name . Pier-Hugues Pellerin)(address . ph@heykimo.com)
20220420215950.32236-1-ph@heykimo.com
---
gnu/packages/xdisorg.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 08f6f3ad69..b531e735cc 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Pier-Hugues Pellerin <ph@heykimo.com>
;;;
;;; This file is part of GNU Guix.
;;;
--
2.35.1
L
L
Ludovic Courtès wrote on 29 Apr 2022 00:44
Re: bug#55046: [PATCH 1/2] gnu: avizo: Add 1.2
(name . Pier-Hugues Pellerin)(address . ph@heykimo.com)(address . 55046-done@debbugs.gnu.org)
87pml0akv0.fsf@gnu.org
Pier-Hugues Pellerin <ph@heykimo.com> skribis:

Toggle quote (5 lines)
> Avizo is a simple notification daemon, mainly intended to be used for
> multimedia keys.
> ---
> gnu/packages/xdisorg.scm | 29 +++++++++++++++++++++++++++++

Hi!

Pushed as 313ae43f51b6571c64642645cdc9d63e2f886114.

I took the liberty to make a couple of changes: moving it to wm.scm
(next to Sway), running ‘guix style -S inputs’ and ‘guix style’, and
adjusting the synopsis as reported by ‘guix lint’.

Let me know if anything is amiss.

Thanks!

Ludo’.
Closed
?