python-scipy breaks login on foreign distro

  • Done
  • quality assurance status badge
Details
2 participants
  • Maxim Cournoyer
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 20 Apr 2022 17:07
(address . bug-guix@gnu.org)
8735i723p7.fsf@gmail.com
Hi,

Running Guix on the top of Ubuntu, GDM refuses to log in if the package
“python-scipy” is installed and its profile sourced.

Basically, consider

mkdir -p ~/.config/guix/profiles
guix package -i python-scipy -p ~/.config/guix/profiles/python

Then also consider that the file ~/.bash_profile contains:

Toggle snippet (4 lines)
GUIX_PROFILE=~/.config/guix/profiles/python
. $GUIX_PROFILE/etc/profile

which basically export:

Toggle snippet (7 lines)
export PATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/bin${PATH:+:}$PATH"
export XDG_DATA_DIRS="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/share${XDG_DATA_DIRS:+:}$XDG_DATA_DIRS"
export GI_TYPELIB_PATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/lib/girepository-1.0${GI_TYPELIB_PATH:+:}$GI_TYPELIB_PATH"
export GUIX_PYTHONPATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/lib/python3.9/site-packages${GUIX_PYTHONPATH:+:}$GUIX_PYTHONPATH"


Well, I do not know where does the issue come from. From my
understanding, the issue is potentially because GI_TYPELIB_PATH.

Compare:

Toggle snippet (13 lines)
$ ls /usr/lib/girepository-1.0/
AccountsService-1.0.typelib PackageKitGlib-1.0.typelib UnityExtras-7.0.typelib
AppIndicator3-0.1.typelib Unity-7.0.typelib

$ ls ~/.config/guix/profiles/python/lib/girepository-1.0
cairo-1.0.typelib GIRepository-2.0.typelib Vulkan-1.0.typelib
DBus-1.0.typelib GL-1.0.typelib win32-1.0.typelib
DBusGLib-1.0.typelib GLib-2.0.typelib xfixes-4.0.typelib
fontconfig-2.0.typelib GModule-2.0.typelib xft-2.0.typelib
freetype2-2.0.typelib GObject-2.0.typelib xlib-2.0.typelib
Gio-2.0.typelib libxml2-2.0.typelib xrandr-1.3.typelib

And note that ’python-scipy’ propagates X11, for some reasons.

Toggle snippet (13 lines)
$ ls -1 ~/.config/guix/profiles/python/lib/ | grep X11
libX11.la
libX11.so
libX11.so.6
libX11.so.6.4.0
libX11-xcb.la
libX11-xcb.so
libX11-xcb.so.1
libX11-xcb.so.1.0.0



Cheers,
simon
M
M
Maxim Cournoyer wrote on 21 Apr 2022 17:40
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 55042@debbugs.gnu.org)
87zgke4f8i.fsf@gmail.com
Hi Simon,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (23 lines)
> Hi,
>
> Running Guix on the top of Ubuntu, GDM refuses to log in if the package
> “python-scipy” is installed and its profile sourced.
>
> Basically, consider
>
> mkdir -p ~/.config/guix/profiles
> guix package -i python-scipy -p ~/.config/guix/profiles/python
>
> Then also consider that the file ~/.bash_profile contains:
>
> GUIX_PROFILE=~/.config/guix/profiles/python
> . $GUIX_PROFILE/etc/profile
>
>
> which basically export:
>
> export PATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/bin${PATH:+:}$PATH"
> export XDG_DATA_DIRS="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/share${XDG_DATA_DIRS:+:}$XDG_DATA_DIRS"
> export GI_TYPELIB_PATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/lib/girepository-1.0${GI_TYPELIB_PATH:+:}$GI_TYPELIB_PATH"
> export GUIX_PYTHONPATH="${GUIX_PROFILE:-/gnu/store/qij79rxcr8jpjzh1rqv63ckajvivdxfn-profile}/lib/python3.9/site-packages${GUIX_PYTHONPATH:+:}$GUIX_PYTHONPATH"

It's probably XDG_DATA_DIRS; could you try unsetting it? See the old
bug #26202, which looks like a duplicate to me.

Thanks,

Maxim
Z
Z
zimoun wrote on 21 Apr 2022 18:09
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 55042@debbugs.gnu.org)
CAJ3okZ2exf46KPubGgh6G1tiPuXeW2R3Nzj2_GPLbMW23hTHrw@mail.gmail.com
Hi Maxim,

On Thu, 21 Apr 2022 at 17:40, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:

Toggle quote (3 lines)
> It's probably XDG_DATA_DIRS; could you try unsetting it? See the old
> bug #26202, which looks like a duplicate to me.

Indeed, it seems a duplicate. Note that I cannot reproduce on Debian,
as I wrote [1].

By unset the variable, you mean just not source any Guix profile at
login time, right?



Cheers.
simon
M
M
Maxim Cournoyer wrote on 22 Apr 2022 06:25
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 55042@debbugs.gnu.org)
87h76l4udb.fsf@gmail.com
Hi Simon,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (13 lines)
> Hi Maxim,
>
> On Thu, 21 Apr 2022 at 17:40, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> It's probably XDG_DATA_DIRS; could you try unsetting it? See the old
>> bug #26202, which looks like a duplicate to me.
>
> Indeed, it seems a duplicate. Note that I cannot reproduce on Debian,
> as I wrote [1].
>
> By unset the variable, you mean just not source any Guix profile at
> login time, right?

I forget how it works, but I think the greeter would typically read
/etc/profile or /etc/profile.d/guix.sh which sets your profile variables
such as XDG_DATA_DIRS. You could hack it temporarily to unset
XDG_DATA_DIRS after it's done sourcing these.

Easier said than accomplished, depending on the greeter.

Cheers!

Maxim
M
M
Maxim Cournoyer wrote on 8 Jun 2022 22:38
control message for bug #55042
(address . control@debbugs.gnu.org)
8735geki16.fsf@gmail.com
tags 55042 + moreinfo
quit
M
M
Maxim Cournoyer wrote on 29 Sep 2022 04:52
Re: bug#55042: python-scipy breaks login on foreign distro
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 55042-done@debbugs.gnu.org)
871qruopsq.fsf@gmail.com
Hi,

zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (10 lines)
> Hi Maxim,
>
> On Thu, 21 Apr 2022 at 17:40, Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
>
>> It's probably XDG_DATA_DIRS; could you try unsetting it? See the old
>> bug #26202, which looks like a duplicate to me.
>
> Indeed, it seems a duplicate. Note that I cannot reproduce on Debian,
> as I wrote [1].

I've tested multiple times now that the XDG_DATA_DIRS issue causing this
kind of problem has been resolved with
23aafc800c9e678662766440916449ec5bbce830.

Closing.
--
Thanks,
Maxim
Closed
?