[PATCH 0/4] Fix broken packages by PyYAML upgrade.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 14 Apr 2022 13:08
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220414110849.2088259-1-zimon.toutoune@gmail.com
Hi,

Currently, python-pyyaml-for-awscli is not used. Its use had been removed by
commit 21cd4c704e. Reuse the package to fix some others; waiting their
regular updates.

Note that the package orange is still broken. Because
python-orange-canvas-core is broken. However, note that:

Toggle snippet (13 lines)
$ ./pre-inst-env guix graph --path python-orange-canvas-core python-pyyaml
python-orange-canvas-core@0.1.24
python-qasync@0.22.0
python-pyqt@5.15.2
qtbase@5.15.2
gtk+@3.24.30
rest@0.8.1
libsoup-minimal@2.72.0
samba@4.15.3
python-markdown@3.3.4
python-pyyaml@6.0

and update it to 0.1.26 is not enough, for instance.


zimoun (4):
gnu: python-pyyaml-for-awscli: Rename and hide.
gnu: docker-compose: Use python-pyyaml@5.
gnu: conan: Use python-pyyaml@5.
gnu: ganeti: Use python-pyyaml@5.

gnu/packages/docker.scm | 2 +-
gnu/packages/package-management.scm | 2 +-
gnu/packages/python-xyz.scm | 24 +++++++++++++-----------
gnu/packages/virtualization.scm | 2 +-
4 files changed, 16 insertions(+), 14 deletions(-)


base-commit: 7d990e775e76c0a898c7d4b53691d1932fc0e6eb
--
2.35.1
Z
Z
zimoun wrote on 14 Apr 2022 13:10
[PATCH 2/4] gnu: docker-compose: Use python-pyyaml@5.
(address . 54934@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220414111039.2088906-2-zimon.toutoune@gmail.com
* gnu/packages/docker.scm (docker-compose)[inputs]: Replace python-pyyaml by
python-pyyaml-5.
---
gnu/packages/docker.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 3f52f4f8db..07731886ae 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -122,7 +122,7 @@ (define-public docker-compose
python-docopt
python-dotenv
python-jsonschema
- python-pyyaml
+ python-pyyaml-5
python-requests
python-six
python-texttable
--
2.35.1
Z
Z
zimoun wrote on 14 Apr 2022 13:10
[PATCH 1/4] gnu: python-pyyaml-for-awscli: Rename and hide.
(address . 54934@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220414111039.2088906-1-zimon.toutoune@gmail.com
* gnu/packages/python-xyz.scm (python-pyyaml-for-awscli): Rename variable to
'python-pyyaml-5', hide the package.
---
gnu/packages/python-xyz.scm | 24 +++++++++++++-----------
1 file changed, 13 insertions(+), 11 deletions(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 36e4fe5898..1938b2bfad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3941,17 +3941,19 @@ (define-public python2-pyyaml
(base32
"0pm440pmpvgv5rbbnm8hk4qga5a292kvlm1bh3x2nwr8pb5p8xv0")))))))
-(define-public python-pyyaml-for-awscli
- (package
- (inherit python-pyyaml)
- (version "5.4.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "PyYAML" version))
- (sha256
- (base32
- "0pm440pmpvgv5rbbnm8hk4qga5a292kvlm1bh3x2nwr8pb5p8xv0"))))))
+;;; Required by some packages not yet updated.
+(define-public python-pyyaml-5
+ (hidden-package
+ (package
+ (inherit python-pyyaml)
+ (version "5.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyYAML" version))
+ (sha256
+ (base32
+ "0pm440pmpvgv5rbbnm8hk4qga5a292kvlm1bh3x2nwr8pb5p8xv0")))))))
(define-public python-vine
(package
--
2.35.1
Z
Z
zimoun wrote on 14 Apr 2022 13:10
[PATCH 3/4] gnu: conan: Use python-pyyaml@5.
(address . 54934@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220414111039.2088906-3-zimon.toutoune@gmail.com
* gnu/packages/package-management.scm (conan)[propagated-inputs]: Replace
python-pyyaml by python-yyaml-5.
---
gnu/packages/package-management.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 9c5db0d608..092aa159a3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -1183,7 +1183,7 @@ (define system ,(or (%current-target-system)
python-pluginbase
python-pygments
python-pyjwt
- python-pyyaml
+ python-pyyaml-5
python-requests
python-six
python-tqdm
--
2.35.1
Z
Z
zimoun wrote on 14 Apr 2022 13:10
[PATCH 4/4] gnu: ganeti: Use python-pyyaml@5.
(address . 54934@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220414111039.2088906-4-zimon.toutoune@gmail.com
* gnu/packages/virtualization.scm (ganeti)[native-inputs]: Replace
python-pyyaml by python-pyyaml-5.
---
gnu/packages/virtualization.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index f3396e7c94..bc2523d8ec 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -830,7 +830,7 @@ (define* (wrap? file #:rest _)
("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
("python-mock" ,python-mock)
- ("python-pyyaml" ,python-pyyaml)
+ ("python-pyyaml" ,python-pyyaml-5)
("openssh" ,openssh)
("procps" ,procps)
("shelltestrunner" ,shelltestrunner)
--
2.35.1
R
R
Ricardo Wurmus wrote on 14 Apr 2022 15:19
Re: [bug#54934] [PATCH 0/4] Fix broken packages by PyYAML upgrade.
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 54934@debbugs.gnu.org)
87o813vm1p.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (3 lines)
> Note that the package orange is still broken. Because
> python-orange-canvas-core is broken.

I don’t understand. It builds just fine here. I tested on commit
b0dd06bd0caea46a852248ab48ab2e6aaff57752.

How is it broken?

--
Ricardo
Z
Z
zimoun wrote on 14 Apr 2022 15:28
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 54934@debbugs.gnu.org)
CAJ3okZ1nLfZRuy3GKaRDnZEY9suKMi4WJ54vA2samxw_zbjWKA@mail.gmail.com
On Thu, 14 Apr 2022 at 15:20, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (6 lines)
> > Note that the package orange is still broken. Because
> > python-orange-canvas-core is broken.
>
> I don’t understand. It builds just fine here. I tested on commit
> b0dd06bd0caea46a852248ab48ab2e6aaff57752.

I have not tested on this one since it is very recent ;-)

CommitDate: Thu Apr 14 14:53:17 2022 +0200

but it fails with 7d990e775e76c0a898c7d4b53691d1932fc0e6eb.


Toggle quote (2 lines)
> How is it broken?

R
R
Ricardo Wurmus wrote on 14 Apr 2022 16:00
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 54934@debbugs.gnu.org)
87fsmfvk5n.fsf@elephly.net
zimoun <zimon.toutoune@gmail.com> writes:

Toggle quote (19 lines)
> On Thu, 14 Apr 2022 at 15:20, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> > Note that the package orange is still broken. Because
>> > python-orange-canvas-core is broken.
>>
>> I don’t understand. It builds just fine here. I tested on commit
>> b0dd06bd0caea46a852248ab48ab2e6aaff57752.
>
> I have not tested on this one since it is very recent ;-)
>
> CommitDate: Thu Apr 14 14:53:17 2022 +0200
>
> but it fails with 7d990e775e76c0a898c7d4b53691d1932fc0e6eb.
>
>
>> How is it broken?
>
> Like this <https://ci.guix.gnu.org/build/644998/details>

I cannot reproduce this. I also ran “guix build
/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv” on ci.guix.gnu.org to
see if I can reproduce the failure there, but it succeeded.

--
Ricardo
Z
Z
zimoun wrote on 14 Apr 2022 17:07
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 54934@debbugs.gnu.org)
864k2vzoti.fsf@gmail.com
Hi,

On Thu, 14 Apr 2022 at 16:00, Ricardo Wurmus <rekado@elephly.net> wrote:

Toggle quote (4 lines)
> I cannot reproduce this. I also ran “guix build
> /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv” on ci.guix.gnu.org to
> see if I can reproduce the failure there, but it succeeded.

Well, it is orthogonal with the submission, but for the record:

Toggle snippet (26 lines)
$ guix build /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv\
--no-grafts --check

[...]

test_context_menu_delete (orangecanvas.canvas.items.tests.test_graphicstextitem.TestGraphicsTextItem) ... Traceback (most recent call last):
File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 137, in contextMenuEvent
QGraphicsTextItem_contextMenuEvent(self, event)
File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 144, in QGraphicsTextItem_contextMenuEvent
menu = createStandardContextMenu(self, event.pos(), event.widget())
File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 290, in createStandardContextMenu
enabled=canPaste(),
File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 187, in canPaste
return mime.hasFormat("text/plain") or mime.hasFormat("text/html")
AttributeError: 'NoneType' object has no attribute 'hasFormat'
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test") exit-status: #f term-signal: 6 stop-signal: #f>
phase `check' failed after 1.6 seconds
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with signal 6
builder for `/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv' failed with exit code 1
build of /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv failed
View build log at '/var/log/guix/drvs/aj/4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv.bz2'.
guix build: error: build of `/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv' failed


Cheers,
simon
L
L
Ludovic Courtès wrote on 28 Apr 2022 00:11
Re: bug#54934: [PATCH 0/4] Fix broken packages by PyYAML upgrade.
(name . zimoun)(address . zimon.toutoune@gmail.com)
87tuaefa7y.fsf@gnu.org
Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (5 lines)
> gnu: python-pyyaml-for-awscli: Rename and hide.
> gnu: docker-compose: Use python-pyyaml@5.
> gnu: conan: Use python-pyyaml@5.
> gnu: ganeti: Use python-pyyaml@5.

I had to adjust the first one (since python-pyyaml-for-awscli was
removed recently) and drop the last one (since ganeti was fixed in the
meantime), but at last the remaining 3 patches are now applied.

Thanks, and apologies for the delay!

Ludo’.
Closed
?