[patch] Add Liquid War 6

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • zamfofex
Owner
unassigned
Submitted by
zamfofex
Severity
normal
Z
Z
zamfofex wrote on 14 Apr 2022 12:00
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
1383010778.267330.1649930429294@privateemail.com

Toggle diff (56 lines)
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index de398c297f..8765f70761 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -70,6 +70,7 @@
;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
+;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -140,6 +141,7 @@ (define-module (gnu packages games)
#:use-module (gnu packages golang)
#:use-module (gnu packages gperf)
#:use-module (gnu packages graphics)
+ #:use-module (gnu packages graphviz)
#:use-module (gnu packages gsasl)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages gtk)
@@ -12647,3 +12649,35 @@ (define-public fheroes2
Magic II (aka HOMM2) game engine. It requires assets and game resources to
play; it will look for them at @file{~/.local/share/fheroes2} folder.")
(license license:gpl2)))
+
+(define-public liquidwar6
+ (package
+ (name "liquidwar6")
+ (version "0.6.3902")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/liquidwar6/"
+ "liquidwar6-" version ".tar.gz"))
+ (sha256
+ (base32 "1976nnl83d8wspjhb5d5ivdvdxgb8lp34wp54jal60z4zad581fn"))))
+ (inputs
+ (list guile-2.0 zlib expat sqlite ncurses readline curl doxygen python-2
+ libxslt perl graphviz glu libcaca
+ (sdl-union (list sdl sdl-image sdl-ttf sdl-mixer))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list
+ "--enable-allinone"
+ "CFLAGS=-Wno-error"
+ (string-append "CPPFLAGS="
+ "-I" (search-input-directory %build-inputs "include/SDL")))))
+ (synopsis "Liquid War 6 is a unique multiplayer wargame.")
+ (description
+ (string-append
+ "Liquid War 6 is a unique multiplayer wargame. Your army is a blob of "
+ "liquid and you have to try and eat your opponents. Rules are very "
+ "simple yet original, they have been invented by Thomas Colcombet."))
+ (home-page "https://www.gnu.org/software/liquidwar6/")
+ (license license:gpl3+)))
L
L
Ludovic Courtès wrote on 29 Apr 2022 23:14
(name . zamfofex)(address . zamfofex@twdb.moe)(address . 54933-done@debbugs.gnu.org)
87ilqr618x.fsf@gnu.org
Hi,

zamfofex <zamfofex@twdb.moe> skribis:

Toggle quote (5 lines)
> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index de398c297f..8765f70761 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm

Applied with mostly cosmetic changes:

Toggle quote (5 lines)
> + (inputs
> + (list guile-2.0 zlib expat sqlite ncurses readline curl doxygen python-2
> + libxslt perl graphviz glu libcaca
> + (sdl-union (list sdl sdl-image sdl-ttf sdl-mixer))))

I passed it through ‘guix style’ and moved ‘doxygen’ to ‘native-inputs’
as suggested by ‘guix lint’.

Toggle quote (8 lines)
> + (arguments
> + '(#:configure-flags
> + (list
> + "--enable-allinone"
> + "CFLAGS=-Wno-error"
> + (string-append "CPPFLAGS="
> + "-I" (search-input-directory %build-inputs "include/SDL")))))

I used a gexp and ‘this-package-input’here.

Toggle quote (6 lines)
> + (description
> + (string-append
> + "Liquid War 6 is a unique multiplayer wargame. Your army is a blob of "
> + "liquid and you have to try and eat your opponents. Rules are very "
> + "simple yet original, they have been invented by Thomas Colcombet."))

I changed that to a literal string:


For future patches please take a look at:


In particular, please use ‘git format-patch’ and possibly ‘git
send-email’ to send patches. That ensures the commit log and authorship
are preserved and makes the reviewer’s life easier. :-)

Thanks!

Ludo’.
Closed
?