[PATCH 2/3] gnu: nomad-optimizer: Remove trailing booleans.

  • Done
  • quality assurance status badge
Details
2 participants
  • Liliana Marie Prikler
  • Paul A. Patience
Owner
unassigned
Submitted by
Paul A. Patience
Severity
normal
Merged with
P
P
Paul A. Patience wrote on 12 Apr 2022 20:57
(address . guix-patches@gnu.org)(name . Paul A. Patience)(address . paul@apatience.com)
20220412185712.67292-2-paul@apatience.com
* gnu/packages/maths.scm (nomad-optimizer)[arguments]: Remove trailing
booleans.
---
gnu/packages/maths.scm | 9 +++------
1 file changed, 3 insertions(+), 6 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6a6ac22a3b..b68cb966c2 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1994,8 +1994,7 @@ (define-public nomad-optimizer
(("^( +os_include_dirs = ).*" _ prefix)
(string-append prefix "[\"../../src\"]\n"))
(("^(installed_lib_dir = ).*" _ prefix)
- (string-append prefix "\"" out "/lib\"\n"))))
- #t))
+ (string-append prefix "\"" out "/lib\"\n"))))))

;; Fix the tests so they run in out-of-source builds.
(add-after 'fix-sources-for-build 'fix-sources-for-tests
@@ -2060,8 +2059,7 @@ (define-public nomad-optimizer
(string-append builddir "/src/nomad ")))
(for-each
(lambda (f) (fix-exe-path dir f))
- '("param1.txt" "param2.txt" "param3.txt" "param10.txt"))))
- #t))
+ '("param1.txt" "param2.txt" "param3.txt" "param10.txt"))))))

;; The information in the .egg-info file is not kept up to date.
(add-after 'install 'delete-superfluous-egg-info
@@ -2070,8 +2068,7 @@ (define-public nomad-optimizer
(site-packages inputs outputs)
"/PyNomad-0.0.0-py"
(python-version (assoc-ref inputs "python"))
- ".egg-info"))
- #t)))))
+ ".egg-info")))))))
(home-page "https://www.gerad.ca/nomad/")
(synopsis "Nonlinear optimization by mesh-adaptive direct search")
(description
--
2.35.1
L
L
Liliana Marie Prikler wrote on 13 Apr 2022 12:12
(address . control@debbugs.gnu.org)
2ff0ad66b0e37bcdb104736e6dfcbc7168cc864c.camel@ist.tugraz.at
merge 54890 54891 54892
thanks
?