[PATCH] gnu: Add r-xcir.

  • Done
  • quality assurance status badge
Details
2 participants
  • M?d?lin Ionel Patra?cu
  • Ricardo Wurmus
Owner
unassigned
Submitted by
M?d?lin Ionel Patra?cu
Severity
normal
M
M
M?d?lin Ionel Patra?cu wrote on 11 Apr 2022 16:03
(address . guix-patches@gnu.org)
20220411140335.16135-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioconductor.scm (r-xcir): New variable.
---
gnu/packages/bioconductor.scm | 37 ++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ce1e23f0bf..d78fcdce32 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2017, 2018, 2019, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Peter Lo <peterloleungyau@gmail.com>
-;;; Copyright © 2020, 2021 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2020, 2021, 2022 M?d?lin Ionel Patra?cu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2020 Jakub K?dzio?ka <kuba@kadziolka.net>
;;; Copyright © 2021 Hong Li <hli@mdc-berlin.de>
;;; Copyright © 2021 Tim Howes <timhowes@lavabit.com>
@@ -5100,6 +5100,41 @@ (define-public r-vsn
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+;; This package doesn't have a release yet.
+(define-public r-xcir
+ (let ((commit "4e51efe9980056e7fe274224da0173fcfaf2edd7") (revision "1"))
+ (package
+ (name "r-xcir")
+ (version (git-version "1.7.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/SRenan/XCIR")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0pb2fnpwlimw2p43ygy56pwj90h1l7yz2npqm3ypzp3bgld9b8n5"))))
+ (properties `((upstream-name . "XCIR")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-biomart
+ r-biostrings
+ r-data-table
+ r-ggplot2
+ r-iranges
+ r-readxl
+ r-s4vectors
+ r-seqminer
+ r-variantannotation))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/SRenan/XCIR")
+ (synopsis "Analysis of X chromosome inactivation")
+ (description
+ "This package @code{XCIR} is a R package that offers models and tools
+for subject level analysis of X chromosome inactivation (XCI) and XCI-escape
+inference.")
+ (license license:gpl2))))
+
(define-public r-xina
(package
(name "r-xina")
--
2.34.0
R
R
Ricardo Wurmus wrote on 14 Apr 2022 15:11
(address . 54856-done@debbugs.gnu.org)
87sfqfvme9.fsf@elephly.net
Thanks for the patch!

I changed this a little: it’s better to fetch the code from the official
Bioconductor git repository. I took the latest commit from the
RELEASE_3_14 branch. This corresponded to version 1.8.0.

I also changed the description a little.

--
Ricardo
Closed
?