[PATCH] gnu: lsof: Fix invalid G-Expression.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brian Kubisiak
  • Ludovic Courtès
Owner
unassigned
Submitted by
Brian Kubisiak
Severity
normal
B
B
Brian Kubisiak wrote on 8 Apr 2022 22:30
(address . guix-patches@gnu.org)
20220408203034.oot2hkhnhurhjs7r@peregrine
Cross-compiling lsof is failing with an "invalid G-expression input"
error. Fix this by using a quoted list.

* gnu/packages/lsof.scm (lsof): Fix invalid G-Expression.
---
gnu/packages/lsof.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index be7bf43646..5f413483f4 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -55,7 +55,7 @@ (define-public lsof
(lambda _
(setenv "LSOF_CC" ,(cc-for-target))
,@(if (%current-target-system)
- (list (setenv "LINUX_CONF_CC" "gcc"))
+ '((setenv "LINUX_CONF_CC" "gcc"))
'())
(setenv "LSOF_MAKE" "make")
--
2.34.0
L
L
Ludovic Courtès wrote on 8 Apr 2022 23:07
(name . Brian Kubisiak)(address . brian@kubisiak.com)(address . 54801-done@debbugs.gnu.org)
8735inb7yf.fsf@gnu.org
Hi,

Brian Kubisiak <brian@kubisiak.com> skribis:

Toggle quote (5 lines)
> Cross-compiling lsof is failing with an "invalid G-expression input"
> error. Fix this by using a quoted list.
>
> * gnu/packages/lsof.scm (lsof): Fix invalid G-Expression.

Good catch; applied.

Toggle quote (3 lines)
> ,@(if (%current-target-system)
> - (list (setenv "LINUX_CONF_CC" "gcc"))

Ouch, glad it wasn’t (delete-file-recursively "/").

Thanks!

Ludo’.
Closed
?