[PATCH] gnu: Add python-verspec.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vincent Prat
Owner
unassigned
Submitted by
Vincent Prat
Severity
normal
V
V
Vincent Prat wrote on 8 Apr 2022 16:32
(address . guix-patches@gnu.org)
CAH9Ak7JEV2a7R9d+Bh3m7ceA3MMxjMJQpZEUpY0TcryMeqbhNw@mail.gmail.com

From 6358a97915e91a49eb9fff85729a60e58ff920d2 Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 8 Apr 2022 16:29:38 +0200
Subject: [PATCH] gnu: Add python-verspec.

* gnu/packages/python.xyz.scm (python-verspec): New variable.
---
gnu/packages/python-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55705ab2ea..bd503b2480 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29364,3 +29364,31 @@ writing STL files. It supports both the text and binary forms of STL.")
database from the asyncio (PEP-3156/tulip) framework. It wraps
asynchronous features of the Psycopg database driver.")
(license license:bsd-3)))
+
+(define-public python-verspec
+ (package
+ (name "python-verspec")
+ (version "0.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "verspec" version))
+ (sha256
+ (base32
+ "07n06wv85fm4vl1ird2mja0823js3x322wgs9gdnq1djjyk4ql64"))))
+ (build-system python-build-system)
+ (native-inputs (list python-coverage python-flake8 python-mypy
+ python-pretend python-pytest))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "touch" "test/__init__.py")
+ (invoke "pytest")))))))
+ (home-page "https://github.com/jimporter/verspec")
+ (synopsis "Flexible version handling for Python")
+ (description
+ "Python library for handling software versions and specifiers, adapted
+from the packaging package.")
+ (license (list license:bsd-2 license:asl2.0))))
--
2.30.2
L
L
Ludovic Courtès wrote on 15 Apr 2022 18:48
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 54792-done@debbugs.gnu.org)
87v8va2sz8.fsf@gnu.org
Vincent Prat <vprat@deeplinks.com> skribis:

Toggle quote (7 lines)
> From 6358a97915e91a49eb9fff85729a60e58ff920d2 Mon Sep 17 00:00:00 2001
> From: Vincent Prat <vprat@deeplinks.com>
> Date: Fri, 8 Apr 2022 16:29:38 +0200
> Subject: [PATCH] gnu: Add python-verspec.
>
> * gnu/packages/python.xyz.scm (python-verspec): New variable.

Applied with the changes below, as per

Thanks,
Ludo’.
Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2278d7fa85..b3187f97be 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29489,8 +29489,8 @@ (define-public python-verspec
(home-page "https://github.com/jimporter/verspec")
(synopsis "Flexible version handling for Python")
(description
- "Python library for handling software versions and specifiers, adapted
-from the packaging package.")
+ "This Python library handles software versions and specifiers. It is
+adapted from the @code{packaging} package.")
(license (list license:bsd-2 license:asl2.0))))
(define-public python-shtab
Closed
?