[PATCH] gnu: Add python-shtab.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vincent Prat
Owner
unassigned
Submitted by
Vincent Prat
Severity
normal
V
V
Vincent Prat wrote on 8 Apr 2022 15:44
(address . guix-patches@gnu.org)
CAH9Ak7JjdnmwH7Xnzn1XkoXMRD3b_1=PO7z2Dk07e99R6OaA8g@mail.gmail.com

From be2415cffa689af8cb6d5f507b9c597cf24a9f94 Mon Sep 17 00:00:00 2001
From: Vincent Prat <vprat@deeplinks.com>
Date: Fri, 8 Apr 2022 15:11:21 +0200
Subject: [PATCH] gnu: Add python-shtab.

* gnu/packages/python-xyz.scm (python-shtab): New variable.
---
gnu/packages/python-xyz.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55705ab2ea..8026a75536 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29364,3 +29364,37 @@ writing STL files. It supports both the text and binary forms of STL.")
database from the asyncio (PEP-3156/tulip) framework. It wraps
asynchronous features of the Psycopg database driver.")
(license license:bsd-3)))
+
+(define-public python-shtab
+ (package
+ (name "python-shtab")
+ (version "1.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "shtab" version))
+ (sha256
+ (base32 "127mymfm7r0hddk2vknqq34fj6dirj6ip990i3g4isx0lsd7pnsc"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list bash
+ python-pytest
+ python-pytest-cov
+ python-pytest-timeout
+ python-setuptools-scm
+ python-wheel))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace
+ 'check
+ (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest")))))))
+ (home-page "https://github.com/iterative/shtab")
+ (synopsis "Automagic shell tab completion for Python CLI applications")
+ (description
+ "This package automatically generates shell tab completion scripts for
+Python CLI apps.")
+ (license license:asl2.0)))
--
2.30.2
L
L
Ludovic Courtès wrote on 15 Apr 2022 18:42
(name . Vincent Prat)(address . vprat@deeplinks.com)(address . 54791-done@debbugs.gnu.org)
87zgkm2t8p.fsf@gnu.org
Hi,

Vincent Prat <vprat@deeplinks.com> skribis:

Toggle quote (7 lines)
> From be2415cffa689af8cb6d5f507b9c597cf24a9f94 Mon Sep 17 00:00:00 2001
> From: Vincent Prat <vprat@deeplinks.com>
> Date: Fri, 8 Apr 2022 15:11:21 +0200
> Subject: [PATCH] gnu: Add python-shtab.
>
> * gnu/packages/python-xyz.scm (python-shtab): New variable.

Applied, thanks!

Ludo’.
Closed
?