[PATCH 0/3] Add r-copykat and dependencies

  • Done
  • quality assurance status badge
Details
2 participants
  • Ricardo Wurmus
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 8 Apr 2022 16:58
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220408145829.3344728-1-zimon.toutoune@gmail.com
Hi,

I hope that all is fine.


Cheers,
simon

zimoun (3):
gnu: Add r-paralleldist.
gnu: Add r-dlm.
gnu: Add r-copykat.

gnu/packages/bioinformatics.scm | 38 +++++++++++++++++++++++
gnu/packages/cran.scm | 53 +++++++++++++++++++++++++++++++++
2 files changed, 91 insertions(+)


base-commit: 09ec1d65613e111a3ee2cbeda350441e058deb8f
--
2.34.0
Z
Z
zimoun wrote on 8 Apr 2022 16:59
[PATCH 1/3] gnu: Add r-paralleldist.
(address . 54790@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220408145954.3345224-1-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-paralleldist): New variable.
---
gnu/packages/cran.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index be77a57f28..b9ea1144f2 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1074,6 +1074,39 @@ (define-public r-pacman
functions which can speed up workflow.")
(license license:gpl2)))
+(define-public r-paralleldist
+ (package
+ (name "r-paralleldist")
+ (version "0.2.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "parallelDist" version))
+ (sha256
+ (base32 "01ly4hxwa64a0ya5gla8rvv72s9mcknsfznivjkh937pbjwb7iih"))))
+ (properties `((upstream-name . "parallelDist")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-rcpp r-rcpparmadillo r-rcppparallel))
+ (home-page "https://github.com/alexeckert/parallelDist")
+ (synopsis "Parallel Distance Matrix Computation using Multiple Threads")
+ (description
+ "This package provides a fast parallelized alternative to R's native
+'dist' function to calculate distance matrices for continuous, binary, and
+multi-dimensional input matrices, which supports a broad variety of 41
+predefined distance functions from the 'stats', 'proxy' and 'dtw' R packages,
+as well as user- defined functions written in C++. For ease of use, the
+'parDist' function extends the signature of the 'dist' function and uses the
+same parameter naming conventions as distance methods of existing R packages.
+The package is mainly implemented in C++ and leverages the 'RcppParallel'
+package to parallelize the distance computations with the help of the
+'TinyThread' library. Furthermore, the 'Armadillo' linear algebra library is
+used for optimized matrix operations during distance calculations. The
+curiously recurring template pattern (CRTP) technique is applied to avoid
+virtual functions, which improves the Dynamic Time Warping calculations while
+the implementation stays flexible enough to support different DTW step
+patterns and normalization methods.")
+ (license license:gpl2+)))
+
(define-public r-pheatmap
(package
(name "r-pheatmap")
--
2.34.0
Z
Z
zimoun wrote on 8 Apr 2022 16:59
[PATCH 2/3] gnu: Add r-dlm.
(address . 54790@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220408145954.3345224-2-zimon.toutoune@gmail.com
* gnu/packages/cran.scm (r-dlm): New variable.
---
gnu/packages/cran.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b9ea1144f2..5a852af4b7 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -659,6 +659,26 @@ (define-public r-clipr
the system clipboards.")
(license license:gpl3)))
+(define-public r-dlm
+ (package
+ (name "r-dlm")
+ (version "1.1-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dlm" version))
+ (sha256
+ (base32 "1aksm66sfa7ipl5xgs4j5giac7q2m744wjl40mva56xn6i674h4r"))))
+ (properties `((upstream-name . "dlm")))
+ (build-system r-build-system)
+ (home-page "https://cran.r-project.org/package=dlm")
+ (synopsis "Bayesian and Likelihood Analysis of Dynamic Linear Models")
+ (description
+ "This package provides routines for Maximum likelihood, Kalman filtering
+and smoothing, and Bayesian analysis of Normal linear State Space models, also
+known as Dynamic Linear Models.")
+ (license license:gpl2+)))
+
(define-public r-zoo
(package
(name "r-zoo")
--
2.34.0
Z
Z
zimoun wrote on 8 Apr 2022 16:59
[PATCH 3/3] gnu: Add r-copykat.
(address . 54790@debbugs.gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20220408145954.3345224-3-zimon.toutoune@gmail.com
* gnu/packages/bioinformatics.scm (r-copykat): New variable.
---
gnu/packages/bioinformatics.scm | 38 +++++++++++++++++++++++++++++++++
1 file changed, 38 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 106b25a50b..e3cca9aab8 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -9138,6 +9138,44 @@ (define-public r-cellchat
communication networks from scRNA-seq data.")
(license license:gpl3))))
+(define-public r-copykat
+ (let ((commit ;no tag
+ "256de33dfc1b80a1a0ac9e098c5557f95a4e0d53")
+ (revision "0"))
+ (package
+ (name "r-copykat")
+ (version (git-version "1.0.8" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/navinlabcode/copykat")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ckyqnial3imcqlgd6xfgwk5w977l1i87sx4kdbwdvg40w0vh1j8"))))
+ (properties `((upstream-name . "copykat")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-cluster
+ r-dlm
+ r-gplots
+ r-mcmcpack
+ r-mixtools
+ r-paralleldist
+ r-rcolorbrewer))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/navinlabcode/copykat")
+ (synopsis "Inference of genomic copy number from single cell RNAseq data")
+ (description
+ "This package Copynumber KAryotyping of Tumors infers genomic copy
+number and subclonal structure of human tumors using integrative Bayesian
+approaches to identify genome-wide aneuploidy at 5MB resolution in single
+cells data. It separates tumor cells and tumor subclones from normal cells
+using high-throughput sc-RNAseq data.")
+ (license license:gpl2))))
+
(define-public sambamba
(package
(name "sambamba")
--
2.34.0
R
R
Ricardo Wurmus wrote on 11 Apr 2022 16:13
Re: [bug#54790] [PATCH 0/3] Add r-copykat and dependencies
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 54790-done@debbugs.gnu.org)
878rsbzoz7.fsf@elephly.net
Thank you for the patches!

Toggle quote (5 lines)
> zimoun (3):
> gnu: Add r-paralleldist.
> gnu: Add r-dlm.
> gnu: Add r-copykat.

I shortened the description of r-paralleldist and pushed the three
patches.

--
Ricardo
Closed
?