[PATCH] gnu: Add python-flatten-json.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Peter Polidoro
Owner
unassigned
Submitted by
Peter Polidoro
Severity
normal
P
P
Peter Polidoro wrote on 6 Apr 2022 21:22
(address . guix-patches@gnu.org)
86y20it3s1.fsf@polidoro.io
From 6f5dc31615613a4ed41fed20230609b3a4c3aa67 Mon Sep 17 00:00:00 2001
From: Peter Polidoro <peter@polidoro.io>
Date: Wed, 6 Apr 2022 15:21:14 -0400
Subject: [PATCH] gnu: Add python-flatten-json.

* gnu/packages/python-xyz.scm (python-flatten-json): New variable.
---
gnu/packages/python-xyz.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (27 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 55705ab2ea..e782407f39 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29364,3 +29364,20 @@ (define-public python-aiopg
database from the asyncio (PEP-3156/tulip) framework. It wraps
asynchronous features of the Psycopg database driver.")
(license license:bsd-3)))
+
+(define-public python-flatten-json
+ (package
+ (name "python-flatten-json")
+ (version "0.1.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flatten_json" version))
+ (sha256
+ (base32 "007m28gfs7pmz2rqqjxpial6skzw26hrfi8vrdy9agi9x0rj6dgf"))))
+ (build-system python-build-system)
+ (propagated-inputs (list python-six))
+ (home-page "https://github.com/amirziai/flatten")
+ (synopsis "Flatten JSON objects")
+ (description "Flatten JSON objects")
+ (license license:expat)))
--
2.35.1
L
L
Ludovic Courtès wrote on 29 Apr 2022 15:30
(name . Peter Polidoro)(address . peter@polidoro.io)(address . 54755-done@debbugs.gnu.org)
87k0b86mqd.fsf@gnu.org
Hi,

Peter Polidoro <peter@polidoro.io> skribis:

Toggle quote (7 lines)
>>From 6f5dc31615613a4ed41fed20230609b3a4c3aa67 Mon Sep 17 00:00:00 2001
> From: Peter Polidoro <peter@polidoro.io>
> Date: Wed, 6 Apr 2022 15:21:14 -0400
> Subject: [PATCH] gnu: Add python-flatten-json.
>
> * gnu/packages/python-xyz.scm (python-flatten-json): New variable.

Applied with the cosmetic changes below, as per

Thanks!

Ludo’.
Toggle diff (13 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3286cd0548..2bfe6745d9 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29602,5 +29602,7 @@ (define-public python-flatten-json
(propagated-inputs (list python-six))
(home-page "https://github.com/amirziai/flatten")
(synopsis "Flatten JSON objects")
- (description "Flatten JSON objects")
+ (description
+ "The @code{flatten_json} Python library flattens the hierarchy in your
+object, which can be useful if you want to force your objects into a table.")
(license license:expat)))
Closed
?