[PATCH] gnu: Add smtpmail

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Justin Veilleux
Owner
unassigned
Submitted by
Justin Veilleux
Severity
normal
J
J
Justin Veilleux wrote on 6 Apr 2022 19:17
(address . guix-patches@gnu.org)
8db52a33-c3d9-d88d-fba8-e987dc68962f@cock.li
Here is a patch to add smtpmail.

Cheers.
From c1c1dea4834c47adf7269070831696f28ffb949d Mon Sep 17 00:00:00 2001
From: terramorpha <terramorpha@cock.li>
Date: Wed, 6 Apr 2022 13:11:52 -0400
Subject: [PATCH] gnu: Add smtpmail.

* gnu/packages/mail.scm (smtpmail): New variable.
---
gnu/packages/mail.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 16569741a4..6dc8db526f 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -46,6 +46,7 @@
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2022 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4597,3 +4598,25 @@ (define-public sendgmail
all known forks, including support for non-@code{@@gmail.com} email
addresses.")
(license license:asl2.0))))
+
+(define-public smtpmail
+ (package
+ (name "smtpmail")
+ (version "0.4.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://download.savannah.nongnu.org/releases/smtpmail/smtpmail-"
+ version
+ ".tar.gz"))
+ (sha256 (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
+ (build-system gnu-build-system)
+ (home-page "https://www.nongnu.org/smtpmail/")
+ (synopsis "SMTP utility")
+ (description
+ "smtpmail is a little console-based tool for users who have no local
+mailserver on her machine. it enables these users to send their mail over a
+remote smtp server.")
+ (license license:gpl2)))
--
2.34.0
L
L
Ludovic Courtès wrote on 12 Apr 2022 23:54
(name . Justin Veilleux)(address . terramorpha@cock.li)(address . 54753-done@debbugs.gnu.org)
87k0buarwx.fsf@gnu.org
Hi,

Justin Veilleux <terramorpha@cock.li> skribis:

Toggle quote (7 lines)
> From c1c1dea4834c47adf7269070831696f28ffb949d Mon Sep 17 00:00:00 2001
> From: terramorpha <terramorpha@cock.li>
> Date: Wed, 6 Apr 2022 13:11:52 -0400
> Subject: [PATCH] gnu: Add smtpmail.
>
> * gnu/packages/mail.scm (smtpmail): New variable.

Applied with the changes below. License is ‘gpl2+’ because source file
headers says “or any later version”.

Thanks,
Ludo’.
Toggle diff (29 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 6dc8db526f..5dd7f3b33e 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4606,17 +4606,15 @@ (define-public smtpmail
(source
(origin
(method url-fetch)
- (uri
- (string-append
- "http://download.savannah.nongnu.org/releases/smtpmail/smtpmail-"
- version
- ".tar.gz"))
- (sha256 (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
+ (uri (string-append "mirror://savannah/smtpmail/smtpmail-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "08ap2l2g2avkq2jx05jy993517vvapmypg7j5cwl8gvpq436gdh5"))))
(build-system gnu-build-system)
(home-page "https://www.nongnu.org/smtpmail/")
(synopsis "SMTP utility")
(description
"smtpmail is a little console-based tool for users who have no local
-mailserver on her machine. it enables these users to send their mail over a
-remote smtp server.")
- (license license:gpl2)))
+mailserver on their machine. It enables these users to send their mail over a
+remote SMTP server.")
+ (license license:gpl2+)))
Closed
?