[PATCH] gnu: Add emacs-toodoo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Stefan Reichör
Owner
unassigned
Submitted by
Stefan Reichör
Severity
normal
S
S
Stefan Reichör wrote on 5 Apr 2022 22:35
(address . guix-patches@gnu.org)(name . Stefan Reichör)(address . stefan@xsteve.at)
20220405203516.84365-1-stefan@xsteve.at
* gnu/packages/emacs-xyz.scm (emacs-toodoo): New variable.
---
gnu/packages/emacs-xyz.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ffa45e218a..fd7226aa58 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -94,7 +94,7 @@
;;; Copyright © 2021 Yurii Kholodkov <urist.mckorobochka@gmail.com>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
-;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2021, 2022 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Eugene Klimov <lipklim@mailbox.org>
;;; Copyright © 2021 Zheng Junjie <873216071@qq.com>
@@ -12792,6 +12792,32 @@ properties are set on a heading, and when it is changing from a TODO state to
a DONE state.")
(license license:gpl3+)))
+(define-public emacs-toodoo
+ ;; Package has no release. Version is extracted from "Version:" keyword in
+ ;; main file.
+ (let ((commit "149a563863c2f728c5f903475dbce50547c51000")
+ (revision "0"))
+ (package
+ (name "emacs-toodoo")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ChanderG/toodoo.el")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00q7aym0kl03j9m66pivgy0snxcjjg402049b2wdy18kgyypfvx8"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-transient emacs-evil))
+ (home-page "https://github.com/ChanderG/toodoo.el")
+ (synopsis "Magit like interface for a simple Todo workflow built on top of Org")
+ (description "Provides a minor mode for fast and easy management
+of Todos using Org-mode and transients.")
+ (license license:asl2.0))))
+
(define-public emacs-flx
(package
(name "emacs-flx")
--
2.25.1
N
N
Nicolas Goaziou wrote on 8 Jun 2022 00:10
(name . Stefan Reichör)(address . stefan@xsteve.at)(address . 54738-done@debbugs.gnu.org)
877d5sqg4n.fsf@nicolasgoaziou.fr
Hello,

Stefan Reichör <stefan@xsteve.at> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-toodoo): New variable.

Pushed with the change below.

Thanks.

Toggle quote (9 lines)
> +(define-public emacs-toodoo
> + ;; Package has no release. Version is extracted from "Version:" keyword in
> + ;; main file.
> + (let ((commit "149a563863c2f728c5f903475dbce50547c51000")
> + (revision "0"))
> + (package
> + (name "emacs-toodoo")
> + (version (git-version "0.2" revision commit))

I made it version "0.2" since the commit you provide matches the version
bump.

Regards,
--
Nicolas Goaziou
Closed
?