[PATCH] gnu: python-gst: Fix the concatenation of install path.

  • Done
  • quality assurance status badge
Details
2 participants
  • Zhu Zihao
  • Ludovic Courtès
Owner
unassigned
Submitted by
Zhu Zihao
Severity
normal
Z
Z
Zhu Zihao wrote on 4 Apr 2022 18:21
(address . guix-patches@gnu.org)
86pmlwyfz3.fsf@163.com
python-gst install it's component to
/<prefix>/site-packagesgi/overrides, expected to install to
/<prefix>/site-packages/gi/overrides.

This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.

This is a patch to fix that issue.
-----BEGIN PGP SIGNATURE-----

iIsEARYIADMWIQRefA5qkqvnKdl/GTlmOX+E92aT+QUCYksboBUcYWxsX2J1dF9s
YXN0QDE2My5jb20ACgkQZjl/hPdmk/kU+wD9FxI1IwDI8hJnJFdwjy1x/Jbvpu1p
D3Vt0N3n6BgAGHsBAO7SV3Gec6z+e4w++egtvZSlK1xYoJOKJ+jFG8m/LmoD
=izhu
-----END PGP SIGNATURE-----

From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Tue, 5 Apr 2022 00:17:29 +0800
Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.

* gnu/packages/gstreamer.scm (python-gst):
[arguments]:
<configure-flags>: Add missing leading slash.
---
gnu/packages/gstreamer.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 8ff8e6242b..8b01c9b04b 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -1076,7 +1076,7 @@ (define-public python-gst
#:configure-flags
(list (string-append
"-Dpygi-overrides-dir="
- (python:site-packages %build-inputs %outputs) "gi/overrides"))))
+ (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
(native-inputs
(list pkg-config python))
(propagated-inputs
--
2.34.0
--
Retrieve my PGP public key:

gpg --recv-keys D47A9C8B2AE3905B563D9135BE42B352A9F6821F

Zihao
L
L
Ludovic Courtès wrote on 5 Apr 2022 20:25
(name . Zhu Zihao)(address . all_but_last@163.com)(address . 54710-done@debbugs.gnu.org)
87h777jslb.fsf@gnu.org
Zhu Zihao <all_but_last@163.com> skribis:

Toggle quote (17 lines)
> python-gst install it's component to
> /<prefix>/site-packagesgi/overrides, expected to install to
> /<prefix>/site-packages/gi/overrides.
>
> This issue is introduced in a5c2e7961c21ef8620ce4cfb3569109fbd694e1e.
>
> This is a patch to fix that issue.
>
>>From a341a2bbdef6fc0362d0e54dd66649005a81d7c9 Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Tue, 5 Apr 2022 00:17:29 +0800
> Subject: [PATCH] gnu: python-gst: Fix the concatenation of install path.
>
> * gnu/packages/gstreamer.scm (python-gst):
> [arguments]:
> <configure-flags>: Add missing leading slash.

Applied, thanks!

I added the reference to the offending commit in the commit log.

Ludo’.
Closed
?