[PATCH] gnu: emacs-elpy: Update to 1746e70.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220331025250.23435-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
[arguments]: Remove #:tests? keyword statement set to true.
---
gnu/packages/emacs-xyz.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f8a44a1fef..5250933a7f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10849,8 +10849,8 @@ (define-public emacs-highlight-indentation
(define-public emacs-elpy
;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
;; Jedi 0.18.
- (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")
- (revision "0"))
+ (let ((commit "1746e7009000b7635c0ea6f1559018143aa61642")
+ (revision "1"))
(package
(name "emacs-elpy")
(version (git-version "1.35.0" revision commit))
@@ -10862,7 +10862,7 @@ (define-public emacs-elpy
(file-name (git-file-name name version))
(sha256
(base32
- "0hg6yk0wkfh2rwcc4h0bb6m2p3dg62ja22mjpa94khq52lv1piwf"))))
+ "120xzzaa8jxls3lri6d53zq6gafnkc6d9mlg09an334kkmh8k2fc"))))
(build-system emacs-build-system)
(arguments
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
@@ -10904,7 +10904,6 @@ (define-public emacs-elpy
(mkdir-p man1)
(copy-file "docs/_build/man/elpy.1"
(string-append man1 "/elpy.1"))))))
- #:tests? #t
#:test-command '("ert-runner")))
(propagated-inputs
(list emacs-company
--
2.34.0
M
M
Maxim Cournoyer wrote on 31 Mar 2022 05:00
(name . jgart)(address . jgart@dismail.de)(address . 54645@debbugs.gnu.org)
87bkxm3jyk.fsf@gmail.com
Hello!

jgart <jgart@dismail.de> writes:

Toggle quote (16 lines)
> * gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
> [arguments]: Remove #:tests? keyword statement set to true.
> ---
> gnu/packages/emacs-xyz.scm | 7 +++----
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index f8a44a1fef..5250933a7f 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -10849,8 +10849,8 @@ (define-public emacs-highlight-indentation
> (define-public emacs-elpy
> ;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
> ;; Jedi 0.18.
> - (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")

Is there some worthy fixes in this latest version? If there are, the
comment giving the rationale for not using the stable release should be
updated to reflect why using the latest commit is necessary.

Thank you,

Maxim
M
M
Maxime Devos wrote on 31 Mar 2022 14:03
Re: [bug#54645] [PATCH] gnu: emacs-elpy: Update to 1746e70.
c94a0ababfabc20692bca1c1c382d5031f207c7d.camel@telenet.be
jgart via Guix-patches via schreef op wo 30-03-2022 om 22:52 [-0400]:
Toggle quote (2 lines)
> -         #:tests? #t

Please keep this, because tests are not run by default for emacs-build-
system. (emacs-build-system is a bit of an exception)

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYkWYgRccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7tI+AQDWTCy1kUAhZotqpcWBHHUktmVQ
Sjj1/1yY8tggfygOoAD+PcaTivfge4tGnvd7IZGlh7LLmwUGmjTmuI2q8EoGEQ8=
=nyyL
-----END PGP SIGNATURE-----


J
[PATCH v2] gnu: emacs-elpy: Update to 1746e70.
(address . 54645@debbugs.gnu.org)
20220331143304.6063-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.

Using the latest commit fixes outstanding bugs such as the following:

Hi Maxime,

Thanks for the review.

I added a comment on some of the fixes that are provided by using the latest current commit.

The previous version (8d0de31) of emacs-elpy was also using the latest commit at the time.

There was a comment about it in the let block.

WDYT?

all best,

jgart

---
gnu/packages/emacs-xyz.scm | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b733adc02f..beda1126c5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10847,10 +10847,12 @@ (define-public emacs-highlight-indentation
(license license:gpl2+))))
(define-public emacs-elpy
- ;; Use the latest commit, as it contains unreleased fixes for Python 3.9 and
- ;; Jedi 0.18.
- (let ((commit "8d0de310d41ebf06b22321a8534546447456870c")
- (revision "0"))
+ ;; Using the latest commit fixes outstanding bugs such as the following:
+ ;; https://github.com/jorgenschaefer/elpy/issues/1824
+ ;; https://github.com/jorgenschaefer/elpy/pull/1951
+ ;; https://github.com/jorgenschaefer/elpy/issues/1940
+ (let ((commit "1746e7009000b7635c0ea6f1559018143aa61642")
+ (revision "1"))
(package
(name "emacs-elpy")
(version (git-version "1.35.0" revision commit))
@@ -10862,7 +10864,7 @@ (define-public emacs-elpy
(file-name (git-file-name name version))
(sha256
(base32
- "0hg6yk0wkfh2rwcc4h0bb6m2p3dg62ja22mjpa94khq52lv1piwf"))))
+ "120xzzaa8jxls3lri6d53zq6gafnkc6d9mlg09an334kkmh8k2fc"))))
(build-system emacs-build-system)
(arguments
`(#:include (cons* "^elpy/[^/]+\\.py$" "^snippets\\/" %default-include)
--
2.34.0
M
M
Maxim Cournoyer wrote on 4 Apr 2022 05:56
(name . jgart)(address . jgart@dismail.de)(address . 54645-done@debbugs.gnu.org)
87ilrp1oxm.fsf@gmail.com
Hello,

jgart <jgart@dismail.de> writes:

Toggle quote (19 lines)
> * gnu/packages/emacs-xyz.scm (emacs-elpy): Update to 1746e70.
>
> Using the latest commit fixes outstanding bugs such as the following:
> https://github.com/jorgenschaefer/elpy/issues/1824
> https://github.com/jorgenschaefer/elpy/pull/1951
> https://github.com/jorgenschaefer/elpy/issues/1940
>
> Hi Maxime,
>
> Thanks for the review.
>
> I added a comment on some of the fixes that are provided by using the latest current commit.
>
> The previous version (8d0de31) of emacs-elpy was also using the latest commit at the time.
>
> There was a comment about it in the let block.
>
> WDYT?

LGTM. Applied as 75371f952fd800bda7e8c2fe5dac5a4fd0f87d70. Thank you!

Closing.

Maxim
Closed
?