[PATCH] gnu: solfege: Remove trailing booleans.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Liliana Marie Prikler
  • Mathieu Othacehe
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220326011538.26236-1-jgart@dismail.de
* gnu/packages/music.scm (solfege): Remove trailing booleans.
---
gnu/packages/music.scm | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 2c6b530aac..d7f0c0d39d 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2058,16 +2058,14 @@ (define-public solfege
(("/usr/bin/aplay") "aplay")
(("/usr/bin/timidity") "timidity")
(("/usr/bin/mpg123") "mpg123")
- (("/usr/bin/ogg123") "ogg123"))
- #t))
+ (("/usr/bin/ogg123") "ogg123"))))
(add-before 'build 'patch-python-shebangs
(lambda _
;; Two python scripts begin with a Unicode BOM, so patch-shebang
;; has no effect.
(substitute* '("solfege/parsetree.py"
"solfege/presetup.py")
- (("#!/usr/bin/python") (string-append "#!" (which "python"))))
- #t))
+ (("#!/usr/bin/python") (string-append "#!" (which "python"))))))
(add-before 'build 'add-sitedirs
;; .pth files are not automatically interpreted unless the
;; directories containing them are added as "sites". The directories
--
2.34.0
L
L
Liliana Marie Prikler wrote on 26 Mar 2022 10:14
5a9ca7c6593d8259f4b9d57e4f0aab7328b3b86f.camel@gmail.com
Hi jgart

Am Freitag, dem 25.03.2022 um 21:15 -0400 schrieb jgart:
Toggle quote (28 lines)
> * gnu/packages/music.scm (solfege): Remove trailing booleans.
> ---
>  gnu/packages/music.scm | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
> index 2c6b530aac..d7f0c0d39d 100644
> --- a/gnu/packages/music.scm
> +++ b/gnu/packages/music.scm
> @@ -2058,16 +2058,14 @@ (define-public solfege
>                 (("/usr/bin/aplay") "aplay")
>                 (("/usr/bin/timidity") "timidity")
>                 (("/usr/bin/mpg123") "mpg123")
> -               (("/usr/bin/ogg123") "ogg123"))
> -             #t))
> +               (("/usr/bin/ogg123") "ogg123"))))
>           (add-before 'build 'patch-python-shebangs
>             (lambda _
>               ;; Two python scripts begin with a Unicode BOM, so
> patch-shebang
>               ;; has no effect.
>               (substitute* '("solfege/parsetree.py"
>                              "solfege/presetup.py")
> -               (("#!/usr/bin/python") (string-append "#!" (which
> "python"))))
> -             #t))
> +               (("#!/usr/bin/python") (string-append "#!" (which
> "python"))))))
Questionable uses of which.

It'd also be nice if you could update arguments to be a list of G-
expressions and do all the other modernizations.

Cheers
M
M
Mathieu Othacehe wrote on 29 Mar 2022 10:57
Re: bug#54572: [PATCH] gnu: solfege: Remove trailing booleans.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87ilrx6squ.fsf_-_@gnu.org
Hey,

Toggle quote (5 lines)
> Questionable uses of which.
>
> It'd also be nice if you could update arguments to be a list of G-
> expressions and do all the other modernizations.

That can come in a follow-up patch, pushed that one in the meantime.

Thanks,

Mathieu
Closed
?