[PATCH] gnu: Add gigolo.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • tumashu
Owner
unassigned
Submitted by
tumashu
Severity
normal
T
T
tumashu wrote on 22 Mar 2022 21:52
(address . guix-patches@gnu.org)(name . Feng Shu)(address . tumashu@163.com)
20220322205229.10070-1-tumashu@163.com
From: Feng Shu <tumashu@163.com>

* gnu/packages/xfce.scm (gigolo): New variable.
---
gnu/packages/xfce.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index cdd98f2863..b58a517257 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -881,6 +881,29 @@ (define-public xfdesktop
devices and folders.")
(license gpl2+)))
+(define-public gigolo
+ (package
+ (name "gigolo")
+ (version "0.5.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://archive.xfce.org/src/apps/"
+ name "/" (version-major+minor version)
+ "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1hxv3lla567nnqxxly8xfi8fzmpcdhxb493x9hinr7szfnh1ljp3"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config intltool))
+ (inputs (list gtk+))
+ (home-page "https://www.xfce.org/")
+ (synopsis "A frontend to easily manage connections to remote filesystems")
+ (description
+ "A frontend to easily manage connections to remote filesystems using
+GIO/GVfs. It allows you to quickly connect/mount local and remote filesystems
+and manage bookmarks of such.")
+ (license gpl2+)))
+
(define-public xfce4-terminal
(package
(name "xfce4-terminal")
--
2.34.0
L
L
Ludovic Courtès wrote on 25 Mar 2022 11:57
(address . tumashu@163.com)(address . 54527-done@debbugs.gnu.org)
878rsy8fl5.fsf@gnu.org
Hi,

tumashu@163.com skribis:

Toggle quote (4 lines)
> From: Feng Shu <tumashu@163.com>
>
> * gnu/packages/xfce.scm (gigolo): New variable.

Applied with the cosmetic changes below + license change: source file
headers explicitly say “version 2”, without the “or any later version”
wording.

Thanks,
Ludo’.
Toggle diff (22 lines)
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index b58a517257..a2d8e99290 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -897,12 +897,12 @@ (define-public gigolo
(native-inputs (list pkg-config intltool))
(inputs (list gtk+))
(home-page "https://www.xfce.org/")
- (synopsis "A frontend to easily manage connections to remote filesystems")
+ (synopsis "Manage connections to remote file systems")
(description
- "A frontend to easily manage connections to remote filesystems using
-GIO/GVfs. It allows you to quickly connect/mount local and remote filesystems
-and manage bookmarks of such.")
- (license gpl2+)))
+ "Gigolo is a graphical user interface to easily manage connections to
+remote file systems using GIO/GVfs. It allows you to quickly connect/mount
+local and remote file systems and manage bookmarks of such.")
+ (license gpl2))) ;version 2 only
(define-public xfce4-terminal
(package
Closed
?