[PATCH] gnu: openfst: Update to 1.8.2

DoneSubmitted by Aurora.
Details
2 participants
  • Ludovic Courtès
  • Aurora
Owner
unassigned
Severity
normal
A
A
Aurora wrote on 21 Mar 18:32 +0100
(address . guix-patches@gnu.org)(name . Aurora)(address . rind38@disroot.org)
20220321173215.1526-2-rind38@disroot.org
---
gnu/packages/machine-learning.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index ba6a439..e2e8252 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -570,14 +570,14 @@ sample proximities between pairs of cases.")
 (define-public openfst
   (package
     (name "openfst")
-    (version "1.7.9")
+    (version "1.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.openfst.org/twiki/pub/FST/"
                                   "FstDownload/openfst-" version ".tar.gz"))
               (sha256
                (base32
-                "1pmx1yhn2gknj0an0zwqmzgwjaycapi896244np50a8y3nrsw6ck"))))
+                "0hlbdmjjf1jgsvi3d2hwni5lz3l9a5bzj6ijpbawa8a7cbrpp66y"))))
     (build-system gnu-build-system)
     (home-page "http://www.openfst.org")
     (synopsis "Library for weighted finite-state transducers")
-- 
2.30.2
A
A
Aurora wrote on 23 Mar 16:43 +0100
[PATCH v2] gnu: openfst: Update to 1.8.2, enable ngram extension
(address . 54506@debbugs.gnu.org)(name . Aurora)(address . rind38@disroot.org)
20220323154359.2684-1-rind38@disroot.org
This extension is required by some programs that depend on openfst that aren't
yet packaged.

The extension itself also depends on C++14 to build due to make_unique.
---
gnu/packages/machine-learning.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index afac56f..b13e800 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -570,15 +570,16 @@ sample proximities between pairs of cases.")
 (define-public openfst
   (package
     (name "openfst")
-    (version "1.7.9")
+    (version "1.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.openfst.org/twiki/pub/FST/"
                                   "FstDownload/openfst-" version ".tar.gz"))
               (sha256
                (base32
-                "1pmx1yhn2gknj0an0zwqmzgwjaycapi896244np50a8y3nrsw6ck"))))
+                "0hlbdmjjf1jgsvi3d2hwni5lz3l9a5bzj6ijpbawa8a7cbrpp66y"))))
     (build-system gnu-build-system)
+    (arguments '(#:configure-flags '("--enable-ngram-fsts" "CXXFLAGS=-std=c++14")))
     (home-page "http://www.openfst.org")
     (synopsis "Library for weighted finite-state transducers")
     (description "OpenFst is a library for constructing, combining,
-- 
2.30.2
A
A
Aurora wrote on 23 Mar 16:53 +0100
[PATCH v3 0/1] gnu: openfst: Update to 1.8.2, enable ngram extension
(address . 54506@debbugs.gnu.org)(name . Aurora)(address . rind38@disroot.org)
20220323155343.3109-1-rind38@disroot.org
openfst 1.8.2 already moved to C++17

Aurora (1):
gnu: openfst: Update to 1.8.2, enable ngram extension

gnu/packages/machine-learning.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

--
2.30.2
A
A
Aurora wrote on 23 Mar 16:53 +0100
[PATCH v3 1/1] gnu: openfst: Update to 1.8.2, enable ngram extension
(address . 54506@debbugs.gnu.org)(name . Aurora)(address . rind38@disroot.org)
20220323155343.3109-2-rind38@disroot.org
This extension is required by some programs that depend on openfst that aren't
yet packaged.
---
gnu/packages/machine-learning.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index afac56f..2ec461f 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -570,15 +570,16 @@ sample proximities between pairs of cases.")
 (define-public openfst
   (package
     (name "openfst")
-    (version "1.7.9")
+    (version "1.8.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://www.openfst.org/twiki/pub/FST/"
                                   "FstDownload/openfst-" version ".tar.gz"))
               (sha256
                (base32
-                "1pmx1yhn2gknj0an0zwqmzgwjaycapi896244np50a8y3nrsw6ck"))))
+                "0hlbdmjjf1jgsvi3d2hwni5lz3l9a5bzj6ijpbawa8a7cbrpp66y"))))
     (build-system gnu-build-system)
+    (arguments '(#:configure-flags '("--enable-ngram-fsts")))
     (home-page "http://www.openfst.org")
     (synopsis "Library for weighted finite-state transducers")
     (description "OpenFst is a library for constructing, combining,
-- 
2.30.2
L
L
Ludovic Courtès wrote on 15 May 22:29 +0200
Re: bug#54506: [PATCH] gnu: openfst: Update to 1.8.2
(name . Aurora)(address . rind38@disroot.org)(address . 54506-done@debbugs.gnu.org)
871qwuedz9.fsf_-_@gnu.org
Hi,

Aurora <rind38@disroot.org> skribis:

Toggle quote (8 lines)
> openfst 1.8.2 already moved to C++17
>
> Aurora (1):
> gnu: openfst: Update to 1.8.2, enable ngram extension
>
> gnu/packages/machine-learning.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)

Applied to the ‘staging’ branch, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send email to 54506@debbugs.gnu.org