[PATCH] gnu: sbcl-ningle: Update to 2e85675.

  • Done
  • quality assurance status badge
Details
3 participants
  • Guillaume Le Vaillant
  • jgart
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)
20220321163542.32583-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (sbcl-ningle): Update to 2e85675.
[arguments]: Remove custom phase that changes the name of compiled files
causing a permission denied error when loading ningle.
See this discussion:

Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>

Hi Guillaume,

Here is an upgrade to ningle that also fixes what we were discussing at

I added you as co-author. Thank you!

all best,

jgart

---
gnu/packages/lisp-xyz.scm | 32 ++++----------------------------
1 file changed, 4 insertions(+), 28 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 85f8af31bb..cbb8e1b851 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4826,8 +4826,8 @@ (define-public ecl-trivial-mimes
(sbcl-package->ecl-package sbcl-trivial-mimes))
(define-public sbcl-ningle
- (let ((commit "50bd4f09b5a03a7249bd4d78265d6451563b25ad")
- (revision "1"))
+ (let ((commit "2e85675bbb668d6ef341514fc9f22391a0f506b1")
+ (revision "2"))
(package
(name "sbcl-ningle")
(version (git-version "0.3.0" revision commit))
@@ -4839,34 +4839,10 @@ (define-public sbcl-ningle
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1bsl8cnxhacb8p92z9n89vhk1ikmij5zavk0m2zvmj7iqm79jzgw"))))
+ (base32 "0s9nn8ml1j4839rycvdjcbsynkqnhxw1zmrgpjz48smscwdf1f8p"))))
(build-system asdf-build-system/sbcl)
(arguments
- ;; TODO: pull in clack-test
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'cleanup-files)
- (delete 'cleanup)
- (add-before 'cleanup 'combine-fasls
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/sbcl"))
- (ningle-path (string-append lib "/ningle"))
- (fasl-files (find-files out "\\.fasl$")))
- (mkdir-p ningle-path)
- (let ((fasl-path (lambda (name)
- (string-append ningle-path
- "/"
- (basename name)
- "--system.fasl"))))
- (for-each (lambda (file)
- (rename-file file
- (fasl-path
- (basename file ".fasl"))))
- fasl-files))
- fasl-files)
- #t)))))
+ '(#:tests? #f))
(native-inputs
(list sbcl-prove))
(inputs
--
2.34.0
M
M
Maxime Devos wrote on 21 Mar 2022 19:40
(name . Guillaume Le Vaillant)(address . glv@posteo.net)
8d7f75a27cb69f3168753e604e9a337763dc2de8.camel@telenet.be
jgart via Guix-patches via schreef op ma 21-03-2022 om 12:35 [-0400]:
Toggle quote (2 lines)
> -       ;; TODO: pull in clack-test

Why is this comment removed? Tests are still disabled.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjjGphccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7kchAP98uvqeObIfhyTN5FI6PSZC5ocW
liFy6EO03nXIZtSTWAD8DFfboZRiwtN12OntiNmgOXBVShHrjKwgkWWpkIP5rwI=
=Sx1g
-----END PGP SIGNATURE-----


J
[PATCH v2] gnu: sbcl-ningle: Update to 2e85675.
(address . 54503@debbugs.gnu.org)
20220321185651.26145-1-jgart@dismail.de
* gnu/packages/lisp-xyz.scm (sbcl-ningle): Update to 2e85675.
[arguments]: Remove custom phase that changes the name of compiled files
causing a permission denied error when loading ningle.
See this discussion:

Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>

Hi Maxime,

Thanks for catching that. I added it back in this v2.

all best,

jgart

---
gnu/packages/lisp-xyz.scm | 32 ++++----------------------------
1 file changed, 4 insertions(+), 28 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 85f8af31bb..d6923314af 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -4826,8 +4826,8 @@ (define-public ecl-trivial-mimes
(sbcl-package->ecl-package sbcl-trivial-mimes))
(define-public sbcl-ningle
- (let ((commit "50bd4f09b5a03a7249bd4d78265d6451563b25ad")
- (revision "1"))
+ (let ((commit "2e85675bbb668d6ef341514fc9f22391a0f506b1")
+ (revision "2"))
(package
(name "sbcl-ningle")
(version (git-version "0.3.0" revision commit))
@@ -4839,34 +4839,10 @@ (define-public sbcl-ningle
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "1bsl8cnxhacb8p92z9n89vhk1ikmij5zavk0m2zvmj7iqm79jzgw"))))
+ (base32 "0s9nn8ml1j4839rycvdjcbsynkqnhxw1zmrgpjz48smscwdf1f8p"))))
(build-system asdf-build-system/sbcl)
(arguments
- ;; TODO: pull in clack-test
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'cleanup-files)
- (delete 'cleanup)
- (add-before 'cleanup 'combine-fasls
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/sbcl"))
- (ningle-path (string-append lib "/ningle"))
- (fasl-files (find-files out "\\.fasl$")))
- (mkdir-p ningle-path)
- (let ((fasl-path (lambda (name)
- (string-append ningle-path
- "/"
- (basename name)
- "--system.fasl"))))
- (for-each (lambda (file)
- (rename-file file
- (fasl-path
- (basename file ".fasl"))))
- fasl-files))
- fasl-files)
- #t)))))
+ '(#:tests? #f)) ; TODO: pull in clack-test
(native-inputs
(list sbcl-prove))
(inputs
--
2.34.0
G
G
Guillaume Le Vaillant wrote on 23 Mar 2022 09:54
(name . jgart)(address . jgart@dismail.de)(address . 54503-done@debbugs.gnu.org)
877d8lxd43.fsf@kitej
Patch pushed as 297a5b74c37fd11b4b73e353ae9ab1b7cb2ae7ac.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYjrgXA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8ebgD+J6lISpqUXwyVWefreJ7OlgPpHUQ8W9ZOR8D1
0iwx2S4A/2GdIVrQ4Nn2BaMotU0b9VUoKdSOivH+rwKDiWzrG6IJ
=2YMp
-----END PGP SIGNATURE-----

Closed
?