[PATCH] gnu: dav1d: Update to 1.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Famulari
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 18 Mar 2022 16:54
(address . guix-patches@gnu.org)
e86f1b952b7b9936ddb4c02ed478c1d7b1beec6e.1647618859.git.leo@famulari.name
* gnu/packages/video.scm (dav1d): Update to 1.0.0.
---
gnu/packages/video.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index dc05c0a222..464a8aea2f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4948,7 +4948,7 @@ (define-public shotcut
(define-public dav1d
(package
(name "dav1d")
- (version "0.9.2")
+ (version "1.0.0")
(source
(origin
(method git-fetch)
@@ -4957,7 +4957,7 @@ (define-public dav1d
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0bkps488h9s15ylvkm4fmfywgrpbw570glawpnv6khpq9n223dzl"))))
+ (base32 "0jkvb5as7danpalzlwd0w1dc9i2vijvmf39z0j6fwqvialsgnnj5"))))
(build-system meson-build-system)
(native-inputs (list nasm))
(home-page "https://code.videolan.org/videolan/dav1d")
--
2.34.0
L
L
Leo Famulari wrote on 18 Mar 2022 18:23
(address . 54451@debbugs.gnu.org)
YjTAHOema/PBfk/a@jasmine.lan
I tried building VLC with this update, because VLC and dav1d are both
projects of VideoLAN, so it's a good test.

Unfortunately, it seems that VLC is not yet ready for dav1d 1.0.0.
Compilation fails with many errors like this:

------
codec/dav1d.c:306:65: error: ‘Dav1dSettings’ has no member named ‘n_tile_threads’; did you mean ‘n_threads’?
306 | dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
| ^~~~~~~~~~~~~~
../include/vlc_messages.h:79:23: note: in definition of macro ‘msg_Generic’
79 | __func__, __VA_ARGS__)
| ^~~~~~~~~~~
codec/dav1d.c:305:5: note: in expansion of macro ‘msg_Dbg’
305 | msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
| ^~~~~~~
codec/dav1d.c:310:45: error: ‘Dav1dSettings’ has no member named ‘n_frame_threads’
310 | dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
| ^
make[4]: *** [Makefile:21741: codec/libdav1d_plugin_la-dav1d.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
demux/flac.c: In function ‘GetPacketizedBlock’:
demux/flac.c:230:17: warning: unused variable ‘i_ret’ [-Wunused-variable]
230 | int i_ret = FLAC_ParseSyncInfo( p_block->p_buffer, streaminfo, NULL, &headerinfo );
| ^~~~~
make[4]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
make[3]: *** [Makefile:28011: all-recursive] Error 1
make[3]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
make[2]: *** [Makefile:12804: all] Error 2
make[2]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
make[1]: *** [Makefile:1563: all-recursive] Error 1
make[1]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16'
make: *** [Makefile:1450: all] Error 2
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "make" arguments: ("-j" "4") exit-status: 2 term-signal: #f stop-signal: #f>
phase `build' failed after 52.2 seconds
command "make" "-j" "4" failed with status 2
builder for `/gnu/store/zs6a6l91hlw5apphqddijavx532kc4ln-vlc-3.0.16.drv' failed with exit code 1
build of /gnu/store/zs6a6l91hlw5apphqddijavx532kc4ln-vlc-3.0.16.drv failed
------
M
M
Maxim Cournoyer wrote on 9 Feb 2023 14:19
Re: bug#54451: [PATCH] gnu: dav1d: Update to 1.0.0.
(name . Leo Famulari)(address . leo@famulari.name)(address . 54451@debbugs.gnu.org)
87r0uzgema.fsf_-_@gmail.com
Hi Leo,

Leo Famulari <leo@famulari.name> writes:

Toggle quote (40 lines)
> I tried building VLC with this update, because VLC and dav1d are both
> projects of VideoLAN, so it's a good test.
>
> Unfortunately, it seems that VLC is not yet ready for dav1d 1.0.0.
> Compilation fails with many errors like this:
>
> ------
> codec/dav1d.c:306:65: error: ‘Dav1dSettings’ has no member named ‘n_tile_threads’; did you mean ‘n_threads’?
> 306 | dav1d_version(), p_sys->s.n_frame_threads, p_sys->s.n_tile_threads);
> | ^~~~~~~~~~~~~~
> ../include/vlc_messages.h:79:23: note: in definition of macro ‘msg_Generic’
> 79 | __func__, __VA_ARGS__)
> | ^~~~~~~~~~~
> codec/dav1d.c:305:5: note: in expansion of macro ‘msg_Dbg’
> 305 | msg_Dbg(p_this, "Using dav1d version %s with %d/%d frame/tile threads",
> | ^~~~~~~
> codec/dav1d.c:310:45: error: ‘Dav1dSettings’ has no member named ‘n_frame_threads’
> 310 | dec->i_extra_picture_buffers = (p_sys->s.n_frame_threads - 1);
> | ^
> make[4]: *** [Makefile:21741: codec/libdav1d_plugin_la-dav1d.lo] Error 1
> make[4]: *** Waiting for unfinished jobs....
> demux/flac.c: In function ‘GetPacketizedBlock’:
> demux/flac.c:230:17: warning: unused variable ‘i_ret’ [-Wunused-variable]
> 230 | int i_ret = FLAC_ParseSyncInfo( p_block->p_buffer, streaminfo, NULL, &headerinfo );
> | ^~~~~
> make[4]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
> make[3]: *** [Makefile:28011: all-recursive] Error 1
> make[3]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
> make[2]: *** [Makefile:12804: all] Error 2
> make[2]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16/modules'
> make[1]: *** [Makefile:1563: all-recursive] Error 1
> make[1]: Leaving directory '/tmp/guix-build-vlc-3.0.16.drv-0/vlc-3.0.16'
> make: *** [Makefile:1450: all] Error 2
> error: in phase 'build': uncaught exception:
> %exception #<&invoke-error program: "make" arguments: ("-j" "4") exit-status: 2 term-signal: #f stop-signal: #f>
> phase `build' failed after 52.2 seconds
> command "make" "-j" "4" failed with status 2
> builder for `/gnu/store/zs6a6l91hlw5apphqddijavx532kc4ln-vlc-3.0.16.drv' failed with exit code 1
> build of /gnu/store/zs6a6l91hlw5apphqddijavx532kc4ln-vlc-3.0.16.drv failed

46 weeks later, perhaps a VLC update could fix this? :-)

--
Thanks,
Maxim
L
L
Leo Famulari wrote on 12 Feb 2023 12:51
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 54451-done@debbugs.gnu.org)
Y+jS2OmH53i/47NO@jasmine.lan
On Thu, Feb 09, 2023 at 08:19:57AM -0500, Maxim Cournoyer wrote:
Toggle quote (2 lines)
> 46 weeks later, perhaps a VLC update could fix this? :-)

Yes, thanks for the reminder!

Compatibility between dav1d 1.0.0 and VLC was added in VLC 3.0.18. Also
tested in mpv.

Pushed as 126608f7a9649bc7761331a15940dd65ff773e0c
Closed
?