[PATCH] gnu: Add python-scikit-allel.

  • Done
  • quality assurance status badge
Details
2 participants
  • Efraim Flashner
  • Ludovic Courtès
Owner
unassigned
Submitted by
Efraim Flashner
Severity
normal
E
E
Efraim Flashner wrote on 16 Mar 2022 12:37
(address . guix-patches@gnu.org)(name . Efraim Flashner)(address . efraim@flashner.co.il)
856daf639aa2f6dee3f09e242179ba2fccaf22d8.1647430620.git.efraim@flashner.co.il
* gnu/packages/python-science.scm (python-scikit-allel): New variable.
---
gnu/packages/python-science.scm | 51 ++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)

Toggle diff (80 lines)
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index e3e874dac2..bb25386094 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2022 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016-2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -35,6 +35,7 @@ (define-module (gnu packages python-science)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bioinformatics)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages cpp)
@@ -307,6 +308,54 @@ (define-public python-scikit-image
"Scikit-image is a collection of algorithms for image processing.")
(license license:bsd-3)))
+(define-public python-scikit-allel
+ (package
+ (name "python-scikit-allel")
+ (version "1.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "scikit-allel" version))
+ (sha256
+ (base32 "1vg88ng6gd175gzk39iz1drxig5l91dyx398w2kbw3w8036zv8gj"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "setup.py" "build_ext" "--inplace")
+ (invoke "python" "-m" "pytest" "-v" "allel"
+ ;; AttributeError: 'Dataset' object has no attribute 'asstr'
+ "-k" (string-append
+ "not test_vcf_to_hdf5"
+ " and not test_vcf_to_hdf5_exclude"
+ " and not test_vcf_to_hdf5_rename"
+ " and not test_vcf_to_hdf5_group"
+ " and not test_vcf_to_hdf5_ann"))))))))
+ (propagated-inputs
+ (list python-dask
+ python-numpy))
+ (native-inputs
+ (list python-cython
+ ;; The following are all needed for the tests
+ htslib
+ python-h5py
+ python-hmmlearn
+ python-numexpr
+ python-pytest
+ python-scipy
+ python-setuptools-scm
+ python-zarr))
+ (home-page "https://github.com/cggh/scikit-allel")
+ (synopsis "Explore and analyze genetic variation data")
+ (description
+ "This package provides utilities for exploratory analysis of large scale
+genetic variation data.")
+ (license license:expat)))
+
(define-public python-sgp4
(package
(name "python-sgp4")

base-commit: 53d986215f629f461651e3181af0689ef5f418a2
--
2.34.0
L
L
Ludovic Courtès wrote on 18 Mar 2022 14:57
(name . Efraim Flashner)(address . efraim@flashner.co.il)(address . 54419@debbugs.gnu.org)
87ilsbqs7g.fsf@gnu.org
Hello,

Efraim Flashner <efraim@flashner.co.il> skribis:

Toggle quote (2 lines)
> * gnu/packages/python-science.scm (python-scikit-allel): New variable.

LGTM!

Ludo’.
E
E
Efraim Flashner wrote on 18 Mar 2022 15:00
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 54419-done@debbugs.gnu.org)
YjSQYTLp5KvyE0zc@3900XT
Thanks for the review. Patch pushed!

--
Efraim Flashner <efraim@flashner.co.il> ????? ?????
GPG key = A28B F40C 3E55 1372 662D 14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted
-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEEoov0DD5VE3JmLRT3Qarn3Mo9g1EFAmI0kGEACgkQQarn3Mo9
g1EoYQ/7BkZ3ETTF4MM/6BD7SjAHrjJXNfqnRIXyq7GPwY+jhxRict1VPA2HQAFR
ZZABlb9agS22M7FdNmfmJbCL3dN7G7fZpe5PU7IGgTqkDlsE8smp+donKiCRVKWn
p5ZksUATfYrI12dmsTVKIk/t5xGQXjt//h1EXYGlh4zwt2QmHA5vRUz/2RXUcVNd
0x5Sw98AnaTPp0rzkeFnmhfVjFgJKQsI+ie/A0s+HJvscP4kbZ08ZUypCcn8u9MN
WfSFZtx1TRwVDmt7dJeZed7u6Cl9QRWTJXBF9taejZLyDEp9wgii8fKIM7ZmtUUm
q5aaSlu1YsEBUVMyZbowNJyWo9hpfknpAGd+IkzOlb+m8kF4hbMDKygcaOaXvQki
6MRzu4NBvtViqEGnEOn+IEg2SknexITFhlkLx4tAKwaNcuM0VakNY6ROR2MHcqOi
c1M3BAImfggX7l9VcMmJoS9QECNhG2I78eX0BcCqs2KkLvDcQIYadRaagrGAWxjg
qitCbW0u0Fzy4jnbWvgcsCSt+Ibg3JVklOo54sZ0gIfIloZZtWb8T+7+m+zwM4yK
RLJcouIrR4F4xAbnjZxZzowCtUtHxIZwzmLz4D15ZOwomg6DWh8t3FRZodag2gP5
XNdiwDCmXFc6dwGC/g9hZztB2TjWmfGw1C+YKGA55tcmc0eJJ5o=
=21eL
-----END PGP SIGNATURE-----


Closed
?