[PATCH] gnu: sicp: Update to bda03f7.

  • Done
  • quality assurance status badge
Details
2 participants
  • Guillaume Le Vaillant
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220316001105.982-1-jgart@dismail.de
* gnu/packages/scheme.scm (sicp): Update to bda03f7.
[arguments]: Remove trailing `#t`.
---
gnu/packages/scheme.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 378a5b4959..4c2eba93f1 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -470,10 +470,10 @@ (define-public chibi-scheme
(license bsd-3)))
(define-public sicp
- (let ((commit "225c172f9b859902a64a3c5dd5e1f9ac1a7382de"))
+ (let ((commit "bda03f79d6e2e8899ac2b5ca6a3732210e290a79"))
(package
(name "sicp")
- (version (string-append "20170703-1." (string-take commit 7)))
+ (version (string-append "20180718-2." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -481,7 +481,7 @@ (define-public sicp
(commit commit)))
(sha256
(base32
- "0bhdrdc1mgdjdsg4jksq9z6x129f3346jbf3zir2a0dfmsj6m10n"))
+ "0mng7qrj2dvssyffr9ycnf4a5k0kadp4dslq7mc5bhzq1qxyjs2w"))
(file-name (string-append name "-" version "-checkout"))))
(build-system trivial-build-system)
(native-inputs `(("gzip" ,gzip)
@@ -506,8 +506,7 @@ (define-public sicp
(string-append info-dir "/sicp.info")
(string-append source "/sicp-pocket.texi"))
(for-each (cut invoke "gzip" "-9n" <>)
- (find-files info-dir))
- #t))))
+ (find-files info-dir))))))
(home-page "https://sarabander.github.io/sicp")
(synopsis "Structure and Interpretation of Computer Programs")
(description "Structure and Interpretation of Computer Programs (SICP) is
--
2.35.1
J
[PATCH v2] gnu: sicp: Update to bda03f7.
(address . 54413@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220316041639.28551-1-jgart@dismail.de
* gnu/packages/scheme.scm (sicp): Update to bda03f7.
[version]: Use git-version function.
[arguments]: Remove trailing `#t`.

Hi,

This v2 uses git-version function.

all best,

jgart
---
gnu/packages/scheme.scm | 9 ++++-----
1 file changed, 4 insertions(+), 5 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 378a5b4959..4c2eba93f1 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -470,10 +470,10 @@ (define-public chibi-scheme
(license bsd-3)))
(define-public sicp
- (let ((commit "225c172f9b859902a64a3c5dd5e1f9ac1a7382de"))
+ (let ((commit "bda03f79d6e2e8899ac2b5ca6a3732210e290a79"))
(package
(name "sicp")
- (version (string-append "20170703-1." (string-take commit 7)))
+ (version (string-append "20180718-2." (string-take commit 7)))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -481,7 +481,7 @@ (define-public sicp
(commit commit)))
(sha256
(base32
- "0bhdrdc1mgdjdsg4jksq9z6x129f3346jbf3zir2a0dfmsj6m10n"))
+ "0mng7qrj2dvssyffr9ycnf4a5k0kadp4dslq7mc5bhzq1qxyjs2w"))
(file-name (string-append name "-" version "-checkout"))))
(build-system trivial-build-system)
(native-inputs `(("gzip" ,gzip)
@@ -506,8 +506,7 @@ (define-public sicp
(string-append info-dir "/sicp.info")
(string-append source "/sicp-pocket.texi"))
(for-each (cut invoke "gzip" "-9n" <>)
- (find-files info-dir))
- #t))))
+ (find-files info-dir))))))
(home-page "https://sarabander.github.io/sicp")
(synopsis "Structure and Interpretation of Computer Programs")
(description "Structure and Interpretation of Computer Programs (SICP) is
--
2.35.1
J
[PATCH v3] gnu: sicp: Update to bda03f7.
(address . 54413@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220316041807.28997-1-jgart@dismail.de
* gnu/packages/scheme.scm (sicp): Update to bda03f7.
[version]: Use git-version function.
[arguments]: Remove trailing `#t`.

Oops, never committed the changes.

Here's v3

all best,

jgart

---
gnu/packages/scheme.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 378a5b4959..59c2ec7dcb 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -470,10 +470,11 @@ (define-public chibi-scheme
(license bsd-3)))
(define-public sicp
- (let ((commit "225c172f9b859902a64a3c5dd5e1f9ac1a7382de"))
+ (let ((commit "bda03f79d6e2e8899ac2b5ca6a3732210e290a79")
+ (revision "2"))
(package
(name "sicp")
- (version (string-append "20170703-1." (string-take commit 7)))
+ (version (git-version "20180718" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -481,7 +482,7 @@ (define-public sicp
(commit commit)))
(sha256
(base32
- "0bhdrdc1mgdjdsg4jksq9z6x129f3346jbf3zir2a0dfmsj6m10n"))
+ "0mng7qrj2dvssyffr9ycnf4a5k0kadp4dslq7mc5bhzq1qxyjs2w"))
(file-name (string-append name "-" version "-checkout"))))
(build-system trivial-build-system)
(native-inputs `(("gzip" ,gzip)
@@ -506,8 +507,7 @@ (define-public sicp
(string-append info-dir "/sicp.info")
(string-append source "/sicp-pocket.texi"))
(for-each (cut invoke "gzip" "-9n" <>)
- (find-files info-dir))
- #t))))
+ (find-files info-dir))))))
(home-page "https://sarabander.github.io/sicp")
(synopsis "Structure and Interpretation of Computer Programs")
(description "Structure and Interpretation of Computer Programs (SICP) is
--
2.35.1
G
G
Guillaume Le Vaillant wrote on 17 Mar 2022 10:11
(name . jgart)(address . jgart@dismail.de)(address . 54413-done@debbugs.gnu.org)
871qz12b9j.fsf@kitej
Patch pushed as bae2201a8ddf789dff3f625327f5b2d0a686bc77.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCYjL7eA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j/EuQD/eotJHBDdVH/8NCYnZ0SmFIXGouErIjq2e6nJ
Q2ny5XoA/20N+3Vea46p+VqUaA/PZVrAGhV6VuHd1jc5H43b0MyG
=j8hH
-----END PGP SIGNATURE-----

Closed
?