[PATCH] gnu: Add python-pytest-pudb.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Ludovic Courtès
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 7 Mar 2022 06:37
(address . guix-patches@gnu.org)
20220307053725.25934-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-pytest-pudb): New variable.

Co-authored-by: BonfaceKilz <me@bonfacemunyoki.com>
---
gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d3d7b7160d..ba0c8489f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28704,6 +28704,41 @@ (define-public pudb
keyboard-friendly package.")
(license license:expat)))
+(define-public python-pytest-pudb
+ ;; PyPi does not include tests
+ (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")
+ (revision "0"))
+ (package
+ (name "python-pytest-pudb")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wronglink/pytest-pudb")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32 "1c0pypxx3y8w7s5bz9iy3w3aablnhn81rnhmb0is8hf2qpm6k3w0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list pudb))
+ (native-inputs
+ (list python-pytest))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
+ (home-page "https://github.com/wronglink/pytest-pudb")
+ (synopsis "Pytest PuDB debugger integration")
+ (description
+ "@code{python-pytest-pudb} provides PuDB debugger integration based on
+ pytest PDB integration.")
+ (license license:expat))))
+
(define-public python-iwlib
(package
(name "python-iwlib")
--
2.35.1
J
[PATCH v2] gnu: Add python-pytest-pudb.
(address . 54284@debbugs.gnu.org)(name . jgart)(address . jgart@dismail.de)
20220315214147.17096-1-jgart@dismail.de
* gnu/packages/check.scm (python-pytest-pudb): New variable.

Hi, here is a version 2 of the patch that puts it in the check module instead.

all best,

jgart

---
gnu/packages/check.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c66ec4722f..970a8196b5 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3082,6 +3082,41 @@ (define-public python-pytest-dependency
skipped if any of the dependencies did fail or has been skipped.")
(license license:asl2.0)))
+(define-public python-pytest-pudb
+ ;; PyPi does not include tests
+ (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")
+ (revision "0"))
+ (package
+ (name "python-pytest-pudb")
+ (version "0.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wronglink/pytest-pudb")
+ (commit commit)))
+ (file-name (string-append name "-" commit))
+ (sha256
+ (base32 "1c0pypxx3y8w7s5bz9iy3w3aablnhn81rnhmb0is8hf2qpm6k3w0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list pudb))
+ (native-inputs
+ (list python-pytest))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
+ (home-page "https://github.com/wronglink/pytest-pudb")
+ (synopsis "Pytest PuDB debugger integration")
+ (description
+ "@code{python-pytest-pudb} provides PuDB debugger integration based on
+ pytest PDB integration.")
+ (license license:expat))))
+
(define-public python-pytest-datadir
(package
(name "python-pytest-datadir")
--
2.35.1
L
L
Ludovic Courtès wrote on 18 Mar 2022 23:16
Re: bug#54284: [PATCH] gnu: Add python-pytest-pudb.
(name . jgart)(address . jgart@dismail.de)(address . 54284@debbugs.gnu.org)
8735jeq53w.fsf_-_@gnu.org
Hi,

jgart <jgart@dismail.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/check.scm (python-pytest-pudb): New variable.

[...]

Toggle quote (8 lines)
> +(define-public python-pytest-pudb
> + ;; PyPi does not include tests
> + (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")
> + (revision "0"))
> + (package
> + (name "python-pytest-pudb")
> + (version "0.7.0")

Could you clarify in a comment how this commit relates to this version
number? You can remove the ‘revision’ variable, since it’s unused.

Toggle quote (2 lines)
> + (file-name (string-append name "-" commit))

Rather: (file-name (git-file-name name version)).

Toggle quote (4 lines)
> + (synopsis "Pytest PuDB debugger integration")
> + (description
> + "@code{python-pytest-pudb} provides PuDB debugger integration based on
> + pytest PDB integration.")
^
Extra space here.

IWBN if you could add a sentence or two explaining what that means. :-)

Last, please pass it through ‘guix style’.

Could you send an updated patch?

TIA!

Ludo’.
J
[PATCH v2] gnu: Add python-pytest-pudb.
(address . 54284@debbugs.gnu.org)
20220319015104.17516-1-jgart@dismail.de
* gnu/packages/check.scm (python-pytest-pudb): New variable.

Hi Ludo,

Thanks for the review. It is much appreciated.

Here's v2.

Let me know if there is anything else to fix. I think I got it all...

all best,

jgart

https://whereis.???/
gemini://whereis.???/

---
gnu/packages/check.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c66ec4722f..335ab7ab11 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3082,6 +3082,41 @@ (define-public python-pytest-dependency
skipped if any of the dependencies did fail or has been skipped.")
(license license:asl2.0)))
+(define-public python-pytest-pudb
+ ;; PyPi does not include tests
+ (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5"))
+ (package
+ (name "python-pytest-pudb")
+ ;; Version mentioned in setup.py version field.
+ (version "0.7.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wronglink/pytest-pudb")
+ (commit commit)))
+ (file-name (git-file-name name commit))
+ (sha256
+ (base32
+ "1c0pypxx3y8w7s5bz9iy3w3aablnhn81rnhmb0is8hf2qpm6k3w0"))))
+ (build-system python-build-system)
+ (propagated-inputs (list pudb))
+ (native-inputs (list python-pytest))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs outputs tests? #:allow-other-keys)
+ (when tests?
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-v")))))))
+ (home-page "https://github.com/wronglink/pytest-pudb")
+ (synopsis "Pytest PuDB debugger integration")
+ (description
+ "@code{python-pytest-pudb} provides PuDB debugger integration based
+on pytest PDB integration. For example, the software developer can
+call pudb by running @code{py.test --pudb} from the command line or by
+including @code{pudb.set_trace} in their test file(s).")
+ (license license:expat))))
+
(define-public python-pytest-datadir
(package
(name "python-pytest-datadir")
--
2.34.0
M
M
Maxime Devos wrote on 20 Mar 2022 09:16
835449298073c4bc05da5e1e280f1a1d87719bab.camel@telenet.be
jgart via Guix-patches via schreef op di 15-03-2022 om 17:41 [-0400]:
Toggle quote (2 lines)
> +  (let ((commit "a6b3d2f4d35e558d72bccff472ecde9c9d9c69e5")

This commit is only used in a single place, so don't see any need
to put it in a variable.

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYjbi9hccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7r4mAP9QiYqcvfrlNIktYHCJYR0xZOl8
0EbxPvP4wtJRwrCfawEA+F/XTH7Enz/8emO7Th/atn6fRyzrI32Blkmt1udVbQc=
=4q7S
-----END PGP SIGNATURE-----


L
L
Ludovic Courtès wrote on 21 Mar 2022 14:37
Re: [PATCH v2] gnu: Add python-pytest-pudb.
(name . jgart)(address . jgart@dismail.de)(address . 54284-done@debbugs.gnu.org)
87lex3juke.fsf@gnu.org
Hi jgart,

jgart <jgart@dismail.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/check.scm (python-pytest-pudb): New variable.

Perfect. Applied, thanks!

Ludo’.
Closed
?