[PATCH] gnu: Add python-bip39.

  • Done
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 3 Mar 2022 10:11
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220303091104.26336-1-attila@lendvai.name
* gnu/packages/python-xyz.scm (python-bip39): New variable.
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (36 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c05502388e..ea6694972e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1242,6 +1242,29 @@ (define-public python-bidict
for working with bidirectional mappings in Python.")
(license license:mpl2.0)))
+(define-public python-bip39
+ (package
+ (name "python-bip39")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "bip39" version))
+ (sha256
+ (base32 "18m7d3gi7vj2zi0bl1z7m0nhcj6i8j9vj4vil276siagnpkv64ry"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/de-centralized-systems/python-bip39/")
+ (synopsis "Self-contained and simple BIP39 implementation in Python")
+ (description
+ "This package provides a self-contained and simple BIP39
+implementation written in Python. It includes a @code{bip39.py} executable.
+
+BIP39 is a standardized mapping between binary data (the @emph{entropy}),
+and a list of words that are easier to remember for humans (the
+@emph{mnemonic}).")
+ (license license:expat)))
+
(define-public python-bitarray
(package
(name "python-bitarray")
--
2.34.0
R
R
Ricardo Wurmus wrote on 4 Apr 2022 10:32
(address . 54229-done@debbugs.gnu.org)
87sfqt2qp4.fsf@elephly.net
Thank you for the patch! I pushed it with commit
4d336ecf200e1011eed6433f4a74e3fa7272b3af.

--
Ricardo
Closed
?