[PATCH] gnu: shepherd: Convert to build from git instead of a release.

  • Done
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Maxime Devos
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 1 Mar 2022 09:59
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220301085912.31958-1-attila@lendvai.name
This increases the flexibility to inherit from this package, and use a
non-yet-released version of Shepherd in a Guix build while working on
Shepherd.
---
gnu/packages/admin.scm | 37 ++++++++++++++++++++++---------------
1 file changed, 22 insertions(+), 15 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c8f91aab0d..59a37c5ace 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -270,26 +270,33 @@ (define-public shepherd
(package
(name "shepherd")
(version "0.8.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/shepherd/shepherd-"
- version ".tar.gz"))
- (sha256
- (base32
- "0x9zr0x3xvk4qkb6jnda451d5iyrl06cz1bjzjsm0lxvjj3fabyk"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Build with -O1 to work around <https://bugs.gnu.org/48368>.
- (substitute* "Makefile.in"
- (("compile --target")
- "compile -O1 --target"))))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/shepherd.git/")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "109ha9rk4ycqcmx9cddlbym92c3fvbwp12q9p42h8sg8vr367w5j"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; Build with -O1 to work around <https://bugs.gnu.org/48368>.
+ (substitute* "Makefile.am"
+ (("compile --target")
+ "compile -O1 --target"))))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--localstatedir=/var")
#:make-flags '("GUILE_AUTO_COMPILE=0")))
(native-inputs
- (list pkg-config
+ (list autoconf
+ automake
+ gettext-minimal
+ help2man
+ pkg-config
+ texinfo
;; This is the Guile we use as a cross-compiler...
guile-3.0))
(inputs
--
2.34.0
A
A
Attila Lendvai wrote on 1 Mar 2022 10:09
(No Subject)
(name . 54207@debbugs.gnu.org)(address . 54207@debbugs.gnu.org)
Cu44cG-pHDDr8WZ4U13pDFWR54uME8ZWwTxHWvMxzK5OzIiqttbaDfAWvhF2Es1PL1iKR8WvwlVm3OpnHe1NM_7K8ElUMlzFwRsUKHQGqx0=@lendvai.name
i forgot to check this:

$ ./pre-inst-env guix refresh --list-dependent shepherd | tr " " "\n" | wc -l
1349

i.e. this should go into staging.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“Not all men want to dominate a large number of other persons, but those who do affect the life of many.”
— Silvano Arieti (1914–1981)
M
M
Maxime Devos wrote on 1 Mar 2022 11:18
Re: [bug#54207] [PATCH] gnu: shepherd: Convert to build from git instead of a release.
bb1efdbf41460cf19760f656cd9ac185804f6325.camel@telenet.be
Attila Lendvai schreef op di 01-03-2022 om 09:59 [+0100]:
Toggle quote (7 lines)
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.savannah.gnu.org/git/shepherd.git/")
> +             (commit (string-append "v" version))))

Perhaps add a comment about why it a git origin is used
and autoconf & friends are in native-inputs?

;; Build from git and add Autotools inputs, to make developing
;; the shepherd easier

Also, to avoid having to go through staging for adding a feature
to the shepherd to use in Guix, WDYT of defining a package variant
of shepherd for use in Guix, and modifying the default Guix in
'shepherd-configuration' appropriately?

(define-public shepherd-for-guix
(let ((commit ...)
(revision ...))
(package
(inherit shepherd)
(source [the git origin])
(version (git-version ...))
(native-inputs
(modify-inputs (package-inputs shepherd)
(prepend [autotools packages])))
(description [a package variant for use in Guix]))))

Greetings,
Maxime.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYh3zExccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7oWQAP0cQ/F9z9/rcqEAm/0ULVSFo2vr
ChVRdMLbIQHmqiBnQQEAzVxBy6zJPOSbcAeILNF/G/9vvhqDdwk/t/MDRU9lBgQ=
=Jp+P
-----END PGP SIGNATURE-----


A
A
Attila Lendvai wrote on 1 Mar 2022 19:49
(No Subject)
(name . 54207-close@debbugs.gnu.org)(address . 54207-close@debbugs.gnu.org)
KoFUF9Wi4wtBjPA5ZdFXFUXchTQaQcDtEVZ-bBOTjU627iXeao1bC5aRQ3v3MvB4BQ8H-G4uLbTCZ9z9fP2cjJlE13Vbdrx78TcFVOj07PM=@lendvai.name
closing this, because i've accidentall sent the suggested solution as a separate issue:


--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“What's done to children, they will do to society.”
— Karl A. Menninger (http://psychohistory.com/)
?