[PATCH] gnu: matterbridge: update to 1.24.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Denis 'GNUtoo' Carikli
  • Ludovic Courtès
Owner
unassigned
Submitted by
Denis 'GNUtoo' Carikli
Severity
normal
D
D
Denis 'GNUtoo' Carikli wrote on 24 Feb 2022 21:40
(address . guix-patches@gnu.org)(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)
20220224204048.25280-1-GNUtoo@cyberdimension.org
* gnu/packages/messaging.scm (matterbridge): Update to 1.24.0.

Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
---
gnu/packages/messaging.scm | 59 ++++++++++++++++++++++++++++----------
1 file changed, 44 insertions(+), 15 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 779d37fdd7..d23ec998db 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3109,23 +3109,52 @@ (define-public zulip-term
(define-public matterbridge
(package
(name "matterbridge")
- (version "1.22.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/42wim/matterbridge")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "07rgdc4v043fhzsalmlhickqizk6xjlpjkzn6l5v9ryp5gmv580z"))))
- (build-system go-build-system)
+ (version "1.24.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/42wim/matterbridge")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0cd70x9685162c0imdici1ipl9lziq700wzyb5bsg610wfak3ms7"))))
+ ;; Using the go-build-system results in the same error message
+ ;; than in the bug 1551[1]. So we fix it by running go build
+ ;; manually in the git repository as-is as this is the solution
+ ;; given to that bug by the matterbridge developers.
+ ;; [1]https://github.com/42wim/matterbridge/issues/1551
+ (build-system gnu-build-system)
(arguments
- `(#:import-path "github.com/42wim/matterbridge"
- #:unpack-path "github.com/42wim/matterbridge"))
+ `(#:phases (modify-phases %standard-phases
+ (delete 'configure)
+ (replace 'build
+ (lambda _
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref %outputs "out") "/bin"))
+ (invoke "go" "build" "-v" "-x")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref %outputs "out")
+ "/bin"))
+ (invoke "go" "test" "-v" "-x"))))
+ (replace 'install
+ (lambda _
+ (setenv "GOCACHE"
+ (string-append (getcwd) "/go-build"))
+ (setenv "GOBIN"
+ (string-append (assoc-ref %outputs "out") "/bin"))
+ (invoke "go" "install" "-v" "-x"))))))
+ (native-inputs (list go))
(synopsis "Bridge together various messaging networks and protocols")
- (description "Relays messages between different channels from various
+ (description
+ "Relays messages between different channels from various
messaging networks and protocols. So far it supports mattermost, IRC, gitter,
xmpp, slack, discord, telegram, rocketchat, twitch, ssh-chat, zulip, whatsapp,
keybase, matrix, microsoft teams, nextcloud, mumble, vk and more with REST
--
2.35.1
L
L
Ludovic Courtès wrote on 16 Mar 2022 15:43
(name . Denis 'GNUtoo' Carikli)(address . GNUtoo@cyberdimension.org)(address . 54148-done@debbugs.gnu.org)
8735jidkl1.fsf@gnu.org
Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> skribis:

Toggle quote (4 lines)
> * gnu/packages/messaging.scm (matterbridge): Update to 1.24.0.
>
> Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>

Applied with the minor tweaks below (referring to the phase parameters
instead of the ‘%outputs’ global variable), thanks!

Ludo’.
Toggle diff (38 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 6283db02bf..f78719575a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -3128,27 +3128,27 @@ (define-public matterbridge
`(#:phases (modify-phases %standard-phases
(delete 'configure)
(replace 'build
- (lambda _
+ (lambda* (#:key outputs #:allow-other-keys)
(setenv "GOCACHE"
(string-append (getcwd) "/go-build"))
(setenv "GOBIN"
- (string-append (assoc-ref %outputs "out") "/bin"))
+ (string-append (assoc-ref outputs "out") "/bin"))
(invoke "go" "build" "-v" "-x")))
(replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
+ (lambda* (#:key outputs tests? #:allow-other-keys)
(when tests?
(setenv "GOCACHE"
(string-append (getcwd) "/go-build"))
(setenv "GOBIN"
- (string-append (assoc-ref %outputs "out")
+ (string-append (assoc-ref outputs "out")
"/bin"))
(invoke "go" "test" "-v" "-x"))))
(replace 'install
- (lambda _
+ (lambda* (#:key outputs #:allow-other-keys)
(setenv "GOCACHE"
(string-append (getcwd) "/go-build"))
(setenv "GOBIN"
- (string-append (assoc-ref %outputs "out") "/bin"))
+ (string-append (assoc-ref outputs "out") "/bin"))
(invoke "go" "install" "-v" "-x"))))))
(native-inputs (list go))
(synopsis "Bridge together various messaging networks and protocols")
Closed
?