[PATCH] gnu: services: Also accept 'undefined in maybe-foo? constructs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Attila Lendvai
  • Ludovic Courtès
Owner
unassigned
Submitted by
Attila Lendvai
Severity
normal
A
A
Attila Lendvai wrote on 31 Jan 2022 16:27
(address . guix-patches@gnu.org)(name . Attila Lendvai)(address . attila@lendvai.name)
20220131152753.19880-1-attila@lendvai.name
This is a temporary bandaid until a more explicit handling of maybe types is
introduced for configurations (e.g. by using srfi-189). Until then, with this
change it becomes possible to have definitions like:

(define-maybe string (no-serialization))

(define-configuration my-configuration
(my-field (maybe-string))
(no-serialization))

i.e. without providing a default value for MY-FIELD.
---
gnu/services/configuration.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/services/configuration.scm b/gnu/services/configuration.scm
index 0de350a4df..c5f276eab5 100644
--- a/gnu/services/configuration.scm
+++ b/gnu/services/configuration.scm
@@ -141,7 +141,9 @@ (define (define-maybe-helper serialize? prefix syn)
(id #'stem #'serialize-maybe- #'stem))))
#`(begin
(define (maybe-stem? val)
- (or (eq? val 'disabled) (stem? val)))
+ (or (eq? val 'disabled)
+ (eq? val 'undefined)
+ (stem? val)))
#,@(if serialize?
(list #'(define (serialize-maybe-stem field-name val)
(if (stem? val)
--
2.34.0
L
L
Ludovic Courtès wrote on 1 Feb 2022 10:53
(name . Attila Lendvai)(address . attila@lendvai.name)(address . 53663@debbugs.gnu.org)
87ilty6hgd.fsf@gnu.org
Hi!

Attila Lendvai <attila@lendvai.name> skribis:

Toggle quote (28 lines)
> This is a temporary bandaid until a more explicit handling of maybe types is
> introduced for configurations (e.g. by using srfi-189). Until then, with this
> change it becomes possible to have definitions like:
>
> (define-maybe string (no-serialization))
>
> (define-configuration my-configuration
> (my-field (maybe-string))
> (no-serialization))
>
> i.e. without providing a default value for MY-FIELD.
> ---
> gnu/services/configuration.scm | 4 +++-
> 1 file changed, 3 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/services/configuration.scm b/gnu/services/configuration.scm
> index 0de350a4df..c5f276eab5 100644
> --- a/gnu/services/configuration.scm
> +++ b/gnu/services/configuration.scm
> @@ -141,7 +141,9 @@ (define (define-maybe-helper serialize? prefix syn)
> (id #'stem #'serialize-maybe- #'stem))))
> #`(begin
> (define (maybe-stem? val)
> - (or (eq? val 'disabled) (stem? val)))
> + (or (eq? val 'disabled)
> + (eq? val 'undefined)
> + (stem? val)))

My understanding is that 'disabled is here precisely to allow users to
not provide a value, in which case the generated configuration file will
not contain anything for that field.

What would be different here?

Thanks,
Ludo’.
A
A
Attila Lendvai wrote on 2 Feb 2022 12:47
(name . 53663-close@debbugs.gnu.org)(address . 53663-close@debbugs.gnu.org)
LZAnSJmgmdtLPRzpDhrfzSlilVJJq1MLXCWIIkE-yMLDeEXnFN5wPrWeMGAjZGo2vl1yUKPrilT3nCtusH9frolHVuqEM9boV1MLWgVr64U=@lendvai.name
Toggle quote (2 lines)
> What would be different here?

the possibility of writing:

(define-configuration my-cfg
(my-field (maybe-string)))

versus now having to write:

(define-configuration my-cfg
(my-field (maybe-string 'disabled)))

but now that i thought about it, i think everyone is better off if i
deal with this on my side, instead of having a discussion about the
exact shape of a bandaid.

closing this for now; more later in the form of a proper cleanup
proposal of the configuration code.

--
• attila lendvai
• PGP: 963F 5D5F 45C7 DFCD 0A39
--
“There can be no greater stretch of arbitrary power than is required to seize children from their parents, teach them whatever the authorities decree they shall be taught, and expropriate from the parents the funds to pay for the procedure.”
— Isabel Paterson (1886–1961), 'The God of the Machine' (1943)
?