[PATCH] gnu: python-pyqtgraph: Remove a transitive dependency on QtWebKit.

  • Done
  • quality assurance status badge
Details
One participant
  • Leo Famulari
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 28 Jan 2022 20:49
(address . guix-patches@gnu.org)(address . monego@posteo.net)
3490657b447a9f4be32e5dfe4ce6e650bd4b83c9.1643399199.git.leo@famulari.name
See https://issues.guix.gnu.org/53289 for more information about this change.

These are the packages that depend directly on pyqtgraph:

------
./pre-inst-env guix package -s . | recsel -e 'dependencies ~ "python-pyqtgraph"' -p name,synopsis
name: gnuradio
synopsis: Toolkit for software-defined radios

name: python-orange-widget-base
synopsis: Base Widget for Orange Canvas

name: orange
synopsis: Component-based data mining framework
------

They all build with this change. I'm confident that it won't cause a regression
for gnuradio, because we switched gnuradio from python-pyqt to
python-pyqt-without-qtwebkit months ago.

Vinicius, I've CC-ed you so that you can check if this causes problems for
Orange. I think it's unlikely, because Orange depends directly on QtWebEngine,
which replaces QtWebKit in the world of Qt.

* gnu/packages/python-xyz.scm (python-pyqtgraph)[propagated-inputs]: Replace
python-pyqt with python-pyqt-without-qtwebkit.
---
gnu/packages/python-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a8aff94334..3b1956fecd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14794,7 +14794,7 @@ (define-public python-pyqtgraph
(list qtbase-5))
(propagated-inputs
(list python-h5py python-numpy python-pyopengl python-scipy
- python-pyqt))
+ python-pyqt-without-qtwebkit))
(home-page "http://www.pyqtgraph.org")
(synopsis "Scientific graphics and GUI library for Python")
(description
--
2.34.0
L
L
Leo Famulari wrote on 16 Feb 2022 20:36
(address . 53614-done@debbugs.gnu.org)
Yg1STQm1WrPwlVQH@jasmine.lan
Pushed as 0dc0d87839ccb7e85f99d7469da1ef478a1c8dc4
Closed
?