[PATCH] gnu: Add emacs-validate-html.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Nicolas Goaziou
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220127055425.18752-1-jgart@dismail.de
* gnu/packages/emacs-xyz.scm (emacs-validate-html): New variable.
---

Hi,

Here is another one I'm upstreaming from Guix 'R Us.

all best,

jgart

gemini://whereiseveryone.srht.site

gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 258c2b25b5..fa8acf47e7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -29917,6 +29917,33 @@ (define-public emacs-nasm-mode
Unlike Emacs' generic ASM mode, it understands NASM-specific syntax.")
(license license:unlicense)))
+(define-public emacs-validate-html
+ (let ((commit "748e874d50c3a95c61590ae293778e26de05c5f9")
+ (revision "0"))
+ (package
+ (name "emacs-validate-html")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/arthurgleckler/validate-html")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b2b5dm85jwgkqvga23r3vfya07vxv2n7a3a6r1pxpk8asqlw41c"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/arthurgleckler/validate-html")
+ (synopsis "Run the W3C HTML Validator directly from Emacs")
+ (description
+"@command{emacs-validate-html} installs the command @command{validate-html},
+which sends the current buffer to the World Wide Web Consortium’s HTML
+Validator service and displays the results in a buffer in Compilation
+mode. Use standard Compilation commands like next-error to move through
+the errors in the source buffer.")
+ (license license:gpl3+))))
+
(define-public emacs-global-tags
(let ((commit "06db25d91cc8bfb5e24e02adc04de1226c7e742d")
(revision "0"))
--
2.34.1
N
N
Nicolas Goaziou wrote on 28 Jan 2022 09:19
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87pmocw9uf.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-validate-html): New variable.

Thank you. I applied it with the changes below:

Toggle quote (7 lines)
> +(define-public emacs-validate-html
> + (let ((commit "748e874d50c3a95c61590ae293778e26de05c5f9")
> + (revision "0"))
> + (package
> + (name "emacs-validate-html")
> + (version (git-version "0.1" revision commit))

Version is actually "1.3" per main file. I also removed `revision'
since `commit' matches the latest version bump.

I also added a comment explaining the situation.

Toggle quote (8 lines)
> + (description
> +"@command{emacs-validate-html} installs the command @command{validate-html},
> +which sends the current buffer to the World Wide Web Consortium’s HTML
> +Validator service and displays the results in a buffer in Compilation
> +mode. Use standard Compilation commands like next-error to move through
> +the errors in the source buffer.")
> + (license license:gpl3+))))

I removed last sentence, which belongs to the package manual rather than
its description.

Regards,
--
Nicolas Goaziou
?