[PATCH 2/2] gnu: Remove aseba.

  • Done
  • quality assurance status badge
Details
3 participants
  • Leo Famulari
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Leo Famulari
Severity
normal
L
L
Leo Famulari wrote on 26 Jan 2022 19:25
(address . guix-patches@gnu.org)
be1efde5ea29f155345d61abe9028eb42e54453b.1643221548.git.leo@famulari.name
This package doesn't build anymore:


* gnu/packages/robotics.scm (aseba): Remove variable.
---
gnu/packages/robotics.scm | 67 ++-------------------------------------
1 file changed, 3 insertions(+), 64 deletions(-)

Toggle diff (89 lines)
diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
index a110d0e6bd..9d7e2bf4c4 100644
--- a/gnu/packages/robotics.scm
+++ b/gnu/packages/robotics.scm
@@ -18,20 +18,13 @@
(define-module (gnu packages robotics)
#:use-module (guix packages)
- #:use-module (guix download)
#:use-module (guix git-download)
- #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix licenses)
#:use-module (guix build-system cmake)
- #:use-module (gnu packages avahi)
- #:use-module (gnu packages cpp)
#:use-module (gnu packages gl)
- #:use-module (gnu packages linux)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages protobuf)
- #:use-module (gnu packages qt)
#:use-module (gnu packages sdl)
- #:use-module (gnu packages valgrind)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages qt))
(define-public enki
;; Previous versions use Qt4 and are unsuitable for Aseba.
@@ -70,58 +63,4 @@ (define-public enki
;; researchers using the software are "asked" to cite using a given
;; citation, but that sentence is written as not being part of the
;; license (fortunately).
- (license license:gpl2+))))
-
-(define-public aseba
- ;; Use the commit that allows us to build with Qt5.
- (let ((commit "3b35de80d5fdd47592b1c01d57e1f4ef37c5e5ea")
- (revision "0"))
- (package
- (name "aseba")
- (version (git-version "1.6.0" revision commit))
- (home-page "https://github.com/aseba-community/aseba")
- (source (origin
- (method git-fetch)
- (uri (git-reference (url home-page) (commit commit)
- (recursive? #t))) ;for Blockly
- (sha256
- (base32
- "0j31lmc9f0ksvkh0md2fgsz92hcsrwnrqqcynamizs2ah8iwlqi5"))
- (file-name (string-append name "-" version "-checkout"))
- (modules '((guix build utils)))
- (snippet
- ;; Add missing Qt5::Network.
- '(begin
- (substitute* "targets/playground/CMakeLists.txt"
- (("target_link_libraries(.*)\\$\\{EXTRA_LIBS\\}" _ middle)
- (string-append "target_link_libraries" middle
- " Qt5::Network ${EXTRA_LIBS}")))
- #t))))
- (build-system cmake-build-system)
- (arguments
- '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
- (native-inputs
- (list pkg-config valgrind)) ;for tests
- (inputs
- (list dashel
- enki
- protobuf-3.5 ;for logging
- qtbase-5
- qtsvg
- qttools ;for libQt5Help, needed by "studio"
- qtwebkit
- qtx11extras
- eudev
- libxml2
- sdl2
- avahi)) ;XXX: we need the libdnssd compat layer
- (synopsis "Event-based robot programming tools")
- (description
- "Aseba means @dfn{actuator and sensor event-based architecture}.
-It is a set of tools which allow beginners to program robots easily and
-efficiently. It includes robot simulators, a programming language, and a
-visual programming language (VPL) that is notably used together with the
-Thymio educational robot.")
-
- ;; Source file headers say "version 3.0" without "or any later version".
- (license license:lgpl3))))
+ (license gpl2+))))
--
2.34.0
M
M
Maxim Cournoyer wrote on 27 Jan 2022 05:39
(name . Leo Famulari)(address . leo@famulari.name)
87o83x23n6.fsf@gmail.com
+CC Ludo, who originally added the package

Hi Leo!

Leo Famulari <leo@famulari.name> writes:

Toggle quote (97 lines)
> This package doesn't build anymore:
>
> https://ci.guix.gnu.org/search?query=spec%3Amaster+system%3Ax86_64-linux+aseba
>
> * gnu/packages/robotics.scm (aseba): Remove variable.
> ---
> gnu/packages/robotics.scm | 67 ++-------------------------------------
> 1 file changed, 3 insertions(+), 64 deletions(-)
>
> diff --git a/gnu/packages/robotics.scm b/gnu/packages/robotics.scm
> index a110d0e6bd..9d7e2bf4c4 100644
> --- a/gnu/packages/robotics.scm
> +++ b/gnu/packages/robotics.scm
> @@ -18,20 +18,13 @@
>
> (define-module (gnu packages robotics)
> #:use-module (guix packages)
> - #:use-module (guix download)
> #:use-module (guix git-download)
> - #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix licenses)
> #:use-module (guix build-system cmake)
> - #:use-module (gnu packages avahi)
> - #:use-module (gnu packages cpp)
> #:use-module (gnu packages gl)
> - #:use-module (gnu packages linux)
> #:use-module (gnu packages pkg-config)
> - #:use-module (gnu packages protobuf)
> - #:use-module (gnu packages qt)
> #:use-module (gnu packages sdl)
> - #:use-module (gnu packages valgrind)
> - #:use-module (gnu packages xml))
> + #:use-module (gnu packages qt))
>
> (define-public enki
> ;; Previous versions use Qt4 and are unsuitable for Aseba.
> @@ -70,58 +63,4 @@ (define-public enki
> ;; researchers using the software are "asked" to cite using a given
> ;; citation, but that sentence is written as not being part of the
> ;; license (fortunately).
> - (license license:gpl2+))))
> -
> -(define-public aseba
> - ;; Use the commit that allows us to build with Qt5.
> - (let ((commit "3b35de80d5fdd47592b1c01d57e1f4ef37c5e5ea")
> - (revision "0"))
> - (package
> - (name "aseba")
> - (version (git-version "1.6.0" revision commit))
> - (home-page "https://github.com/aseba-community/aseba")
> - (source (origin
> - (method git-fetch)
> - (uri (git-reference (url home-page) (commit commit)
> - (recursive? #t))) ;for Blockly
> - (sha256
> - (base32
> - "0j31lmc9f0ksvkh0md2fgsz92hcsrwnrqqcynamizs2ah8iwlqi5"))
> - (file-name (string-append name "-" version "-checkout"))
> - (modules '((guix build utils)))
> - (snippet
> - ;; Add missing Qt5::Network.
> - '(begin
> - (substitute* "targets/playground/CMakeLists.txt"
> - (("target_link_libraries(.*)\\$\\{EXTRA_LIBS\\}" _ middle)
> - (string-append "target_link_libraries" middle
> - " Qt5::Network ${EXTRA_LIBS}")))
> - #t))))
> - (build-system cmake-build-system)
> - (arguments
> - '(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
> - (native-inputs
> - (list pkg-config valgrind)) ;for tests
> - (inputs
> - (list dashel
> - enki
> - protobuf-3.5 ;for logging
> - qtbase-5
> - qtsvg
> - qttools ;for libQt5Help, needed by "studio"
> - qtwebkit
> - qtx11extras
> - eudev
> - libxml2
> - sdl2
> - avahi)) ;XXX: we need the libdnssd compat layer
> - (synopsis "Event-based robot programming tools")
> - (description
> - "Aseba means @dfn{actuator and sensor event-based architecture}.
> -It is a set of tools which allow beginners to program robots easily and
> -efficiently. It includes robot simulators, a programming language, and a
> -visual programming language (VPL) that is notably used together with the
> -Thymio educational robot.")
> -
> - ;; Source file headers say "version 3.0" without "or any later version".
> - (license license:lgpl3))))
> + (license gpl2+))))

I'm not sure about this one. Pinging Ludo, who originally added it; it
seems to be perhaps related to the work of colleagues at the INRIA.

Thank you,

Maxim
L
L
Ludovic Courtès wrote on 28 Jan 2022 23:57
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
87h79nbh98.fsf@gnu.org
Hi,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (8 lines)
> Leo Famulari <leo@famulari.name> writes:
>
>> This package doesn't build anymore:
>>
>> https://ci.guix.gnu.org/search?query=spec%3Amaster+system%3Ax86_64-linux+aseba
>>
>> * gnu/packages/robotics.scm (aseba): Remove variable.

I’ve instead fixed it in f4554d28d6764aa8a733e4147dff8e8d473be19e.

Thanks for the heads-up!

Ludo’.
Closed
?