[PATCH] gnu: python-uvloop: Skip failing test on PowerPC.

  • Open
  • quality assurance status badge
Details
One participant
  • Lars-Dominik Braun
Owner
unassigned
Submitted by
Lars-Dominik Braun
Severity
normal
L
L
Lars-Dominik Braun wrote on 26 Jan 2022 18:48
(address . guix-patches@gnu.org)
YfGJZ2HYAMcI88A6@noor.fritz.box
* gnu/packages/python-web.scm (python-uvloop)[arguments]: Conditionally
skip test on target-powerpc?.
---
gnu/packages/python-web.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)


Hi,

can someone using a PowerPC machine please verify this fixes the build

Thanks,
Lars

Toggle diff (19 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 406c6cb51b..1c90fde331 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4644,7 +4644,11 @@ (define-public python-uvloop
;; It looks like pytest is preventing
;; custom stdout/stderr redirection,
;; even with -s.
- "and not test_process_streams_redirect "))))))))
+ "and not test_process_streams_redirect "
+ ;; Fails for unknown reasons.
+ (if target-powerpc?
+ "and not test_write_buffer_full "
+ "")))))))))
(native-inputs
(list python-aiohttp
python-cython
--
2.34.1
?