[PATCH] gnu: utf-8-lineseparator: Update to cj7.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Liliana Marie Prikler
  • Ludovic Courtès
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220124054815.3276-1-jgart@dismail.de
* gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
---
gnu/packages/textutils.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 12e3d3b3c8..751b036f79 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
(define-public utf-8-lineseparator
(package
(name "utf-8-lineseparator")
- (version "cj3")
+ (version "cj7")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
(file-name (git-file-name name version))
(sha256
(base32
- "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
+ "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
--
2.34.1
L
L
Liliana Marie Prikler wrote on 24 Jan 2022 17:26
fe9110ab3d07bd942845f6de1666e5002fd00ca9.camel@gmail.com
Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
Toggle quote (29 lines)
> * gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
> ---
>  gnu/packages/textutils.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
> index 12e3d3b3c8..751b036f79 100644
> --- a/gnu/packages/textutils.scm
> +++ b/gnu/packages/textutils.scm
> @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
>  (define-public utf-8-lineseparator
>    (package
>      (name "utf-8-lineseparator")
> -    (version "cj3")
> +    (version "cj7")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -               
> "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> +               
> "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
>      (build-system gnu-build-system)
>      (arguments
>       `(#:make-flags
I know this ought to have been caught by whoever reviewed the package
back then, but is "cj" really a relevant part of the version?

Cheers
J
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 53494@debbugs.gnu.org)
20220124124533.GB18545@gac.attlocal.net
On Mon, 24 Jan 2022 17:26:45 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
Toggle quote (33 lines)
> Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
> > * gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
> > ---
> >  gnu/packages/textutils.scm | 4 ++--
> >  1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
> > index 12e3d3b3c8..751b036f79 100644
> > --- a/gnu/packages/textutils.scm
> > +++ b/gnu/packages/textutils.scm
> > @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
> >  (define-public utf-8-lineseparator
> >    (package
> >      (name "utf-8-lineseparator")
> > -    (version "cj3")
> > +    (version "cj7")
> >      (source (origin
> >                (method git-fetch)
> >                (uri (git-reference
> > @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
> >                (file-name (git-file-name name version))
> >                (sha256
> >                 (base32
> > -               
> > "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> > +               
> > "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
> >      (build-system gnu-build-system)
> >      (arguments
> >       `(#:make-flags
> I know this ought to have been caught by whoever reviewed the package
> back then, but is "cj" really a relevant part of the version?

Hi lilyp,

That's the author's system for version releases.

They're not using semver. See the hugs module/system for one example of
a versioning system that is not semver in upstream GNU/Guix.

all best,

jgart
J
L
L
Liliana Marie Prikler wrote on 24 Jan 2022 19:10
(name . jgart)(address . jgart@dismail.de)(address . 53494@debbugs.gnu.org)
2385b279e1beed46164c5b00988ed7f4a71d41ab.camel@gmail.com
Hi,

Am Montag, dem 24.01.2022 um 12:45 -0500 schrieb jgart:
Toggle quote (44 lines)
> On Mon, 24 Jan 2022 17:26:45 +0100 Liliana Marie Prikler
> <liliana.prikler@gmail.com> wrote:
> > Am Montag, dem 24.01.2022 um 00:48 -0500 schrieb jgart:
> > > * gnu/packages/textutils.scm (utf-8-lineseparator): Update to
> > > cj7.
> > > ---
> > >  gnu/packages/textutils.scm | 4 ++--
> > >  1 file changed, 2 insertions(+), 2 deletions(-)
> > >
> > > diff --git a/gnu/packages/textutils.scm
> > > b/gnu/packages/textutils.scm
> > > index 12e3d3b3c8..751b036f79 100644
> > > --- a/gnu/packages/textutils.scm
> > > +++ b/gnu/packages/textutils.scm
> > > @@ -1377,7 +1377,7 @@ (define-public go-github-com-errata-ai-vale
> > >  (define-public utf-8-lineseparator
> > >    (package
> > >      (name "utf-8-lineseparator")
> > > -    (version "cj3")
> > > +    (version "cj7")
> > >      (source (origin
> > >                (method git-fetch)
> > >                (uri (git-reference
> > > @@ -1386,7 +1386,7 @@ (define-public utf-8-lineseparator
> > >                (file-name (git-file-name name version))
> > >                (sha256
> > >                 (base32
> > > -               
> > > "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
> > > +               
> > > "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
> > >      (build-system gnu-build-system)
> > >      (arguments
> > >       `(#:make-flags
> > I know this ought to have been caught by whoever reviewed the
> > package
> > back then, but is "cj" really a relevant part of the version?
>
> Hi lilyp,
>
> That's the author's system for version releases.
>
> They're not using semver. See the hugs module/system for one example
> of a versioning system that is not semver in upstream GNU/Guix.
That doesn't answer my question and instead just raises more. We
typically strip meaningless version prefixes such as "v", (weird)
spellings of the package name, etc. Why is cj special in this regard?

Also for hugs, we could be using CalVer as far as I can see, though
it's unlikely to receive a version bump after 15 years.

Cheers
L
L
Liliana Marie Prikler wrote on 24 Jan 2022 20:17
(name . jgart)(address . jgart@dismail.de)(address . 53494@debbugs.gnu.org)
65b48dd1a0c3db19dbd09c3d5d342139aecdced0.camel@gmail.com
Am Montag, dem 24.01.2022 um 13:00 -0500 schrieb jgart:
Toggle quote (4 lines)
> On Mon, 24 Jan 2022 12:45:33 -0500 jgart <jgart@dismail.de> wrote:
> > is "cj" really a relevant part of the version?
>
> https://github.com/pflanze/utf-8-lineseparator/archive/refs/tags/cj7.tar.gz
You're not answering the question. I can read the tag myself, I want
to know how to interpret it.
J
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
20220124230620.GB14212@gac.attlocal.net
On Mon, 24 Jan 2022 20:17:48 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:

Toggle quote (3 lines)
> I know this ought to have been caught by whoever reviewed the package
> back then, but is "cj" really a relevant part of the version?

Hi lilyp,

Sorry, I was under the impression that all packages did not have to
follow a particular versioning scheme such as SemVer or CalVer. Is that
part of official Guix Policy that I can read somewhere?

I'm cc'ing Ludovic to see if there is a differing opinion on the
topic given that Ludo had reviewed and merged the utf-8-lineseparator
tool/framework.

all best,

jgart
L
L
Ludovic Courtès wrote on 25 Jan 2022 14:52
(name . jgart)(address . jgart@dismail.de)
875yq7ncsb.fsf@gnu.org
Hi,

jgart <jgart@dismail.de> skribis:

Toggle quote (5 lines)
> On Mon, 24 Jan 2022 20:17:48 +0100 Liliana Marie Prikler <liliana.prikler@gmail.com> wrote:
>
>> I know this ought to have been caught by whoever reviewed the package
>> back then, but is "cj" really a relevant part of the version?

I overlooked that bit; “cj3” doesn’t look like a version number, indeed.

Toggle quote (4 lines)
> Sorry, I was under the impression that all packages did not have to
> follow a particular versioning scheme such as SemVer or CalVer. Is that
> part of official Guix Policy that I can read somewhere?

There’s no policy regarding semver & co: packages can do what they want.

However, the Guix CLI assumes “normal” version numbers, meaning a string
that starts with dot-separated digits. ‘guix upgrade’, for instance,
compares version strings to determine what’s being upgraded, so those
strings have to be “normal” version strings.

jgart, is “cj7” the version string upstream? In that case, can we
change it to “7” or “7.cj” or something along these lines?

Ludo’.
J
[PATCH v2] gnu: utf-8-lineseparator: Update to cj7.
(address . 53494@debbugs.gnu.org)
20220126062010.14230-1-jgart@dismail.de
* gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.
---

Hi Ludo,

Thank you for explaining this (much appreciated) and sorry for the
confusion. Attached is version 2 of the patch.

all best,

jgart

gnu/packages/textutils.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/textutils.scm b/gnu/packages/textutils.scm
index 12e3d3b3c8..f10ca300ab 100644
--- a/gnu/packages/textutils.scm
+++ b/gnu/packages/textutils.scm
@@ -1377,16 +1377,16 @@ (define-public go-github-com-errata-ai-vale
(define-public utf-8-lineseparator
(package
(name "utf-8-lineseparator")
- (version "cj3")
+ (version "7")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/pflanze/utf-8-lineseparator")
- (commit version)))
+ (commit (string-append "cj" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1xnbcanqn5jr965gw9195ij6hz04clfm77m5776dysn9nykn20w1"))))
+ "0lqwfrwq28246lja2gawf5jllh4smddswkpd5lscvc2ynylcmmzx"))))
(build-system gnu-build-system)
(arguments
`(#:make-flags
--
2.34.1
L
L
Ludovic Courtès wrote on 26 Jan 2022 15:49
(name . jgart)(address . jgart@dismail.de)(address . 53494-done@debbugs.gnu.org)
87ilu6h7r4.fsf@gnu.org
Hi,

jgart <jgart@dismail.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/textutils.scm (utf-8-lineseparator): Update to cj7.

Applied, thanks!

Ludo’.
Closed
?