[PATCH] gnu: Add emacs-cape.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brandon Lucas
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Brandon Lucas
Severity
normal
B
B
Brandon Lucas wrote on 23 Jan 2022 15:22
(address . guix-patches@gnu.org)(name . Brandon Lucas)(address . br@ndon.dk)
20220123142234.1196450-1-br@ndon.dk
* gnu/packages/emacs-xyz.scm (emacs-cape): New variable.
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (46 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..f853f0b832 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2902,6 +2902,41 @@ (define-public emacs-corfu
@code{completion-in-region} counterpart of the Vertico minibuffer UI.")
(license license:gpl3+)))

+(define-public emacs-cape
+ (package
+ (name "emacs-cape")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/minad/cape")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0780qymlrg3glyxypizqzwicp5ly5xavxgpmayhx8cxlgp2zlkjh"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/minad/cape")
+ (synopsis "Completion At Point Extensions for Emacs")
+ (description
+ "Cape provides additional completion backends in the form of Capfs
+(completion-at-point-functions).
+
+@itemize
+@item cape-dabbrev: Complete word from current buffers
+@item cape-file: Complete file name
+@item cape-keyword: Complete programming language keyword
+@item cape-symbol: Complete Elisp symbol
+@item cape-abbrev: Complete abbreviation (add-global-abbrev, add-mode-abbrev)
+@item cape-ispell: Complete word from Ispell dictionary
+@item cape-dict: Complete word from dictionary file
+@item cape-line: Complete entire line from file
+@item cape-tex: Complete unicode char from TeX command, e.g. \\hbar.
+@item cape-sgml: Complete unicode char from Sgml entity, e.g., &alpha.
+@item cape-rfc1345: Complete unicode char using RFC 1345 mnemonics.
+@end itemize\n")
+ (license license:gpl3)))
+
(define-public emacs-direnv
(package
(name "emacs-direnv")
--
2.34.0
N
N
Nicolas Goaziou wrote on 23 Jan 2022 18:24
(name . Brandon Lucas)(address . br@ndon.dk)(address . 53475-done@debbugs.gnu.org)
87o842cql4.fsf@nicolasgoaziou.fr
Hello,

Brandon Lucas <br@ndon.dk> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-cape): New variable.

Thank you.

I fixed the license field, changed the description, and downcased
synopsis. Then I applied your patch.

Regards,
--
Nicolas Goaziou
Closed
?