[PATCH] gnu: Add emacs-fixed-pitch.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brandon Lucas
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Brandon Lucas
Severity
normal
B
B
Brandon Lucas wrote on 23 Jan 2022 14:42
(address . guix-patches@gnu.org)(name . Brandon Lucas)(address . br@ndon.dk)
20220123134221.1174002-1-br@ndon.dk
* gnu/packages/emacs-xyz.scm (emacs-fixed-pitch): New variable.
---
gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (33 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..73277c06de 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19649,6 +19649,28 @@ (define-public emacs-default-text-scale
decreasing the default font size in all GUI Emacs frames.")
(license license:gpl3+)))

+(define-public emacs-fixed-pitch
+ (package
+ (name "emacs-fixed-pitch")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cstby/fixed-pitch-mode")
+ (commit "f26f96ab65c8452553d803fc39509481ac6b7239")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qlavjvib0r71xdy6y6pan9dhr57lw7jhmqk60mwa8fq6km8kpkj"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/cstby/fixed-pitch-mode")
+ (synopsis "Minor mode for setting a monospaced typeface")
+ (description
+ "Use a minor mode for setting a monospace typeface, so you can set a
+ proportional typeface for UI elements while keeping a monospaced typeface
+ for code.")
+ (license license:gpl3)))
+
(define-public emacs-mixed-pitch
(package
(name "emacs-mixed-pitch")
--
2.34.0
N
N
Nicolas Goaziou wrote on 23 Jan 2022 18:02
(name . Brandon Lucas)(address . br@ndon.dk)(address . 53473-done@debbugs.gnu.org)
87sftecrn5.fsf@nicolasgoaziou.fr
Hello,

Brandon Lucas <br@ndon.dk> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-fixed-pitch): New variable.

Thank you.

I applied your patch with the changes below.

Toggle quote (7 lines)
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/cstby/fixed-pitch-mode")
> + (commit "f26f96ab65c8452553d803fc39509481ac6b7239")))

I used a tag, namely "v0.1.0" created with (string-append "v" version),
instead of a raw git commit.

Note that if you need to use such a reference, please let-bind it to
`commit' at the beginning of the package and use (commit commit)
instead.

Toggle quote (11 lines)
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0qlavjvib0r71xdy6y6pan9dhr57lw7jhmqk60mwa8fq6km8kpkj"))))
> + (build-system emacs-build-system)
> + (home-page "https://github.com/cstby/fixed-pitch-mode")
> + (synopsis "Minor mode for setting a monospaced typeface")
> + (description
> + "Use a minor mode for setting a monospace typeface, so you can set a
> + proportional typeface for UI elements while keeping a monospaced typeface
> + for code.")

I reworded synopsis and description.

Toggle quote (2 lines)
> + (license license:gpl3)))

The license is actually gpl3+ as the main file has "either version 3 of
the License, or ;; (at your option) any later version." in its header.

Regards,
--
Nicolas Goaziou
Closed
?