[PATCH] gnu: Add emacs-minimap.

  • Done
  • quality assurance status badge
Details
2 participants
  • Brandon Lucas
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Brandon Lucas
Severity
normal
B
B
Brandon Lucas wrote on 23 Jan 2022 14:32
(address . guix-patches@gnu.org)(name . Brandon Lucas)(address . br@ndon.dk)
20220123133204.1167960-1-br@ndon.dk
* gnu/packages/emacs-xyz.scm (emacs-minimap): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8edbfc5a3d..2ce2b6070b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26678,6 +26678,36 @@ (define-public emacs-minibuffer-line
variable and the @code{minibuffer-line} face.")
(license license:gpl3+)))

+(define-public emacs-minimap
+ (package
+ (name "emacs-minimap")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://elpa.gnu.org/packages/minimap-"
+ version
+ ".el"))
+ (sha256
+ (base32 "09fm0ziy8cdzzw08l7l6p63dxz2a27p3laia2v51mvbva8177ls1"))))
+ (build-system emacs-build-system)
+ (home-page "http://elpa.gnu.org/packages/minimap.html")
+ (synopsis "Sidebar showing a 'mini-map' of a buffer")
+ (description
+ "Minimap provides Emacs with a minimap sidebar, which is a
+ smaller display of the current buffer on the side, like a scrollbar. It
+ highlights the currently shown region and updates its position automatically.
+ You can navigate in the minibar by dragging the active region with the mouse,
+ which will scroll the corresponding edit buffer.
+ Additionally, you can overlay information from the tags gathered by CEDET's
+ semantic analyzer.
+
+ Use M-x minimap-mode to toggle activation of the minimap.
+ Use 'M-x customize-group RET minimap RET' to adapt minimap to your
+ needs.")
+ (license license:gpl3+)))
+
(define-public emacs-eshell-prompt-extras
(package
(name "emacs-eshell-prompt-extras")
--
2.34.0
N
N
Nicolas Goaziou wrote on 23 Jan 2022 17:49
(name . Brandon Lucas)(address . br@ndon.dk)(address . 53471-done@debbugs.gnu.org)
87wniqcs8l.fsf@nicolasgoaziou.fr
Hello,

Brandon Lucas <br@ndon.dk> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-minimap): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?