[PATCH] gnu: Update nim to 1.6.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • (unmatched-parenthesis
Owner
unassigned
Submitted by
(unmatched-parenthesis
Severity
normal
(
(
(unmatched-parenthesis wrote on 23 Jan 2022 14:10
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220123131020.3933-1-paren@disroot.org
* gnu/packages/nim.scm(nim): Update to 1.6.2.
---
gnu/packages/nim.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 0830a6106a..82a559333c 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -28,14 +28,14 @@ (define-module (gnu packages nim)
(define-public nim
(package
(name "nim")
- (version "1.4.6")
+ (version "1.6.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://nim-lang.org/download/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1gfkk15q022s31ffbsm2lbfrsnsjfslbyixwk7g8bzngha90zg0g"))))
+ (base32 "0wz3jccdbhi7wd19fz9r6zad945iq50qjpbzva8xc5f3lr7p3i4s"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
@@ -73,3 +73,5 @@ (define-public nim
without compromises on runtime efficiency. This means it focuses on compile-time
mechanisms in all their various forms.")
(license license:expat)))
+
+nim
--
2.34.0
(
(
(unmatched-parenthesis wrote on 23 Jan 2022 16:22
[PATCH v2] gnu: Update nim to 1.6.2
(address . 53469@debbugs.gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220123152247.3795-1-paren@disroot.org
Oops! I forgot to add a copyright notice and remove the testing return :)

* gnu/packages/nim.scm(nim): Update to 1.6.2.
---
gnu/packages/nim.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/nim.scm b/gnu/packages/nim.scm
index 0830a6106a..f0f958b215 100644
--- a/gnu/packages/nim.scm
+++ b/gnu/packages/nim.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,14 +29,14 @@ (define-module (gnu packages nim)
(define-public nim
(package
(name "nim")
- (version "1.4.6")
+ (version "1.6.2")
(source
(origin
(method url-fetch)
(uri (string-append "https://nim-lang.org/download/"
name "-" version ".tar.xz"))
(sha256
- (base32 "1gfkk15q022s31ffbsm2lbfrsnsjfslbyixwk7g8bzngha90zg0g"))))
+ (base32 "0wz3jccdbhi7wd19fz9r6zad945iq50qjpbzva8xc5f3lr7p3i4s"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; No tests.
--
2.34.0
N
N
Nicolas Goaziou wrote on 23 Jan 2022 18:36
(name . (unmatched-parenthesis via Guix-patches via)(address . guix-patches@gnu.org)
87czkicq19.fsf@nicolasgoaziou.fr
Hello,

"(unmatched-parenthesis via Guix-patches" via <guix-patches@gnu.org>
writes:

Toggle quote (3 lines)
> Oops! I forgot to add a copyright notice and remove the testing
> return :)

Thank you.

I think a copyright is not applicable to a mere version bump since there
is only one way to do it. However, 1) IANAL 2) I am happy to see more
names in modules headers, so I kept the line.

Applied!

Regards,
--
Nicolas Goaziou
Closed
?