[PATCH 0/2] Update chatty.

  • Done
  • quality assurance status badge
Details
2 participants
  • Julien Lepiller
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 23 Jan 2022 10:45
(address . guix-patches@gnu.org)
f0b86c5f173e0e46210bd94e403d647c9f9af70e.camel@gmail.com
Hi Guix,

chatty is one of the two remaining applications that use libhandy-0.0, the
other one being authenticator. With this patch it is updated to the latest
non-beta release, which builds against libhandy. In order to successfully
build it, evolution-data-server needs to be built against libphonenumber, so
I did that.

I did not yet test the impact of evolution-data-server on other applications,
nor did I test chatty itself. Volunteers welcome.

Liliana Marie Prikler (2):
gnu: evolution-data-server: Build with libphonenumber.
gnu: chatty: Update to 0.4.0.

gnu/packages/gnome.scm | 11 +++++++----
gnu/packages/messaging.scm | 18 ++++++++++--------
2 files changed, 17 insertions(+), 12 deletions(-)

--
2.34.0
L
L
Liliana Marie Prikler wrote on 23 Jan 2022 10:41
[PATCH 1/2] gnu: evolution-data-server: Build with libphonenumber.
(address . 53465@debbugs.gnu.org)
27f3658d7dd7297e91ca3f150e67baa2ece39a93.camel@gmail.com
* gnu/packages/gnome.scm (evolution)[#:configure-flags]: Drop
"-DENABLE_UOA=OFF" and "-DENABLE_GOOGLE_AUTH=OFF" -- these flags no longer
exist.
Add "-DWITH_PHONENUMBER=ON".
[native-inputs]: Add protobuf.
[inputs]: Add boost and libphonenumber.
---
gnu/packages/gnome.scm | 11 +++++++----
1 file changed, 7 insertions(+), 4 deletions(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ad7536c07c..d66a616e49 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -157,6 +157,7 @@ (define-module (gnu packages gnome)
#:use-module (gnu packages mail)
#:use-module (gnu packages man)
#:use-module (gnu packages markup)
+ #:use-module (gnu packages messaging)
#:use-module (gnu packages mp3)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages music)
@@ -7678,14 +7679,13 @@ (define-public evolution-data-server
'("addressbook-backends" "calendar-backends"
"camel-providers" "credential-modules"
"registry-modules"))))
- (list "-DENABLE_UOA=OFF" ;disable Ubuntu Online Accounts support
- "-DENABLE_GOOGLE=OFF" ;disable Google Contacts support
- "-DENABLE_GOOGLE_AUTH=OFF" ;disable Google authentication
+ (list "-DENABLE_GOOGLE=OFF" ;disable Google Contacts support
"-DENABLE_VALA_BINDINGS=ON"
(string-append "-DCMAKE_INSTALL_RPATH=" lib ";"
(string-append lib "/evolution-data-server;")
(string-join runpaths ";"))
- "-DENABLE_INTROSPECTION=ON")) ;required for Vala bindings
+ "-DENABLE_INTROSPECTION=ON" ;required for Vala bindings
+ "-DWITH_PHONENUMBER=ON"))
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'disable-failing-tests
@@ -7715,6 +7715,7 @@ (define-public evolution-data-server
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
("intltool" ,intltool)
("pkg-config" ,pkg-config)
+ ("protobuf" ,protobuf)
("vala" ,vala)
("python" ,python-wrapper)))
(propagated-inputs
@@ -7727,11 +7728,13 @@ (define-public evolution-data-server
("sqlite" ,sqlite)))
(inputs
`(("bdb" ,bdb)
+ ("boost" ,boost)
("gcr" ,gcr)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("json-glib" ,json-glib)
("libcanberra" ,libcanberra)
("libgweather" ,libgweather)
+ ("libphonenumber" ,libphonenumber)
("mit-krb5" ,mit-krb5)
("openldap" ,openldap)
("webkitgtk" ,webkitgtk-with-libsoup2)))
--
2.34.0
L
L
Liliana Marie Prikler wrote on 23 Jan 2022 10:43
[PATCH 2/2] gnu: chatty: Update to 0.4.0.
(address . 53465@debbugs.gnu.org)
86642b7c523bf98fd006e6ca8566a9948a478818.camel@gmail.com
* gnu/packages/messaging.scm (chatty): Update to 0.4.0.
[#:phases]: Drop trailing #t.
[native-inputs]: Use new style. Add protobuf.
[inputs]: Add gspell, json-glib, libolm, libphonenumber and modem-manager.
Replace libhandy-0.0 with libhandy.
---
gnu/packages/messaging.scm | 18 ++++++++++--------
1 file changed, 10 insertions(+), 8 deletions(-)

Toggle diff (52 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 768642f119..ca8a216661 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2757,7 +2757,7 @@ (define-public libphonenumber
(define-public chatty
(package
(name "chatty")
- (version "0.1.17")
+ (version "0.4.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2766,7 +2766,7 @@ (define-public chatty
(file-name (git-file-name name version))
(sha256
(base32
- "0ba1rw8a3vif9k3570hxjfm25vqys3vk3f6g8z5irklwq4bi6lmn"))))
+ "12k1a5xrwd6zk4x0m53hbzggk695z3bpbzy1wcikzy0jvch7h13d"))))
(build-system meson-build-system)
(arguments
'(#:phases
@@ -2774,19 +2774,21 @@ (define-public chatty
(add-after 'unpack 'skip-updating-desktop-database
(lambda _
(substitute* "meson.build"
- (("meson.add_install_script.*") ""))
- #t)))))
+ (("meson.add_install_script.*") "")))))))
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("glib:bin" ,glib "bin")
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal `(,glib "bin") pkg-config protobuf))
(inputs
(list feedbackd
folks
gsettings-desktop-schemas
+ gspell
+ json-glib
libgcrypt
libgee
- libhandy-0.0
+ libhandy
+ libolm
+ libphonenumber
+ modem-manager
pidgin
purple-mm-sms
sqlite))
--
2.34.0
J
J
Julien Lepiller wrote on 8 Feb 2022 14:08
Re: [bug#53465] [PATCH 0/2] Update chatty.
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(address . 53465-done@debbugs.gnu.org)
20220208140805.67db28b3@tachikoma.lepiller.eu
Le Sun, 23 Jan 2022 10:45:47 +0100,
Liliana Marie Prikler <liliana.prikler@gmail.com> a écrit :

Toggle quote (20 lines)
> Hi Guix,
>
> chatty is one of the two remaining applications that use
> libhandy-0.0, the other one being authenticator. With this patch it
> is updated to the latest non-beta release, which builds against
> libhandy. In order to successfully build it, evolution-data-server
> needs to be built against libphonenumber, so I did that.
>
> I did not yet test the impact of evolution-data-server on other
> applications, nor did I test chatty itself. Volunteers welcome.
>
> Liliana Marie Prikler (2):
> gnu: evolution-data-server: Build with libphonenumber.
> gnu: chatty: Update to 0.4.0.
>
> gnu/packages/gnome.scm | 11 +++++++----
> gnu/packages/messaging.scm | 18 ++++++++++--------
> 2 files changed, 17 insertions(+), 12 deletions(-)
>

Thanks for the patches! Since evolution-data-server doesn't seem to
have too many dependencies (13), I pushed the patches to master as
e086b0807b079df58d5607770ecd5ec8c480f093 and
db74cfcf36ddd56a199cc919b2e5b5e580133922.
Closed
?