[PATCH 1/3] gnu: Add python-i3ipc

  • Done
  • quality assurance status badge
Details
2 participants
  • Björn Höfling
  • (unmatched-parenthesis
Owner
unassigned
Submitted by
(unmatched-parenthesis
Severity
normal
(
(
(unmatched-parenthesis wrote on 22 Jan 2022 12:47
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220122114722.21774-1-paren@disroot.org
* gnu/packages/wm.scm(python-i3ipc): New variable.
---
gnu/packages/wm.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 67e113aaa2..975247bf07 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Disseminate Dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2022 (unmatched parenthesis <paren@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -541,6 +542,25 @@ (define-public python-i3-py
(define-public python2-i3-py
(package-with-python2 python-i3-py))
+(define-public python-i3ipc
+ (package
+ (name "python-i3ipc")
+ (version "2.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "i3ipc" version))
+ (sha256
+ (base32 "1s6crkdn7q8wmzl5d0pb6rdkhhbvp444yxilrgaylnbr2kbxg078"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: Fix tests
+ '(#:tests? #f))
+ (propagated-inputs (list python-xlib))
+ (home-page "https://github.com/altdesktop/i3ipc-python")
+ (synopsis "An improved Python library to control i3wm and sway")
+ (description "This package provides an improved Python library to control i3wm and sway.")
+ (license license:bsd-3)))
(define-public qtile
(package
(name "qtile")
--
2.34.0
(
(
(unmatched-parenthesis wrote on 22 Jan 2022 12:47
[PATCH 3/3] gnu: Add i3-autotiling
(address . guix-patches@gnu.org)(name . (unmatched-parenthesis)(address . paren@disroot.org)
20220122114722.21774-3-paren@disroot.org
* gnu/packages/wm.scm(i3-autotiling): New variable.
---
gnu/packages/wm.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index c791bcf44e..9b473b22b1 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -121,6 +121,7 @@ (define-module (gnu packages wm)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-crypto)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages readline)
@@ -564,6 +565,32 @@ (define-public python-i3ipc
(define-public python2-i3ipc
(package-with-python2 python-i3ipc))
+
+(define-public i3-autotiling
+ (package
+ (name "i3-autotiling")
+ (version "1.6")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nwg-piotr/autotiling")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1hjlvg7095s322gb43r9g7mqlsy3pj13l827jpnbn5x0918rq9rr"))))
+ (build-system python-build-system)
+ (arguments
+ ;; TODO: Fix tests
+ '(#:tests? #f))
+ (propagated-inputs
+ (list python-i3ipc python-setuptools python-wheel))
+ (home-page "https://github.com/nwg-piotr/autotiling")
+ (synopsis "Automatic layout tiling for i3wm and sway.")
+ (description "This package uses @code{python-i3ipc} to control the tiling of i3wm and sway. It automatically switches between horizontal and vertical layouts to make the best use of space without human intervention.")
+ (license license:gpl3+)))
+
(define-public qtile
(package
(name "qtile")
--
2.34.0
B
B
Björn Höfling wrote on 25 Sep 2022 22:26
Re: [bug#53444] [PATCH 1/3] gnu: Add python-i3ipc
20220925222638.44157da4@alma-ubu.fritz.box
On Sat, 22 Jan 2022 11:47:22 +0000
"\(unmatched-parenthesis via Guix-patches" via <guix-patches@gnu.org>
wrote:

Toggle quote (2 lines)
> * gnu/packages/wm.scm(python-i3ipc): New variable.

I'm closing this ticket, as it has the same content as #56717, which
was already applied as commits

86da72fb5b3a35a30660e81084ed0c90ec5af08f
515288874ff12c00ca8d1d22a94ef4b4903fec76

Björn
-----BEGIN PGP SIGNATURE-----

iF0EAREKAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCYzC5fgAKCRC/KGy2WT5f
/dauAJ4hPKnh/HIOcE0ffdYLSq8CN1ViQwCdFMUIJa6RlmEyeezcrsx4sbKrFq4=
=F3gd
-----END PGP SIGNATURE-----


Closed
?