[PATCH 0/3] gnu: ddcutil: Update to 1.2.1.

  • Done
  • quality assurance status badge
Details
3 participants
  • Brice Waegeneire
  • Ludovic Courtès
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Brice Waegeneire
Severity
normal
B
B
Brice Waegeneire wrote on 22 Jan 2022 00:13
(address . guix-patches@gnu.org)
20220121231316.8253-1-brice@waegenei.re
This patchset supersedes https://bugs.gnu.org/48984.

Brice Waegeneire (3):
gnu: i2c-tools: Update to 4.3.
gnu: ddcutil: Update to 1.2.1.
gnu: ddcui: Update to 0.2.0.

gnu/packages/admin.scm | 2 +-
gnu/packages/hardware.scm | 12 +++++++-----
gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++------
3 files changed, 35 insertions(+), 12 deletions(-)


base-commit: 98a322e02ef1d6c834fdb16a84162882245c0da2
--
2.34.0
B
B
Brice Waegeneire wrote on 22 Jan 2022 00:23
[PATCH 1/3] gnu: i2c-tools: Update to 4.3.
(address . 53431@debbugs.gnu.org)
20220121232306.12976-1-brice@waegenei.re
* gnu/packages/linux.scm (i2c-tools): Update to 4.3.
[arguments]: Up case "prefix" make-flag and add "LDFLAGS".
(i2c-tools-3): New variable.
* gnu/packages/admin.scm (novena-eeprom)[inputs]: Replace "i2c-tools" by
"i2c-tools-3".
---
gnu/packages/admin.scm | 2 +-
gnu/packages/linux.scm | 33 +++++++++++++++++++++++++++------
2 files changed, 28 insertions(+), 7 deletions(-)

Toggle diff (83 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index ed66e358ea..88e514b0c6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -4753,7 +4753,7 @@ (define-public novena-eeprom
(install-file "novena-eeprom" out-bin)
(install-file "novena-eeprom.8" out-share-man)))))))
(inputs
- (list i2c-tools))
+ (list i2c-tools-3))
(synopsis "Novena EEPROM editor")
(description "This package provides an editor for the Novena EEPROM.
Novena boards contain a device-dependent descriptive EEPROM that defines
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c044f2543d..e08eac1668 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -35,7 +35,7 @@
;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Stefan Stefanovi? <stefanx2ovic@gmail.com>
-;;; Copyright © 2019, 2020, 2021 Brice Waegeneire <brice@waegenei.re>
+;;; Copyright © 2019-2022 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2020, 2021 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
@@ -4430,21 +4430,22 @@ (define-public iucode-tool
(define-public i2c-tools
(package
(name "i2c-tools")
- (version "3.1.1")
+ (version "4.3")
(source (origin
(method url-fetch)
(uri (string-append
"http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
+ "1y0fphjd5ah2j886x8i175r7viq0hmx666hyca0wi4dzrm290qxk"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no 'check' target
#:make-flags
- ,#~(list (string-append "prefix=" #$output)
- (string-append "CC=" #$(cc-for-target)))
+ ,#~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
;; No configure script.
#:phases (modify-phases %standard-phases (delete 'configure))))
(inputs
@@ -4458,6 +4459,26 @@ (define-public i2c-tools
SMBus access.")
(license license:gpl2+)))
+;; Needed for novena-eeprom
+(define-public i2c-tools-3
+ (package
+ (inherit i2c-tools)
+ (version "3.1.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
+ (arguments
+ `(#:make-flags
+ ,#~(list (string-append "prefix=" #$output)
+ (string-append "CC=" #$(cc-for-target)))
+ ,@(strip-keyword-arguments '(#:make-flags)
+ (package-arguments i2c-tools))))))
+
(define-public xsensors
(package
(name "xsensors")
--
2.34.0
M
M
Maxim Cournoyer wrote on 22 Jan 2022 04:38
Re: bug#53431: [PATCH 0/3] gnu: ddcutil: Update to 1.2.1.
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 53431@debbugs.gnu.org)
87iluc8mo4.fsf_-_@gmail.com
Hello Brice!

Brice Waegeneire <brice@waegenei.re> writes:

Toggle quote (2 lines)
> * gnu/packages/linux.scm (i2c-tools): Update to 4.3.
> [arguments]: Up case "prefix" make-flag and add "LDFLAGS".
^ the ^ make flag

[...]

Toggle quote (26 lines)
> @@ -4430,21 +4430,22 @@ (define-public iucode-tool
> (define-public i2c-tools
> (package
> (name "i2c-tools")
> - (version "3.1.1")
> + (version "4.3")
> (source (origin
> (method url-fetch)
> (uri (string-append
> "http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
> - version ".tar.bz2"))
> + version ".tar.xz"))
> (sha256
> (base32
> - "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
> + "1y0fphjd5ah2j886x8i175r7viq0hmx666hyca0wi4dzrm290qxk"))))
> (build-system gnu-build-system)
> (arguments
> `(#:tests? #f ; no 'check' target
> #:make-flags
> - ,#~(list (string-append "prefix=" #$output)
> - (string-append "CC=" #$(cc-for-target)))
> + ,#~(list (string-append "PREFIX=" #$output)
> + (string-append "CC=" #$(cc-for-target))
> + (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))

Why is this ld directive needed? They don't use it in Nix, for
instance. A comment would be helpful.

Toggle quote (7 lines)
> ;; No configure script.
> #:phases (modify-phases %standard-phases (delete 'configure))))
> (inputs
> @@ -4458,6 +4459,26 @@ (define-public i2c-tools
> SMBus access.")
> (license license:gpl2+)))

Looking at the Nix package definition, they do some other things that we
don't have, which we perhaps should:

Toggle snippet (42 lines)
postPatch = ''
substituteInPlace eeprom/decode-edid \
--replace "/usr/sbin/parse-edid" "${read-edid}/bin/parse-edid"

substituteInPlace stub/i2c-stub-from-dump \
--replace "/sbin/" ""
;--8<---------------cut here---------------end--------------->8---

They patch a reference to parse-edid and strip the '/sbin/' prefix from
some other place.

> +;; Needed for novena-eeprom
^. (ending period)
> +(define-public i2c-tools-3
> + (package
> + (inherit i2c-tools)
> + (version "3.1.1")
> + (source (origin
> + (method url-fetch)
> + (uri (string-append
> + "http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
> + version ".tar.bz2"))
> + (sha256
> + (base32
> + "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
> + (arguments
> + `(#:make-flags
> + ,#~(list (string-append "prefix=" #$output)
> + (string-append "CC=" #$(cc-for-target)))
> + ,@(strip-keyword-arguments '(#:make-flags)
> + (package-arguments i2c-tools))))))
> +
> (define-public xsensors
> (package
> (name "xsensors")

The rest LGTM!

Thanks,

Maxim
M
M
Maxim Cournoyer wrote on 23 Jan 2022 03:35
(name . Brice Waegeneire)(address . brice@waegenei.re)(address . 53431@debbugs.gnu.org)
87y2376uxo.fsf@gmail.com
Hi Brice,

Brice Waegeneire <brice@waegenei.re> writes:

Toggle quote (7 lines)
> This patchset supersedes https://bugs.gnu.org/48984.
>
> Brice Waegeneire (3):
> gnu: i2c-tools: Update to 4.3.
> gnu: ddcutil: Update to 1.2.1.
> gnu: ddcui: Update to 0.2.0.

It seems the patches for ddcutil and ddcui have yet to come.

Thanks,

Maxim
B
B
Brice Waegeneire wrote on 12 Feb 2022 10:17
[PATCH 3/3] gnu: ddcui: Update to 0.2.0.
(address . 53431@debbugs.gnu.org)
20220212091709.26436-1-brice@waegenei.re
* gnu/packages/hardware.scm (ddcui): Update to 0.2.0.
---
gnu/packages/hardware.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index e49dec49e0..f8c3cc5c57 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -226,7 +226,7 @@ (define-public ddcutil
(define-public ddcui
(package
(name "ddcui")
- (version "0.1.2")
+ (version "0.2.0")
(source
(origin
(method git-fetch)
@@ -235,7 +235,7 @@ (define-public ddcui
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0myma1zw6dlygv3xbin662d91zcnwss10syf12q2fppkrd8qdgqf"))))
+ (base32 "0da56w5yfmd4zx44gwzx1r0y0hwwicr69wxr434l78z9c7j877kn"))))
(build-system cmake-build-system)
(arguments
'(#:tests? #f)) ; No test suite
--
2.34.0
L
L
Ludovic Courtès wrote on 6 Mar 2022 22:42
Re: bug#53431: [PATCH 0/3] gnu: ddcutil: Update to 1.2.1.
(name . Brice Waegeneire)(address . brice@waegenei.re)
87k0d6iwqj.fsf_-_@gnu.org
Hi Brice,

Did you have a chance to look into this for a v2?


Ludo’.

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

Toggle quote (91 lines)
> Hello Brice!
>
> Brice Waegeneire <brice@waegenei.re> writes:
>
>> * gnu/packages/linux.scm (i2c-tools): Update to 4.3.
>> [arguments]: Up case "prefix" make-flag and add "LDFLAGS".
> ^ the ^ make flag
>
> [...]
>
>> @@ -4430,21 +4430,22 @@ (define-public iucode-tool
>> (define-public i2c-tools
>> (package
>> (name "i2c-tools")
>> - (version "3.1.1")
>> + (version "4.3")
>> (source (origin
>> (method url-fetch)
>> (uri (string-append
>> "http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
>> - version ".tar.bz2"))
>> + version ".tar.xz"))
>> (sha256
>> (base32
>> - "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
>> + "1y0fphjd5ah2j886x8i175r7viq0hmx666hyca0wi4dzrm290qxk"))))
>> (build-system gnu-build-system)
>> (arguments
>> `(#:tests? #f ; no 'check' target
>> #:make-flags
>> - ,#~(list (string-append "prefix=" #$output)
>> - (string-append "CC=" #$(cc-for-target)))
>> + ,#~(list (string-append "PREFIX=" #$output)
>> + (string-append "CC=" #$(cc-for-target))
>> + (string-append "LDFLAGS=-Wl,-rpath=" #$output "/lib"))
>
> Why is this ld directive needed? They don't use it in Nix, for
> instance. A comment would be helpful.
>
>> ;; No configure script.
>> #:phases (modify-phases %standard-phases (delete 'configure))))
>> (inputs
>> @@ -4458,6 +4459,26 @@ (define-public i2c-tools
>> SMBus access.")
>> (license license:gpl2+)))
>
> Looking at the Nix package definition, they do some other things that we
> don't have, which we perhaps should:
>
> --8<---------------cut here---------------start------------->8---
> postPatch = ''
> substituteInPlace eeprom/decode-edid \
> --replace "/usr/sbin/parse-edid" "${read-edid}/bin/parse-edid"
>
> substituteInPlace stub/i2c-stub-from-dump \
> --replace "/sbin/" ""
> ;--8<---------------cut here---------------end--------------->8---
>
> They patch a reference to parse-edid and strip the '/sbin/' prefix from
> some other place.
>
>> +;; Needed for novena-eeprom
> ^. (ending period)
>> +(define-public i2c-tools-3
>> + (package
>> + (inherit i2c-tools)
>> + (version "3.1.1")
>> + (source (origin
>> + (method url-fetch)
>> + (uri (string-append
>> + "http://jdelvare.nerim.net/mirror/i2c-tools/i2c-tools-"
>> + version ".tar.bz2"))
>> + (sha256
>> + (base32
>> + "000pvg995qy1b15ks59gd0klri55hb33kqpg5czy84hw1pbdgm0l"))))
>> + (arguments
>> + `(#:make-flags
>> + ,#~(list (string-append "prefix=" #$output)
>> + (string-append "CC=" #$(cc-for-target)))
>> + ,@(strip-keyword-arguments '(#:make-flags)
>> + (package-arguments i2c-tools))))))
>> +
>> (define-public xsensors
>> (package
>> (name "xsensors")
>
> The rest LGTM!
>
> Thanks,
>
> Maxim
M
M
Maxim Cournoyer wrote on 28 Sep 2022 21:26
(name . Ludovic Courtès)(address . ludo@gnu.org)
87a66jti5l.fsf_-_@gmail.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
> Hi Brice,
>
> Did you have a chance to look into this for a v2?
>
> https://issues.guix.gnu.org/53431

I see all components here are now at version past what was sent here,
thus I'm closing this ticket.

Thanks,

Maxim
Closed
?