[PATCH 0/4] Update tdlib and telega packages

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Andrew Tropin
Severity
normal
A
A
Andrew Tropin wrote on 20 Jan 2022 12:45
(address . guix-patches@gnu.org)
87tudyipzg.fsf@trop.in
tdlib and telega are inteded to be used from specific commits not tags, I keep
revision and commit parameters for those packages to make it easier to update
them to untagged commits in the future.


Also, updated the style for arguments.

Andrew Tropin (4):
gnu: tdlib: Update to 1.8.0.
gnu: telega: Update to 0.8.01.
gnu: tdlib: Use new package style.
gnu: telega: Use new package style.

gnu/packages/emacs-xyz.scm | 88 +++++++++++++++++++-------------------
gnu/packages/messaging.scm | 38 ++++++++--------
2 files changed, 65 insertions(+), 61 deletions(-)
From c64a936ba458676cee41a11a42202fda13dda8cb Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 20 Jan 2022 11:56:11 +0300
Subject: [PATCH 1/4] gnu: tdlib: Update to 1.8.0.

* gnu/packages/messaging.scm (tdlib): Update to 1.8.0.
---
gnu/packages/messaging.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2fe0d35a10..843dba2c61 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2593,10 +2593,11 @@ (define-public telegram-purple
(license license:gpl2+)))
(define-public tdlib
- (let ((commit "34ba9b21f365b8d3bdc36808c2d665ca5cd128f6"))
+ (let ((commit "b3ab664a18f8611f4dfcd3054717504271eeaa7a")
+ (revision "1"))
(package
(name "tdlib")
- (version "1.7.10")
+ (version (git-version "1.8.0" revision commit))
(source
(origin
(method git-fetch)
@@ -2604,7 +2605,7 @@ (define-public tdlib
(url "https://github.com/tdlib/td")
(commit commit)))
(sha256
- (base32 "06fbdh1jypz0p1rf6xbpias4kx7xplq9xjd9vz177vwj9icq3wki"))
+ (base32 "19psqpyh9a2kzfdhgqkirpif4x8pzy89phvi59dq155y30a3661q"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
--
2.34.0
From 84d1bce32f1a18f1e733499f5dc9dd4bb8374aba Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 20 Jan 2022 11:56:22 +0300
Subject: [PATCH 2/4] gnu: telega: Update to 0.8.01.

* gnu/packages/emacs-xyz.scm (emacs-telega-server): Update to 0.8.01.
---
gnu/packages/emacs-xyz.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b317d4dc58..ed58989f56 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26807,11 +26807,11 @@ (define-public emacs-helm-switch-to-repl
(license license:gpl3+)))
(define-public emacs-telega-server
- (let ((commit "b4a5e206bd259f3d7f7633a725b2990704d6a1e8")
+ (let ((commit "5739794d2d0c8a4e7b77c2e37a097e19f80ac9f0")
(revision "1"))
(package
(name "emacs-telega-server")
- (version (git-version "0.7.15" revision commit))
+ (version (git-version "0.8.01" revision commit))
(source
(origin
(method git-fetch)
@@ -26819,7 +26819,7 @@ (define-public emacs-telega-server
(url "https://github.com/zevlg/telega.el")
(commit commit)))
(sha256
- (base32 "0gr4nmpk175hxmj357bpzaqywbjc6dmmvfxnyzkh884vyzbwdxlc"))
+ (base32 "1am0b2bjjkw7zd0yq39v015a08dcbk43j4d4h8y2q8hj53ryfk5a"))
(file-name (git-file-name "emacs-telega" version))
(patches
(search-patches "emacs-telega-path-placeholder.patch"
--
2.34.0
From 4234d27ed60796b6c4927fdd378e75f6cdafa057 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 20 Jan 2022 13:27:15 +0300
Subject: [PATCH 3/4] gnu: tdlib: Use new package style.

* gnu/packages/messaging.scm (tdlib): Use gexps, remove trailing #t.
---
gnu/packages/messaging.scm | 31 ++++++++++++++++---------------
1 file changed, 16 insertions(+), 15 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 843dba2c61..f2d518fdf5 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2609,21 +2609,22 @@ (define-public tdlib
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #t
- #:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
- #t)))))
+ (list
+ #:tests? #t
+ #:configure-flags
+ #~(list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") ""))
+ )))))
(native-inputs
(list gperf openssl zlib php doxygen))
(synopsis "Cross-platform library for building Telegram clients")
--
2.34.0
--
2.34.0
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmHpTPMPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6w8TcP/3CaJrlmx9puLy+ectm9TN+lIG79k1In9zPi
W09+xLg4PpU7abSJ/a73ovTjqDjQnmI9eZ3ZPj0vaS9Q9gsp1f004ZpTV1oxk0V4
l4xzuRdUZEk0wQU9Y+xrYZeZXzcIaw2rU/w9rQ77HD0cSL6At5YDsf4ZEVGuEfQb
YIlZmszmYu7I0FzcMeNnQBXILu63oRPklC7nSUuXnIjXJwYpagCUp2AXn2mgfnhY
JBk5XaIkVPgUO3rySVFgEr3O9yZwSYtCwl8Q0IgiuugOuKKHs6aZ8K68gyB3gJrG
R4o+IMStILQINRcmeN7tzmPWmo1CuSss3fTxd1jTvuquaN0Gqpee+yrWrQsv+c7w
86yxLecYqbrSnld8W5+ZcjcV79IFaJ148NsW3TWi5i1fVH/DGwUME4xNjrkea8pS
8DTFg3cWSlYck0Vhf+cOwjxB7YLZWq0OVXAlcrnvwaMQpF7kIF92P6ZhlEEDtp+C
RYPVUW/ynNxjXjCWoDNV+DuDZiBJN7yaqMxl+PmDrkUwr9Bc2crgR8KXOFZIk9wi
SPG5j2t2sFI3wqt6Ghu+PI1qKji1LIbqR9eIhdy+mRAqEWP/9ZvlSRjf4ko1dnqA
3h9WXjp1YOu6bRgMxEch9KfeIOUChU/6BRFLvnjWvfUw8lfGkXVcsO3rUhwOuGFm
jJhHgFyt
=DiBi
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 22 Jan 2022 16:14
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
ae04bce2f0563f21c67ba6c9726fb03bd352edfa.camel@gmail.com
Hi Andrew,

Am Donnerstag, dem 20.01.2022 um 14:45 +0300 schrieb Andrew Tropin:
Toggle quote (7 lines)
> tdlib and telega are inteded to be used from specific commits not
> tags, I keep revision and commit parameters for those packages to
> make it easier to update them to untagged commits in the future.
>
> https://github.com/tdlib/td/issues/1790
>
> Also, updated the style for arguments.
It appears Telega was already updated through a different patch. The
style adjustments are still relevant, but fail to apply currently.

As for commit vs. tag, I've CC'd Nicolas to make a more informed
decision. I do understand your reasoning, but OTOH I disagree with
Telegram's "every commit is as good as a release" stance, particularly
if there's a widely used client whose releases fail in CI :)
A
A
Andrew Tropin wrote on 27 Jan 2022 08:54
87ee4tsjfd.fsf@trop.in
CCed: avityazev, zevlg

On 2022-01-22 16:14, Liliana Marie Prikler wrote:

Toggle quote (14 lines)
> Hi Andrew,
>
> Am Donnerstag, dem 20.01.2022 um 14:45 +0300 schrieb Andrew Tropin:
>> tdlib and telega are inteded to be used from specific commits not
>> tags, I keep revision and commit parameters for those packages to
>> make it easier to update them to untagged commits in the future.
>>
>> https://github.com/tdlib/td/issues/1790
>>
>> Also, updated the style for arguments.
> It appears Telega was already updated through a different patch. The
> style adjustments are still relevant, but fail to apply currently.
>

Updated patches.

Toggle quote (6 lines)
>
> As for commit vs. tag, I've CC'd Nicolas to make a more informed
> decision. I do understand your reasoning, but OTOH I disagree with
> Telegram's "every commit is as good as a release" stance, particularly
> if there's a widely used client whose releases fail in CI :)

I agree, tdlib rolling release seems a little strange to me and I
personally not in a favor of it. I still propose to keep commit and
revision variables for both tdlib and telega to be able to update them
from time to time to a fresh version, which surely won't have a release
tag.
From 90a77ee77aa4f339c9cee978e96ee72e1316bcd9 Mon Sep 17 00:00:00 2001
From: Andrew Tropin <andrew@trop.in>
Date: Thu, 20 Jan 2022 13:27:15 +0300
Subject: [PATCH 2/2] gnu: tdlib: Use new package style.

* gnu/packages/messaging.scm (tdlib): Use gexps, remove trailing #t.
---
gnu/packages/messaging.scm | 29 +++++++++++++++--------------
1 file changed, 15 insertions(+), 14 deletions(-)

Toggle diff (42 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 768642f119..01316f8bd2 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2612,20 +2612,21 @@ (define-public tdlib
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #t
- #:configure-flags
- (list "-DCMAKE_BUILD_TYPE=Release"
- "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'remove-failing-tests
- (lambda _
- (substitute* "test/CMakeLists.txt"
- ;; The test cases are compiled into a distinct binary
- ;; which uses mtproto.cpp to attempt to connect to
- ;; a remote server. Removing this file from the sources
- ;; list disables those specific test cases.
- (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
+ (list
+ #:tests? #t
+ #:configure-flags
+ #~(list "-DCMAKE_BUILD_TYPE=Release"
+ "-DTD_ENABLE_LTO=OFF") ; FIXME: Get LTO to work.
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-tests
+ (lambda _
+ (substitute* "test/CMakeLists.txt"
+ ;; The test cases are compiled into a distinct binary
+ ;; which uses mtproto.cpp to attempt to connect to
+ ;; a remote server. Removing this file from the sources
+ ;; list disables those specific test cases.
+ (("\\$\\{CMAKE_CURRENT_SOURCE_DIR\\}/mtproto.cpp") "")))))))
(native-inputs
(list gperf openssl zlib php doxygen))
(synopsis "Cross-platform library for building Telegram clients")
--
2.34.0
--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQJDBAEBCgAtFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmHyT6YPHGFuZHJld0B0
cm9wLmluAAoJECII0glYwd6wovYP/1sM9pTpRvgOn/tkIZJK88lfJadDDcMUlda+
KXIOHEUsH5yOr2GU+QW3ii4T57RiVRMIBuXOtk92OX1PmhMrKjFl9PElNOpw8gwb
Xhvq0LPc6gXg2FU//mkXWeN/fG0EF9zDpUO0chfbLbZNZDzAPejSMvbzcRVSO67c
0ZJkDRNG0uUYGOb4eLCMwWA/pZTR8M0/VgznfreaXhUqoGhXc5HOCmFVjIBrhN5N
tcaGZ1JZD8B9Z5qXLNVSwA119HFSkw24MAK74Fld6AD5OR4OTUEqMIIipWILf9RF
ulsYTIrRXPp18B1kaqNOQ9O603aEJffM7vKjjvS+cLq9Ajs1iHuz/5ZNiF9bkkJp
d12i/sUCWvUidQ8WMis4FpkkdrqKtq0uxWX8PQW8Ywnco4dZt6pYaC+QWLvcZEr2
/WfVt87Oi+T0Yd6Tb+m2evKaWwQN2FAtcFMXKs1eL5VI+IeFawToxP/GQlhceKei
3E1/oMMSki2XXum1VFX1xbQ8l22RCihEpWXOp1Xf1Lmttt8dFx977s9CDnLsEF5i
u1XPY8i1ovFsGnFp9YKGonkvnam6KFjDKeAyi7Jv7EVrtD5y8NuKQM60IuWnPCyz
XqMknX4iPthIY3B6Y4YPnR/rx1O2vFDI7s58QGiKdcV+R6lZTyX9xji5du9kTced
OVojp/5C
=YGRn
-----END PGP SIGNATURE-----

L
L
Liliana Marie Prikler wrote on 26 Nov 2022 13:58
79a67632531acfefcf781bdc942b2f60c3f3619e.camel@gmail.com
Hi Andrew,

sorry for not reacting earlier. Is this patch still "fresh and
relevant"? Should we aim for newer versions?

Am Donnerstag, dem 27.01.2022 um 10:54 +0300 schrieb Andrew Tropin:
Toggle quote (35 lines)
> CCed: avityazev, zevlg
>
> On 2022-01-22 16:14, Liliana Marie Prikler wrote:
>
> > Hi Andrew,
> >
> > Am Donnerstag, dem 20.01.2022 um 14:45 +0300 schrieb Andrew Tropin:
> > > tdlib and telega are inteded to be used from specific commits not
> > > tags, I keep revision and commit parameters for those packages to
> > > make it easier to update them to untagged commits in the future.
> > >
> > > https://github.com/tdlib/td/issues/1790
> > >
> > > Also, updated the style for arguments.
> > It appears Telega was already updated through a different patch. 
> > The style adjustments are still relevant, but fail to apply
> > currently.
> >
>
> Updated patches.
>
> >
> > As for commit vs. tag, I've CC'd Nicolas to make a more informed
> > decision.  I do understand your reasoning, but OTOH I disagree with
> > Telegram's "every commit is as good as a release" stance,
> > particularly if there's a widely used client whose releases fail in
> > CI :)
>
> I agree, tdlib rolling release seems a little strange to me and I
> personally not in a favor of it.  I still propose to keep commit and
> revision variables for both tdlib and telega to be able to update
> them from time to time to a fresh version, which surely won't have a
> release tag.
>
>
A
A
Andrew Tropin wrote on 28 Nov 2022 06:43
87pmd7d47m.fsf@trop.in
On 2022-11-26 13:58, Liliana Marie Prikler wrote:

Toggle quote (43 lines)
> Hi Andrew,
>
> sorry for not reacting earlier. Is this patch still "fresh and
> relevant"? Should we aim for newer versions?
>
> Am Donnerstag, dem 27.01.2022 um 10:54 +0300 schrieb Andrew Tropin:
>> CCed: avityazev, zevlg
>>
>> On 2022-01-22 16:14, Liliana Marie Prikler wrote:
>>
>> > Hi Andrew,
>> >
>> > Am Donnerstag, dem 20.01.2022 um 14:45 +0300 schrieb Andrew Tropin:
>> > > tdlib and telega are inteded to be used from specific commits not
>> > > tags, I keep revision and commit parameters for those packages to
>> > > make it easier to update them to untagged commits in the future.
>> > >
>> > > https://github.com/tdlib/td/issues/1790
>> > >
>> > > Also, updated the style for arguments.
>> > It appears Telega was already updated through a different patch. 
>> > The style adjustments are still relevant, but fail to apply
>> > currently.
>> >
>>
>> Updated patches.
>>
>> >
>> > As for commit vs. tag, I've CC'd Nicolas to make a more informed
>> > decision.  I do understand your reasoning, but OTOH I disagree with
>> > Telegram's "every commit is as good as a release" stance,
>> > particularly if there's a widely used client whose releases fail in
>> > CI :)
>>
>> I agree, tdlib rolling release seems a little strange to me and I
>> personally not in a favor of it.  I still propose to keep commit and
>> revision variables for both tdlib and telega to be able to update
>> them from time to time to a fresh version, which surely won't have a
>> release tag.
>>
>>
>

Hi Liliana,

version update seems outdated, emacs-telega-server and tdlib styles
updates outdated as well.

But emacs-telega and emacs-telega-contrib style updates looks relevant
and still applies. Slightly updated the patch, applied, pushed.

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmOESm0ACgkQIgjSCVjB
3rCGxQ/9GNEDij8pZZebemSyZfSH8s4JAcxf+h31x8bfc0c1CQKcRM2uvMVJXgWU
gx2vkfZfG7OgYqU8w8hJ637sa3rT61odQ6CyICGgSlccts0mju334WlSy7+/QaN+
nlwMpPJXc88AgSOnJKKqMpjDjQ4IPs/BjMYybmPwMg0O6js5Gc5YIb+/shswH60g
Eg044eZV0veIWZJYGuubGDgfBFvHkM/Z1XEHk3rGn33xl8kDcfdr8tHr+ER9M/eI
zNX43RcSezWxaPw5AvSgAaCQQd40iJYOysR/IwYpMwqQRHcEYJ9WxIu0hxCbX0Kf
/Umlzp2EEa1ykgnjBL0O4XUxBtnJHQ3cFC/0+lgftVzDBs9B/qdrH0+rx1pEsnAv
bxfzm3PHAxKRYv58TmpgPHT5AYJBmPeM81EArx72gYtBeCIkk9zGg26LyJFXIgeR
FUD+TXT7o4lrSpie0RB+xjnhnQULgVSwoz2AhTxgV1VPL/aWRi83ohNn/olarFN1
dd8GiIhPDfa5RGcNLMJxxGCSMs2CeDthYpOGo0cflpS144j0QlDY65a6ytSbo4xM
ePkSoTp2RDp4NqxGvOTU9sWFUYMl4/x8WGOvQNCT5VQj2ug0j9sGpmUjdPsLlNAU
Xao25HnpThS1HWGloQHkcE3RSK1uDFs218/eDvP3lgMEjg9t3Uw=
=PLl/
-----END PGP SIGNATURE-----

A
A
Andrew Tropin wrote on 28 Nov 2022 07:38
Applied
(address . control@debbugs.gnu.org)
8735a3k2i7.fsf@trop.in
close 53387
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmOEV1AACgkQIgjSCVjB
3rD64RAAirHmz6RUioOdyv7+D/0xWjQIxj4jJKFYQ5x9W49R+k0Ca7BfqmQXBmcB
HnuK4lV0XOmilappIHixpw9gCPvNcMwAbFFeK+c0icoli2vM55yVYDkqLoyVJI8P
ck+4i9z/qkdPmqbi9p7ic3vvZ5G1KCqkzUOgql6E2zj3g7mWoRccP8i9zqR2c8kg
OwbMpGMGqYgnl9Dp86metLfvsA3WsZ93Q/JOjgPXZ7JWz0X084y/qCWsfP/R3kZC
jLIY/hlNsildTD0bg8Rb6N82LTk2f9NSpXyC0aL9ATnX+RdvUNeqtX+0saac6YV8
+6lwmUBjbspVdMUDlS727jLKf4OGecNC3VCECwvIvEY9W2JNjUbSUfG6tbAqoU9B
Ui775f/qYf6uXvab/0YeZZ2vCzAvaC04pz1wUb4vkPEDDe1A0zv3bKWZtbSZHvUC
hGVTRNz3KNjroVHGaKZ5hpRtYH14Nfb+a5dtQez2p3Mgf4yfV4EYfmcRuxkEL8T+
4js6MptUNrkOwVsM1UA8AiDY7cOOkYI/c98vyP41t/GLK8TghF+z7BCb/olQ93p3
o8Vty/kVsX2XZcCAtFMC1HnX1JvDzjl3EOhbil7rmstp1j3koFpQUOZv+gRO8kOh
01sQwVHemtx2qC90/wRpCGs6yraKKVEyn/Tp0EWzQNwwMDnm2Qo=
=RnFf
-----END PGP SIGNATURE-----

?