[PATCH] build-system/python: Change let* to let.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Maxim Cournoyer
  • Maxime Devos
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 5 Jan 2022 23:46
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20220105224600.9227-1-jgart@dismail.de
* guix/build/python-build-system.scm (site-packages): Change let* to let for
readability and since let* is unused.
---
guix/build/python-build-system.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (25 lines)
diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
index 08871f60cd..a9b1c74f63 100644
--- a/guix/build/python-build-system.scm
+++ b/guix/build/python-build-system.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -176,8 +177,8 @@ (define (python-output outputs)
(define (site-packages inputs outputs)
"Return the path of the current output's Python site-package."
- (let* ((out (python-output outputs))
- (python (assoc-ref inputs "python")))
+ (let ((out (python-output outputs))
+ (python (assoc-ref inputs "python")))
(string-append out "/lib/python" (python-version python) "/site-packages")))
(define (add-installed-pythonpath inputs outputs)
--
2.34.1
M
M
Maxime Devos wrote on 9 Jan 2022 22:03
(address . 53039@debbugs.gnu.org)
0cecb536c6d706cd018a121f6595810b2b374347.camel@telenet.be
retitle [PATCH core-updates-frozen] build-system-python: Change let* to let.
thanks

Toggle quote (6 lines)
>[python-build-system.scm]
> - (let* ((out (python-output outputs))
> - (python (assoc-ref inputs "python")))
> + (let ((out (python-output outputs))
> + (python (assoc-ref inputs "python")))

According to "guix refresh -l python-six", this would rebuild a lot
(at least 3122), so this would need to be done on core-updates. Seems
ok otherwise.
-----BEGIN PGP SIGNATURE-----

iI0EABYKADUWIQTB8z7iDFKP233XAR9J4+4iGRcl7gUCYdtNoxccbWF4aW1lZGV2
b3NAdGVsZW5ldC5iZQAKCRBJ4+4iGRcl7rLeAQCoXB5oWxnPAwXk+Js8bgGARgq9
tGx+X6jevrlXdMcYiQEArv+YRBSP86uOYnQu317fMp20f0cZZDiMQMdRX9dPDQI=
=ZJeD
-----END PGP SIGNATURE-----


M
M
Maxim Cournoyer wrote on 18 May 2022 15:06
Re: bug#53039: [PATCH] build-system/python: Change let* to let.
(name . jgart)(address . jgart@dismail.de)(address . 53039-done@debbugs.gnu.org)
87czgb0z2l.fsf@gmail.com
Hi,

jgart <jgart@dismail.de> writes:

Toggle quote (30 lines)
> * guix/build/python-build-system.scm (site-packages): Change let* to let for
> readability and since let* is unused.
> ---
> guix/build/python-build-system.scm | 5 +++--
> 1 file changed, 3 insertions(+), 2 deletions(-)
>
> diff --git a/guix/build/python-build-system.scm b/guix/build/python-build-system.scm
> index 08871f60cd..a9b1c74f63 100644
> --- a/guix/build/python-build-system.scm
> +++ b/guix/build/python-build-system.scm
> @@ -11,6 +11,7 @@
> ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
> ;;; Copyright © 2021 Lars-Dominik Braun <lars@6xq.net>
> ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
> +;;; Copyright © 2022 jgart <jgart@dismail.de>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -176,8 +177,8 @@ (define (python-output outputs)
>
> (define (site-packages inputs outputs)
> "Return the path of the current output's Python site-package."
> - (let* ((out (python-output outputs))
> - (python (assoc-ref inputs "python")))
> + (let ((out (python-output outputs))
> + (python (assoc-ref inputs "python")))
> (string-append out "/lib/python" (python-version python) "/site-packages")))
>
> (define (add-installed-pythonpath inputs outputs)

As Maxime mentioned, that should go to core-updates. It's nice to use
the --subject-prefix option of 'git format-patch' to change it to
"[PATCH core-updates]", so that we don't apply these mistakenly to
master and cause world rebuilds :-)

Another note; only changes of minimally 10 lines are copyrightable, so
you do not need to add a copyright attribution for trivial changes such
as this one.

I've made the change to core-updates and committed as 47fac5dc59; closing.

Thank you!

Maxim
Closed
J
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 53039-done@debbugs.gnu.org)
20220518235056.GD14290@gac
On Wed, 18 May 2022 09:06:58 -0400 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (2 lines)
> I've made the change to core-updates and committed as 47fac5dc59; closing.

Hi Maxim,

Thank you for doing that. Sorry, I couldn't get to it. I've been in the
onboarding process of starting a new job and moving to a new city and
have been really busy.

Hope to get some free time soon to continue contributing to Guix :)

all best,

jgart
Closed
?