[PATCH] gnu: Add python-facebook-sdk.

  • Open
  • quality assurance status badge
Details
One participant
  • Giacomo Leidi
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 4 Jan 2022 01:30
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20220104003003.861-1-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bc7e21ca85..90193590dd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6264,3 +6264,32 @@ (define-public python-mwparserfromhell
Full documentation may be found at
@uref{https://mwparserfromhell.readthedocs.io, ReadTheDocs}")
(license license:expat)))
+
+(define-public python-facebook-sdk
+ (package
+ (name "python-facebook-sdk")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mobolic/facebook-sdk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests require network access.
+ `(#:tests? #f))
+ (propagated-inputs `(("python-requests" ,python-requests)))
+ (home-page "https://facebook-sdk.readthedocs.io")
+ (synopsis
+ "Facebook Graph API client in Python")
+ (description
+ "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+ (license license:asl2.0)))

base-commit: 0c5a58e34d894b95d94c61aae0525a01fa18ecd2
--
2.34.0
P
(no subject)
(name . 52997)(address . 52997@debbugs.gnu.org)
QK586R.JPL4M6RW610J2@autistici.org
This is a friendly ping :)

Thank you for your time and efforts
Attachment: file
P
friendly ping
(address . 52997@debbugs.gnu.org)
1effa643-0796-3214-6a81-9a3dbbf3a76c@autistici.org
Dear all,

this is just a ping, thank you for your time and efforts . I'm attaching
an updated patchset.

paul
G
G
Giacomo Leidi wrote on 6 Mar 2022 00:28
[PATCH] gnu: Add python-facebook-sdk.
(address . 52997@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20220305232808.23783-1-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 240c58b665..e787c20d7e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6390,3 +6390,32 @@ (define-public python-tweepy
(description "This package provides @code{Tweepy}, an easy-to-use Python
library for accessing the Twitter API.")
(license license:expat)))
+
+(define-public python-facebook-sdk
+ (package
+ (name "python-facebook-sdk")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mobolic/facebook-sdk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests require network access.
+ `(#:tests? #f))
+ (propagated-inputs `(("python-requests" ,python-requests)))
+ (home-page "https://facebook-sdk.readthedocs.io")
+ (synopsis
+ "Facebook Graph API client in Python")
+ (description
+ "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+ (license license:asl2.0)))

base-commit: 0c6bf910efd090f0aa0479ba727e5e68655e9b68
--
2.34.0
G
G
goodoldpaul wrote on 1 Jul 2022 23:43
(address . 52997@debbugs.gnu.org)
8ad1f193ccf6d1a2133f51030f88faab@autistici.org
Dear all,
this is a friendly ping :) . I'm sending an updated patch.


Thank you for your time and effort,

giacomo
G
G
Giacomo Leidi wrote on 1 Jul 2022 23:43
(address . 52997@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20220701214325.17848-1-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6f951595c8..fc61951b3c 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7183,6 +7183,35 @@ (define-public python-tweepy
library for accessing the Twitter API.")
(license license:expat)))
+(define-public python-facebook-sdk
+ (package
+ (name "python-facebook-sdk")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mobolic/facebook-sdk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests require network access.
+ `(#:tests? #f))
+ (propagated-inputs `(("python-requests" ,python-requests)))
+ (home-page "https://facebook-sdk.readthedocs.io")
+ (synopsis
+ "Facebook Graph API client in Python")
+ (description
+ "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+ (license license:asl2.0)))
+
(define-public python-quart
(package
(name "python-quart")

base-commit: aba1ee5553099d45eb22d9ca1f685502146a49d0
--
2.36.1
G
G
goodoldpaul wrote on 12 Apr 2023 23:29
9c336cd6c7a18b66ed3f93c04e96cc6b@autistici.org
Dear all,
this is a friendly ping :) . I'm sending an updated patch.

Thank you for your time and effort,

giacomo
G
G
Giacomo Leidi wrote on 12 Apr 2023 23:30
[PATCH-v2] gnu: Add python-facebook-sdk.
(address . 52997@debbugs.gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20230412213030.20899-1-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-facebook-sdk): New variable.
---
gnu/packages/python-web.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 495e13acfe..9eae6d7616 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7844,6 +7844,35 @@ (define-public python-tweepy
library for accessing the Twitter API.")
(license license:expat)))
+(define-public python-facebook-sdk
+ (package
+ (name "python-facebook-sdk")
+ (version "3.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/mobolic/facebook-sdk")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0p7p0wvcspd9p8d6r25bgjbf0ihdw5g1jw3dylwngrazdmc3g36b"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Tests require network access.
+ `(#:tests? #f))
+ (propagated-inputs `(("python-requests" ,python-requests)))
+ (home-page "https://facebook-sdk.readthedocs.io")
+ (synopsis
+ "Facebook Graph API client in Python")
+ (description
+ "This client library is designed to support the Facebook Graph API and
+the official Facebook JavaScript SDK, which is the canonical way to implement
+Facebook authentication.")
+ (license license:asl2.0)))
+
(define-public python-quart
(package
(name "python-quart")

base-commit: dd3e5e71104a2bcbad80e52e062a144ea96b8c6a
--
2.39.2
?