[PATCH] gnu: Add python-tweepy.

  • Done
  • quality assurance status badge
Details
2 participants
  • Giacomo Leidi
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Giacomo Leidi
Severity
normal
G
G
Giacomo Leidi wrote on 4 Jan 2022 01:12
(address . guix-patches@gnu.org)(name . Giacomo Leidi)(address . goodoldpaul@autistici.org)
20220104001210.21299-1-goodoldpaul@autistici.org
* gnu/packages/python-web.scm (python-tweepy): New variable.
---
gnu/packages/python-web.scm | 35 ++++++++++++++++++++++++++++++++++-
1 file changed, 34 insertions(+), 1 deletion(-)

Toggle diff (54 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bc7e21ca85..00598e8307 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -39,7 +39,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020, 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Konrad Hinsen <konrad.hinsen@fastmail.net>
-;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020, 2022 Giacomo Leidi <goodoldpaul@autistici.org>
;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
@@ -6264,3 +6264,36 @@ (define-public python-mwparserfromhell
Full documentation may be found at
@uref{https://mwparserfromhell.readthedocs.io, ReadTheDocs}")
(license license:expat)))
+
+(define-public python-tweepy
+ (package
+ (name "python-tweepy")
+ (version "4.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/tweepy/tweepy")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jl3j20iqvzqqw5q5ldval5wrc2pdx94zff3b6b87j51yjx3qjhr"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "unittest" "discover" "tests")))))))
+ (propagated-inputs
+ (list python-aiohttp python-requests python-requests-oauthlib))
+ (native-inputs
+ (list python-vcrpy))
+ (home-page "https://www.tweepy.org/")
+ (synopsis "Twitter library for Python")
+ (description "This package provides @code{Tweepy}, an easy-to-use Python
+library for accessing the Twitter API.")
+ (license license:expat)))

base-commit: 01ec5efff7cf95cae69493bd4ccfdd21a38770ae
--
2.34.0
P
(no subject)
(name . 52995)(address . 52995@debbugs.gnu.org)
0L586R.TF8IOSLQNLZ53@autistici.org
This is a friendly ping :)

Thank you for your time and efforts
Attachment: file
V
V
Vagrant Cascadian wrote on 2 Sep 2023 00:01
Re: [bug#52995] [PATCH] gnu: Add python-tweepy.
87edjhsgc6.fsf@wireframe
On 2022-01-04, Giacomo Leidi wrote:
Toggle quote (5 lines)
> +(define-public python-tweepy
> + (package
> + (name "python-tweepy")
> + (version "4.4.0")

This was merged as:

13b905bf28ec6309043bd61c5a92744b13352021 gnu: Add python-tweepy.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJfSgAKCRDcUY/If5cW
qr+1AP0dBTGlpCsFEILXB5845sYJvyDyg8InZlMgb+hbsbvkdQD/UkqQ++Xu/NTY
dh9ULr5HytvejcqOMROauceHz78Ouwc=
=a42q
-----END PGP SIGNATURE-----

Closed
?