[PATCH] gnu: Add fff.

  • Done
  • quality assurance status badge
Details
2 participants
  • Disseminate Dissent
  • Christopher Baines
Owner
unassigned
Submitted by
Disseminate Dissent
Severity
normal
D
D
Disseminate Dissent wrote on 4 Jan 2022 00:41
(name . Guix Patches)(address . guix-patches@gnu.org)
-X2z07KXjc89x192B7wGz4x2HT22XQ9qQr7kH5bPFAJDrxkbYGKpzVsNmQwXQP-DJ9eqVaXsZwGhk5Ktwfa_KeU_NDMyiT_2gwALU5ztkRE=@protonmail.com
Disseminate,
Peace
From 749734fc412def963e590241e85428ed18c516a6 Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Mon, 3 Jan 2022 18:37:55 -0500
Subject: [PATCH] gnu: Add fff.

---
gnu/packages/disk.scm | 47 +++++++++++++++++++++++++++++++++++++++++++
1 file changed, 47 insertions(+)

Toggle diff (67 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index ac8b561e79..1ebc629da7 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -770,6 +771,52 @@ (define-public ranger
automatically finding out which program to use for what file type.")
(license license:gpl3)))
+(define-public fff
+ (package
+ (name "fff")
+ (version "2.2")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dylanaraps/fff")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14ymdw6l6phnil0xf1frd5kgznaiwppcic0v4hb61s1zpf4wrshg"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("bash" ,bash)
+ ("coreutils" ,coreutils)
+ ("file" ,file)))
+ ;; ("xdg-utils" ,xdg-utils)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PKG_CONFIG=" ,(pkg-config-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-inputs
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((file (assoc-ref inputs "file")))
+ (substitute* "fff"
+ (("\\bfile [-\"]" match)
+ (string-append file "/bin/" match))))))
+ (delete 'configure)))) ; no configure script
+ (home-page "https://github.com/dylanaraps/fff")
+ (synopsis "Simple file manager written in bash")
+ (description
+ "@command{fff} (fast file-manager) is a simple, blazing fast and minimal
+file manager for Linux, written in bash. It only requires bash and coreutils,
+and its highly optimized now for efficient performance.")
+ (license license:expat)))
+
(define-public volume-key
(package
(name "volume-key")
--
2.34.0
C
C
Christopher Baines wrote on 22 Nov 2022 10:36
(name . Disseminate Dissent)(address . disseminatedissent@protonmail.com)
87y1s3s51q.fsf@cbaines.net
Apologies for the long delay in looking at this!


This seems OK to me, I've made a few updates to the package definition,
and removed some redudant bits and pushed it to master as
bb67d7d99decd416b0235593913d23aeaddce734.

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmN8mHFfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeDeQ//TBMTgjaISFufu4MP0qEQcj9Udn9DWvFF
hP5wD+sqYSrrVVZi3cVEHJVARO8aB/URMYBnwwKd1t8eHcOBXBZ8Uoyn5bm0Z8re
bvDONtTb+L9XliCghZ/5xD4aecuxeuk5O1f3N3TPPEGrVxlBQdHmcJw07ZYsvppa
sU1+iOU9Up/Oti7H21Nv4l4+nIZHW7/8kebYj9TBkbk3V3nQ2J00b2+5l1vPqMwI
2k5teDc9jvw0tk1zP3f8rVksUheWAUK8Ak3fjk8yeZNvxIydLsESmYMMNb4YlZDP
uYhTQYdZAOyJIT0hvfSvbJuEcA0hmUIASV8ylQmiMyhyiS+6x2abAP7l6aEcgW4I
PwWLrDnhopvbPECv5MLSMIovg27cT27HOKEJ2LbGTkQ2O1Yy1BogjZiuKQ6vFnwG
N7/gqTLS608mjQhuQiinX2pBw3vKYqyfAz5LvYvNqvugPMpQ6+6ybDPMkZXj7tVO
eMppHAiQBWZ4GcoMPqidqcV9L4DO7yad5UufiWQfRnEAYbEzJcL41uLLruVvoZFh
lsCfoeub+mmUE6qzg/CZD8UapaT6cUhPJ+FLJqXIE7ko7Dcnm141dj7OH5w4ibII
k9UTscgT4+Pdvtg6K/Gy0Lg27cEnfVhBekEvC7z5sUkozHb+VCtcHH1McENrGn8X
CCechXORoq8=
=be6Q
-----END PGP SIGNATURE-----

?