[PATCH] gnu: Add go-github-com-dreamacro-go-shadowsocks2

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • ??
Owner
unassigned
Submitted by
??
Severity
normal
?
(address . guix-patches@gnu.org)
cea3eb96-7c63-8471-e5a8-8576d23e0663@gmail.com

From 22a4cad70431f236c41bf1b59ea70c437e09a68f Mon Sep 17 00:00:00 2001
From: Lu Hui <luhux76@gmail.com>
Date: Mon, 3 Jan 2022 12:54:50 +0800
Subject: [PATCH] gnu: Add go-github-com-dreamacro-go-shadowsocks2

* gnu/packages/golang.scm (go-github-com-dreamacro-go-shadowsocks2): New variable.
---
gnu/packages/golang.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1ac80f52ad..b1d18e333b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2021 Chadwain Holness <chadwainholness@gmail.com>
;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
+;;; Copyright © 2021 Lu Hui <luhux76@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9236,3 +9237,33 @@ (define-public go-github-com-alecthomas-units
"This library provides unit multipliers and functions for Go.")
(home-page "https://github.com/alecthomas/units")
(license license:expat))))
+
+(define-public go-github-com-dreamacro-go-shadowsocks2
+ (package
+ (name "go-github-com-dreamacro-go-shadowsocks2")
+ (version "0.1.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Dreamacro/go-shadowsocks2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0sjr3r77fav6q0ii6dnp4px9gaz7cq861a0yxppvb6a58420bx3h"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/Dreamacro/go-shadowsocks2"))
+ (propagated-inputs `(("go-golang-org-x-crypto" ,go-golang-org-x-crypto)))
+ (home-page "https://github.com/Dreamacro/go-shadowsocks2")
+ (synopsis "Shadowsocks implementation in Go")
+ (description
+ "This package is @code{shadowsocks} implementation in Go
+
+Features:
+@itemize
+@item SOCKS5 proxy
+@item Support for Netfilter TCP redirect (IPv6 should work but not tested)
+@item UDP tunneling (e.g. relay DNS packets)
+@item TCP tunneling (e.g. benchmark with iperf3)
+@end itemize")
+ (license license:asl2.0)))
--
2.34.0
L
L
Ludovic Courtès wrote on 15 Feb 2022 15:57
(name . ??)(address . luhux76@gmail.com)(address . 52972-done@debbugs.gnu.org)
87v8xgyy7h.fsf@inria.fr
Hi,

?? <luhux76@gmail.com> skribis:

Toggle quote (7 lines)
> From 22a4cad70431f236c41bf1b59ea70c437e09a68f Mon Sep 17 00:00:00 2001
> From: Lu Hui <luhux76@gmail.com>
> Date: Mon, 3 Jan 2022 12:54:50 +0800
> Subject: [PATCH] gnu: Add go-github-com-dreamacro-go-shadowsocks2
>
> * gnu/packages/golang.scm (go-github-com-dreamacro-go-shadowsocks2): New variable.

Applied after running ‘guix style’, thanks!

Ludo’.
Closed
?