[PATCH] gnu: Add go-github-com-mvdan-gofumpt.

  • Done
  • quality assurance status badge
Details
4 participants
  • (
  • Philip Kaludercic
  • Sharlatan Hellseher
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Philip Kaludercic
Severity
normal
P
P
Philip Kaludercic wrote on 31 Dec 2021 15:54
(address . guix-patches@gnu.org)(name . Philip Kaludercic)(address . philipk@posteo.net)
20211231145444.5676-1-philipk@posteo.net
* golang.scm (go-github-com-mvdan-gofumpt): New variable.
---
gnu/packages/golang.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 1223887bf2..d289bd54ad 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -8846,3 +8846,35 @@ (define-public go-github-com-arceliar-ironwood
@url{https://github.com/yggdrasil-network/yggdrasil-go,Yggdrasil}, but it may
be useful for other network applications.")
(license license:mpl2.0)))
+
+(define-public go-github-com-mvdan-gofumpt
+ (package
+ (name "go-github-com-mvdan-gofumpt")
+ (version "0.2.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mvdan/gofumpt")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rczlicfvvhvx8l3ngcd04mjam80mb5ay0vrim9w2max04kyairn"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "github.com/mvdan/gofumpt"))
+ (propagated-inputs
+ `(("go-golang-org-x-tools" ,go-golang-org-x-tools)
+ ("go-golang-org-x-sys" ,go-golang-org-x-sys)
+ ("go-golang-org-x-mod" ,go-golang-org-x-mod)
+ ("go-github-com-rogpeppe-go-internal"
+ ,go-github-com-rogpeppe-go-internal)
+ ("go-github-com-google-go-cmp" ,go-github-com-google-go-cmp)
+ ("go-github-com-frankban-quicktest"
+ ,go-github-com-frankban-quicktest)))
+ (home-page "https://github.com/mvdan/gofumpt")
+ (synopsis "gofumpt")
+ (description
+ "Enforce a stricter format than @code{gofmt}, while being backwards compatible.
+That is, @code{gofumpt} is happy with a subset of the formats that @code{gofmt}
+is happy with.")
+ (license license:bsd-3)))
--
2.34.0
S
S
Sharlatan Hellseher wrote on 13 Aug 2022 16:25
(address . 52915@debbugs.gnu.org)
CAO+9K5quXqR5Y6XfBRnEr8Tg-3FgSfjXWSBsoNTt2jva9oGedg@mail.gmail.com
Hi Guix team!
Is there any objection to accept this package?
It's a part of inputs for Golang language server
in Guix!
--
… ??? ????? - ???????????? ?????????????? ?????? ??????? ????????
????? ????? ????? ? ??? ??????, ??????????? ????? ???????, ??
?????????? ?? ? ????????? ??????? ????? ? ?????????????????.
(
CM57XGB70ZOQ.33F0LNC8TD8B1@guix-aspire
On Sat Aug 13, 2022 at 3:25 PM BST, Sharlatan Hellseher wrote:
Toggle quote (5 lines)
> Is there any objection to accept this package?
> It's a part of inputs for Golang language server
> https://pkg.go.dev/golang.org/x/tools/gopls which would nice to have
> in Guix!

Huh? I've been able to package gopls without it: https://issues.guix.gnu.org/56908.

-- (
V
V
Vagrant Cascadian wrote on 1 Sep 2023 23:58
Re: [bug#52915] [PATCH] gnu: Add go-github-com-mvdan-gofumpt.
87h6odsgid.fsf@wireframe
On 2021-12-31, Philip Kaludercic wrote:
Toggle quote (11 lines)
> +(define-public go-github-com-mvdan-gofumpt
> + (package
> + (name "go-github-com-mvdan-gofumpt")
> + (version "0.2.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/mvdan/gofumpt")
> + (commit (string-append "v" version))))

This appears to have been packaged as gofumpt and go-mvdan-cc-gofumpt:

3b223b8e915c437215f8770649eb506af03f839d gnu: Add go-mvdan-cc-gofumpt.
15330b625ae928d6b94b5dc4515fa65e7e192cc1 gnu: Add gofumpt.

Marking as done.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZPJeawAKCRDcUY/If5cW
qpe1AQDxyDlXtCCpvcii62sR4Izr892FYDK2QDxgPNxEcUzNQgD/ZjGnOvYVikkB
ucU8LZRfSDuJOUD19SLnNWhnbhfpdQI=
=hFDI
-----END PGP SIGNATURE-----

Closed
?