[PATCH] gnu: Add myrddin.

  • Done
  • quality assurance status badge
Details
3 participants
  • jgart
  • Nicolas Goaziou
  • Xinglu Chen
Owner
unassigned
Submitted by
jgart
Severity
normal
J
(address . guix-patches@gnu.org)
20211218201635.17995-1-jgart@dismail.de
From: Guix Together <jgart@dismail.de>

Hi Guixers,

This is one of the packages that we worked on in the packaging meetup today.

all best,

jgart

* gnu/local.mk (GNU_SYSTEM_MODULES): Add myrddin.scm.
* gnu/packages/myrddin.scm: New file.

Co-authored-by: jgart <jgart@dismail.de>
Co-authored-by: Jorge Acereda <jacereda@gmail.com>
Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name>
---
gnu/local.mk | 1 +
gnu/packages/myrddin.scm | 66 ++++++++++++++++++++++++++++++++++++++++
2 files changed, 67 insertions(+)
create mode 100644 gnu/packages/myrddin.scm

Toggle diff (86 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 76403bbdf9..7eb3eb3d33 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -411,6 +411,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/music.scm \
%D%/packages/musl.scm \
%D%/packages/mtools.scm \
+ %D%/packages/myrddin.scm \
%D%/packages/nano.scm \
%D%/packages/ncdu.scm \
%D%/packages/ncurses.scm \
diff --git a/gnu/packages/myrddin.scm b/gnu/packages/myrddin.scm
new file mode 100644
index 0000000000..0633fb4fb2
--- /dev/null
+++ b/gnu/packages/myrddin.scm
@@ -0,0 +1,66 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Guix Together <jgart@dismail.de>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages myrddin)
+ #:use-module (guix build-system gnu)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (gnu packages bison)
+ #:use-module (gnu packages pkg-config)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages))
+
+(define-public myrddin
+ (package
+ (name "myrddin")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/oridb/mc")
+ (commit (string-append "r" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0acqqz74ypmjvi1yqz7g1ymyk3mmkzwqgmdd3s7s287bdy4a72gc"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags
+ (list
+ (string-append "CC=" ,(cc-for-target))
+ (string-append "PREFIX=" %output))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'build
+ (lambda* (#:key make-flags #:allow-other-keys)
+ (apply invoke "make" "bootstrap" make-flags)
+ (apply invoke "make" make-flags))))))
+ (native-inputs
+ (list bison pkg-config))
+ (home-page "https://myrlang.org")
+ (synopsis "Systems language that is both powerful and fun to use")
+ (description
+"Myrddin is a systems language that is both powerful and fun to
+use. It aims for C like low level control, a lightweight high quality
+implementation, and features you may find familiar from languages like
+like rust and ocaml. This combination makes Myrddin suitable for anything
+ranging from desktop applications, to embedded systems and potentially
+even kernel development.")
+ (license license:expat)))
--
2.34.0
X
X
Xinglu Chen wrote on 23 Dec 2021 14:32
877dbvcuql.fsf@yoctocell.xyz
Hi,

jgart via schrieb am Samstag der 18. Dezember 2021 um 15:16 -05:

Toggle quote (8 lines)
> Hi Guixers,
>
> This is one of the packages that we worked on in the packaging meetup today.
>
> all best,
>
> jgart

This part should go under the “---” line, otherwise they will be part of
the commit message.

Toggle quote (21 lines)
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add myrddin.scm.
> * gnu/packages/myrddin.scm: New file.
>
> Co-authored-by: jgart <jgart@dismail.de>
> Co-authored-by: Jorge Acereda <jacereda@gmail.com>
> Co-authored-by: Raghav Gururajan <rg@raghavgururajan.name>
> ---
> gnu/local.mk | 1 +
> gnu/packages/myrddin.scm | 66 ++++++++++++++++++++++++++++++++++++++++
> 2 files changed, 67 insertions(+)
> create mode 100644 gnu/packages/myrddin.scm
>
> diff --git a/gnu/packages/myrddin.scm b/gnu/packages/myrddin.scm
> new file mode 100644
> index 0000000000..0633fb4fb2
> --- /dev/null
> +++ b/gnu/packages/myrddin.scm
> @@ -0,0 +1,66 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2021 Guix Together <jgart@dismail.de>

I am not a laywer, but is “Guix Together” a legal entity? It’s probably
better to put the authors’ names here instead.

Toggle quote (46 lines)
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu packages myrddin)
> + #:use-module (guix build-system gnu)
> + #:use-module (guix utils)
> + #:use-module (guix download)
> + #:use-module (guix git-download)
> + #:use-module (gnu packages bison)
> + #:use-module (gnu packages pkg-config)
> + #:use-module ((guix licenses) #:prefix license:)
> + #:use-module (guix packages))
> +
> +(define-public myrddin
> + (package
> + (name "myrddin")
> + (version "0.3.1")
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/oridb/mc")
> + (commit (string-append "r" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0acqqz74ypmjvi1yqz7g1ymyk3mmkzwqgmdd3s7s287bdy4a72gc"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:make-flags
> + (list
> + (string-append "CC=" ,(cc-for-target))
> + (string-append "PREFIX=" %output))

Nitpick: The new Gexp style could be used instead.

Toggle snippet (12 lines)
(list
#:make-flags
#~(list (string-append "CC=" #$(cc-for-target))
(string-append "PREFIX=" #$output))
#:phases
'(modify-phases %standard-phases
(replace 'build
(lambda* (#:key make-flags #:allow-other-keys)
(apply invoke "make" "bootstrap" make-flags)
(apply invoke "make" make-flags)))))

Toggle quote (7 lines)
> + #:phases
> + (modify-phases %standard-phases
> + (replace 'build
> + (lambda* (#:key make-flags #:allow-other-keys)
> + (apply invoke "make" "bootstrap" make-flags)
> + (apply invoke "make" make-flags))))))

The ‘parallel-build?’ flag should also be respected.

Toggle quote (5 lines)
> + (native-inputs
> + (list bison pkg-config))
> + (home-page "https://myrlang.org")
> + (synopsis "Systems language that is both powerful and fun to use")

This sounds like an advert; I suggest

“Programming language that aims for control and simplicity”
Toggle quote (4 lines)
> + (description
> +"Myrddin is a systems language that is both powerful and fun to
> +use. It aims for C like low level control, a lightweight high quality

Again, “fun” is probably not the best word. “high quality” is
subjective and as a user, it doesn’t really tell me anything.

Toggle quote (3 lines)
> +implementation, and features you may find familiar from languages like
> +like rust and ocaml. This combination makes Myrddin suitable for anything

Capitalize “Rust” and “OCaml”.

Package builds fine!

Toggle snippet (6 lines)
Result of running `guix review 20211218201635.17995-1-jgart@dismail.de': (still a WIP)

Successfully built 1 out of 1 package(s).

No lint warnings were emitted.
-----BEGIN PGP SIGNATURE-----

iQJJBAEBCAAzFiEEAVhh4yyK5+SEykIzrPUJmaL7XHkFAmHEemIVHHB1YmxpY0B5
b2N0b2NlbGwueHl6AAoJEKz1CZmi+1x5//0P/37cLn3BnDEiHSHcxSWgZKnEv09G
ONlWzLUT4rv9X7k49LD1fO59nVzHMw4VZYTWxBs6uoaATTBZ3d/rzRAcPh7e4Bev
5H2vviQSRyEtLQ/1caA5jLfrRzHan9wHXNC7ldG55L5PVZE533JGUqst1q5Z6XR/
CyI9t4fOsSFlOtsMyWQ2Srn0fsvQUOZNHGM9Q6/0j9AAz05JJLEm9GuFtT3DgU4l
WQNCLOmc5I1uK01nhdyeIq+AhgR5YezSurVZwMibFsio1M4GGg4UZPI/Klka0CD/
XX9kdQfbTFhYsFM0EscaRpT4wtTuEFrI+erm7Xt2aAHGVaSOZm6A0/kQ+m64VdYk
nTNLF1KLBD7WLh/1crgzoqIdPavRPD3ZaeCiJpgcGBesgDhlm1gjksnykblVC+LZ
OFg66B79TTd88LOQdDd2IqbA7CB5x0BeSXB7MIeT8pImc2DGQ8AogyN7EjDx6hLm
8JkNb8oMjMTQZ+6AEfhUERi9Fm+wBf0Z3M0GRCaW/btEtaIwZFna8zrA2ElqUOEp
JP+OtsX3F935krW+jPJrpcGafMtcyOGsqK2hq+PAIg18cHBihWI4LBVIkW8gtGrC
suKEmfuQedXVcKMuNoYOxnopnUJxx94lKD808mqtQE3+ttsfuaLdgNx1oCYxkPKh
SpCTOmunu7KhdlSX
=TUhT
-----END PGP SIGNATURE-----

N
N
Nicolas Goaziou wrote on 14 Jan 2022 22:17
(name . jgart via Guix-patches via)(address . guix-patches@gnu.org)
87lezi2f0h.fsf@nicolasgoaziou.fr
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (2 lines)
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add myrddin.scm.
> * gnu/packages/myrddin.scm: New file.
I gexp-ified the package definition, tweaked the synopsis and
description, and applied your patch.

Thanks.

Regards,
--
Nicolas Goaziou
J
(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
20220114162624.GB31787@gac.attlocal.net
On Fri, 14 Jan 2022 22:17:50 +0100 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
Toggle quote (15 lines)
> Hello,
>
> jgart via Guix-patches via <guix-patches@gnu.org> writes:
>
> > * gnu/local.mk (GNU_SYSTEM_MODULES): Add myrddin.scm.
> > * gnu/packages/myrddin.scm: New file.
> I gexp-ified the package definition, tweaked the synopsis and
> description, and applied your patch.
>
> Thanks.
>
> Regards,
> --
> Nicolas Goaziou

Thank you so much!

I removed it from guixrus now:


all best,

jgart
?