[PATCH] gnu: Add python-unalix.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Maxim Cournoyer
Owner
unassigned
Submitted by
jgart
Severity
normal
J
J
jgart wrote on 1 Dec 2021 01:17
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20211201001738.25713-1-jgart@dismail.de
* gnu/packages/python-xyz.scm (python-unalix): New variable.
---
gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1693221ff0..989bd4b3b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -272,6 +272,37 @@ (define-public python-janus
design}.")
(license license:asl2.0)))
+(define-public python-unalix
+ (package
+ (name "python-unalix")
+ (version "0.9")
+ (source
+ (origin
+ ;; There's only a wheel on PyPI.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/AmanoTeam/Unalix")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0h8wc1axv26h753a8brc6dccqndx005c2bhr09gwg5c1hj9zsfml"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "python" "-m" "pytest")))))))
+ (home-page "https://pypi.org/project/Unalix/")
+ (synopsis "Python library for removing tracking fields from URLs")
+ (description
+"Unalix is a library written in Python, it implements the specification
+used by the ClearURLs addon for removing tracking fields from URLs.")
+ (license license:bsd-2)))
+
(define-public python-logbook
(package
(name "python-logbook")
--
2.34.0
M
M
Maxim Cournoyer wrote on 24 Feb 2022 05:11
(name . jgart)(address . jgart@dismail.de)(address . 52210-done@debbugs.gnu.org)
87k0dklx8y.fsf@gmail.com
Hi,

jgart <jgart@dismail.de> writes:

Toggle quote (45 lines)
> * gnu/packages/python-xyz.scm (python-unalix): New variable.
> ---
> gnu/packages/python-xyz.scm | 31 +++++++++++++++++++++++++++++++
> 1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 1693221ff0..989bd4b3b4 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -272,6 +272,37 @@ (define-public python-janus
> design}.")
> (license license:asl2.0)))
>
> +(define-public python-unalix
> + (package
> + (name "python-unalix")
> + (version "0.9")
> + (source
> + (origin
> + ;; There's only a wheel on PyPI.
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/AmanoTeam/Unalix")
> + (commit (string-append "v" version))))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32 "0h8wc1axv26h753a8brc6dccqndx005c2bhr09gwg5c1hj9zsfml"))))
> + (build-system python-build-system)
> + (native-inputs
> + `(("python-pytest" ,python-pytest)))
> + (arguments
> + '(#:phases
> + (modify-phases %standard-phases
> + (replace 'check
> + (lambda* (#:key tests? #:allow-other-keys)
> + (when tests?
> + (invoke "python" "-m" "pytest")))))))
> + (home-page "https://pypi.org/project/Unalix/")
> + (synopsis "Python library for removing tracking fields from URLs")
> + (description
> +"Unalix is a library written in Python, it implements the specification
> +used by the ClearURLs addon for removing tracking fields from URLs.")
> + (license license:bsd-2)))
> +

I've selected (gnu packages python-web) instead as its home, fixed some
light indentation problem with Emacs, used new style for the
native-inputs field, fixed the license (it's LGPL v3 or later, not
BSD-2), and pushed as 3609dcd200059dee96fedc02dedca2b352345757.

Thanks!

Closing.

Maxim
Closed
J
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 52210-done@debbugs.gnu.org)
20220224184247.GB21236@gac.attlocal.net
On Wed, 23 Feb 2022 23:11:25 -0500 Maxim Cournoyer <maxim.cournoyer@gmail.com> wrote:
Toggle quote (8 lines)
> Hi,
>
> jgart <jgart@dismail.de> writes:
> I've selected (gnu packages python-web) instead as its home, fixed some
> light indentation problem with Emacs, used new style for the
> native-inputs field, fixed the license (it's LGPL v3 or later, not
> BSD-2), and pushed as 3609dcd200059dee96fedc02dedca2b352345757.

Thank you for the review and fixes. Much appreciated!

all best,

jgart
Closed
?