[PATCH 0/1] Add n2p2-lib

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Mathieu Othacehe
  • zimoun
Owner
unassigned
Submitted by
zimoun
Severity
normal
Z
Z
zimoun wrote on 26 Nov 2021 14:08
(address . guix-patches@gnu.org)(name . zimoun)(address . zimon.toutoune@gmail.com)
20211126130824.361671-1-zimon.toutoune@gmail.com
Hi,

This adds n2p2-lib. It is an example from Café Guix.

Cheers,
simon


Pierre-Antoine Bouttier (1):
gnu: Add n2p2-lib.

gnu/packages/maths.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

--
2.33.1
M
M
Mathieu Othacehe wrote on 2 Dec 2021 15:46
(name . zimoun)(address . zimon.toutoune@gmail.com)(address . 52124@debbugs.gnu.org)
87a6hjvzco.fsf@gnu.org
Hello zimoun,

Toggle quote (2 lines)
> This adds n2p2-lib. It is an example from Café Guix.

The actual patch seems to be missing here.

Thanks,

Mathieu
Z
Z
zimoun wrote on 2 Dec 2021 16:54
(name . Mathieu Othacehe)(address . othacehe@gnu.org)(address . 52124@debbugs.gnu.org)
CAJ3okZ0Fv6+Sjfuf2c+uwFFp2wFh60ApsgK6RcbRFn96VdnWew@mail.gmail.com
Hi Mathieu,

On Thu, 2 Dec 2021 at 15:46, Mathieu Othacehe <othacehe@gnu.org> wrote:

Toggle quote (4 lines)
> > This adds n2p2-lib. It is an example from Café Guix.
>
> The actual patch seems to be missing here.

Thanks for noticing. I did a live demo at Café Guix [1] past friday
(2021-11-26) and I ran out of time to complete. I try to send ASAP.
:-)



Thanks,
simon
Z
Z
zimoun wrote on 6 Dec 2021 16:24
[PATCH] gnu: Add n2p2-lib.
(address . 52124@debbugs.gnu.org)
20211206152422.121776-1-zimon.toutoune@gmail.com
From: Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>

* gnu/packages/maths.scm (n2p2-lib): New variable.
---
gnu/packages/maths.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 55 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 83f31c1396..b08dc6fe67 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
+;;; Copyright © 2021 Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1753,6 +1754,60 @@ (define-public netcdf-fortran
(home-page (package-home-page netcdf))
(license (package-license netcdf))))
+(define-public n2p2-lib
+ (package
+ (name "n2p2-lib")
+ (version "2.1.4")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/CompPhysVienna/n2p2")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lw195ihpxwh08387i4gamk1glhalpq888q6nj8l5vswbgnrv1pq"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("MODE=shared" "-C" "src")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'post-unpack
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/makefile.gnu"
+ (("PROJECT_EIGEN=/usr/include/eigen3")
+ (string-append "PROJECT_EIGEN="
+ (assoc-ref inputs "eigen") "/include/eigen3")))
+ (substitute* "src/makefile.gnu"
+ (("-lblas")
+ (string-append "-L"
+ (assoc-ref inputs "openblas") "/lib -lopenblas")))))
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bindir (string-append out "/bin"))
+ (libdir (string-append out "/lib"))
+ (incdir (string-append out "/include")))
+ (for-each (lambda (f) (install-file f libdir))
+ (find-files "../lib/" "."))
+ (for-each (lambda (f) (install-file f incdir))
+ (find-files "../include/" "."))))))))
+ (inputs
+ `(("openmpi" ,openmpi)
+ ("gsl" ,gsl)
+ ("openblas" ,openblas)
+ ("eigen" ,eigen)))
+ (synopsis "Neural network potentials for chemistry and physics")
+ (description "This package contains software that will allow you to use
+existing neural network potential parameterizations to predict energies and
+forces (with standalone tools but also in conjunction with the MD software
+LAMMPS). In addition it is possible to train new neural network potentials
+with the provided training tools.")
+ (home-page "https://compphysvienna.github.io/n2p2")
+ (license license:gpl3)))
+
(define-public nlopt
(package
(name "nlopt")

base-commit: 9478a252509a93f3e7f486cbc549631185ba071d
--
2.33.1
Z
Z
zimoun wrote on 3 May 2022 14:38
Re: bug#52124: [PATCH 0/1] Add n2p2-lib
(address . 52124@debbugs.gnu.org)
86zgjyhjv5.fsf_-_@gmail.com
Hi,

On Mon, 06 Dec 2021 at 16:24, zimoun <zimon.toutoune@gmail.com> wrote:
Toggle quote (12 lines)
> From: Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>
>
> * gnu/packages/maths.scm (n2p2-lib): New variable.
> ---
> gnu/packages/maths.scm | 55 ++++++++++++++++++++++++++++++++++++++++++
> 1 file changed, 55 insertions(+)
>
> diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
> index 83f31c1396..b08dc6fe67 100644
> --- a/gnu/packages/maths.scm
> +++ b/gnu/packages/maths.scm

Friendly ping about this patch#52124 [1].



Cheers,
simon
L
L
Ludovic Courtès wrote on 5 May 2022 23:28
(name . zimoun)(address . zimon.toutoune@gmail.com)
87wnez654q.fsf_-_@gnu.org
Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

Toggle quote (4 lines)
> From: Pierre-Antoine Bouttier <pierre-antoine.bouttier@univ-grenoble-alpes.fr>
>
> * gnu/packages/maths.scm (n2p2-lib): New variable.

The ‘install’ phase was not installing anything, so I had to adjust it.
I also fixed a couple of other issues—patch below.

Finally applied, thanks!

Ludo’.
Toggle diff (62 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 613b52f5aa..efa453659c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1855,7 +1855,7 @@ (define-public netcdf-fortran
(define-public n2p2-lib
(package
- (name "n2p2-lib")
+ (name "n2p2")
(version "2.1.4")
(source (origin
(method git-fetch)
@@ -1879,8 +1879,13 @@ (define-public n2p2-lib
(assoc-ref inputs "eigen") "/include/eigen3")))
(substitute* "src/makefile.gnu"
(("-lblas")
- (string-append "-L"
- (assoc-ref inputs "openblas") "/lib -lopenblas")))))
+ (string-append "-L" (assoc-ref inputs "openblas")
+ "/lib -lopenblas"))
+ (("-march=native")
+ ""))
+ (substitute* "src/application/makefile"
+ (("LDFLAGS=")
+ "LDFLAGS=-Wl,-rpath='$$ORIGIN/../lib' "))))
(delete 'configure)
(delete 'check)
(replace 'install
@@ -1889,23 +1894,23 @@ (define-public n2p2-lib
(bindir (string-append out "/bin"))
(libdir (string-append out "/lib"))
(incdir (string-append out "/include")))
+ (for-each (lambda (f) (install-file f bindir))
+ (find-files "bin" "^nnp-"))
(for-each (lambda (f) (install-file f libdir))
- (find-files "../lib/" "."))
+ (find-files "lib" "\\.so$"))
(for-each (lambda (f) (install-file f incdir))
- (find-files "../include/" "."))))))))
+ (find-files "include" "\\.h$"))))))))
(inputs
- `(("openmpi" ,openmpi)
- ("gsl" ,gsl)
- ("openblas" ,openblas)
- ("eigen" ,eigen)))
+ (list openmpi gsl openblas eigen))
(synopsis "Neural network potentials for chemistry and physics")
(description "This package contains software that will allow you to use
existing neural network potential parameterizations to predict energies and
forces (with standalone tools but also in conjunction with the MD software
-LAMMPS). In addition it is possible to train new neural network potentials
+LAMMPS). In addition it is possible to train new neural network potentials
with the provided training tools.")
- (home-page "https://compphysvienna.github.io/n2p2")
- (license license:gpl3)))
+ (home-page "https://compphysvienna.github.io/n2p2/")
+ (properties '((tunable? . #t))) ;to benefit from SIMD code in Eigen
+ (license license:gpl3+)))
(define-public nlopt
(package
Closed
Z
Z
zimoun wrote on 6 May 2022 10:30
(name . Ludovic Courtès)(address . ludo@gnu.org)
CAJ3okZ36FSZnNO3N8oEwJUnuLNkuq58PXuDS1EKEwTvytM1OLg@mail.gmail.com
Hi,

On Thu, 5 May 2022 at 23:28, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (3 lines)
> The ‘install’ phase was not installing anything, so I had to adjust it.
> I also fixed a couple of other issues—patch below.

Thanks. Sorry to not have catched the errors beforehand.


Cheers,
simon
Closed
?